aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-05-26 16:50:35 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-05-26 16:50:35 +0800
commit454dc20845513b41b56e2596188b4c4135c7b5a2 (patch)
treeda2d18c00c2cd5edbeb9687db13da17f312d05d6
parenta8be24938028c27a8f3effa03112d015561ead33 (diff)
downloadfreebsd-ports-gnome-454dc20845513b41b56e2596188b4c4135c7b5a2.tar.gz
freebsd-ports-gnome-454dc20845513b41b56e2596188b4c4135c7b5a2.tar.zst
freebsd-ports-gnome-454dc20845513b41b56e2596188b4c4135c7b5a2.zip
Monoceros is PSGI/Plack server supports HTTP/1.1. Monoceros has a
event-driven connection manager and preforking workers. Monoceros can keep large amount of connection at minimal processes. WWW: http://search.cpan.org/dist/Monoceros/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Monoceros/Makefile28
-rw-r--r--www/p5-Monoceros/distinfo2
-rw-r--r--www/p5-Monoceros/pkg-descr5
-rw-r--r--www/p5-Monoceros/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5a80b525ac2b..04b9bb1460d4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1078,6 +1078,7 @@
SUBDIR += p5-Mojolicious-Plugin-Database
SUBDIR += p5-Mojolicious-Plugin-Mongodb
SUBDIR += p5-Mojolicious-Plugin-YamlConfig
+ SUBDIR += p5-Monoceros
SUBDIR += p5-Mozilla-CA
SUBDIR += p5-Net-Akismet
SUBDIR += p5-Net-Amazon-AWIS
diff --git a/www/p5-Monoceros/Makefile b/www/p5-Monoceros/Makefile
new file mode 100644
index 000000000000..6bc72d7343dc
--- /dev/null
+++ b/www/p5-Monoceros/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= Monoceros
+PORTVERSION= 0.15
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:KAZEBURO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= PSGI/Plack server w/ event driven connection manager, prefork workers
+
+RUN_DEPENDS= \
+ p5-AnyEvent>=7.04:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-IO-FDPass>=1.0:${PORTSDIR}/devel/p5-IO-FDPass \
+ p5-Net-CIDR-Lite>0:${PORTSDIR}/net/p5-Net-CIDR-Lite \
+ p5-Plack>=1.0023:${PORTSDIR}/www/p5-Plack \
+ p5-Starlet>=0.18:${PORTSDIR}/www/p5-Starlet
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP
+
+PERL_MODBUILD= yes
+
+MAN3= Monoceros.3 \
+ Plack::Middleware::MonocerosStatus.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Monoceros/distinfo b/www/p5-Monoceros/distinfo
new file mode 100644
index 000000000000..85f36d86bb68
--- /dev/null
+++ b/www/p5-Monoceros/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Monoceros-0.15.tar.gz) = deea960a00f0da001a18e7e58eb1ade64ebaf61eab0bc284ee03a1dabd2d8399
+SIZE (Monoceros-0.15.tar.gz) = 20876
diff --git a/www/p5-Monoceros/pkg-descr b/www/p5-Monoceros/pkg-descr
new file mode 100644
index 000000000000..e67ea9ed2594
--- /dev/null
+++ b/www/p5-Monoceros/pkg-descr
@@ -0,0 +1,5 @@
+Monoceros is PSGI/Plack server supports HTTP/1.1. Monoceros has a
+event-driven connection manager and preforking workers. Monoceros can
+keep large amount of connection at minimal processes.
+
+WWW: http://search.cpan.org/dist/Monoceros/
diff --git a/www/p5-Monoceros/pkg-plist b/www/p5-Monoceros/pkg-plist
new file mode 100644
index 000000000000..80c9cfba07a8
--- /dev/null
+++ b/www/p5-Monoceros/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Monoceros.pm
+%%SITE_PERL%%/Monoceros/Server.pm
+%%SITE_PERL%%/Plack/Handler/Monoceros.pm
+%%SITE_PERL%%/Plack/Middleware/MonocerosStatus.pm
+@dirrm %%SITE_PERL%%/Monoceros