aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-04-01 19:57:25 +0800
committeredwin <edwin@FreeBSD.org>2006-04-01 19:57:25 +0800
commit45dcf3eca69ffa0f73ea26f79d1199c4e836bbd7 (patch)
tree5d10ee815489ad877097bd7a9e8d9566a6cff52b
parent3b2a6e364ada6223a4029d3e60e6c0e4f37c1d9b (diff)
downloadfreebsd-ports-gnome-45dcf3eca69ffa0f73ea26f79d1199c4e836bbd7.tar.gz
freebsd-ports-gnome-45dcf3eca69ffa0f73ea26f79d1199c4e836bbd7.tar.zst
freebsd-ports-gnome-45dcf3eca69ffa0f73ea26f79d1199c4e836bbd7.zip
Use SUB_FILES
-rw-r--r--databases/postgresql-relay/Makefile10
-rw-r--r--databases/postgresql-relay/files/postgresql-relay.sh.in (renamed from databases/postgresql-relay/files/postgresql-relay.sh)2
-rw-r--r--mail/p3scan/Makefile4
-rw-r--r--mail/p3scan/files/pkg-message.in (renamed from mail/p3scan/pkg-message)6
4 files changed, 8 insertions, 14 deletions
diff --git a/databases/postgresql-relay/Makefile b/databases/postgresql-relay/Makefile
index b4bb5fe3cda7..21ceb78cfe57 100644
--- a/databases/postgresql-relay/Makefile
+++ b/databases/postgresql-relay/Makefile
@@ -21,15 +21,7 @@ PLIST_FILES= bin/postgresql-relay \
USE_REINPLACE= yes
USE_RC_SUBR= yes
USE_PERL5_BUILD=yes
-
-post-extract:
- ${CP} ${FILESDIR}/postgresql-relay.sh ${WRKDIR}
-
-post-patch:
- ${REINPLACE_CMD} \
- -e 's,%%PREFIX%%,${PREFIX},g' \
- -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
- ${WRKDIR}/postgresql-relay.sh
+SUB_FILES= postgresql-relay.sh
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/postgresql-relay ${PREFIX}/bin
diff --git a/databases/postgresql-relay/files/postgresql-relay.sh b/databases/postgresql-relay/files/postgresql-relay.sh.in
index 926c685e54e4..67a2ca128d88 100644
--- a/databases/postgresql-relay/files/postgresql-relay.sh
+++ b/databases/postgresql-relay/files/postgresql-relay.sh.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/databases/postgresql-relay/files/Attic/postgresql-relay.sh.in,v 1.1 2006-04-01 11:57:25 edwin Exp $
#
# PROVIDE: postgresql-relay
diff --git a/mail/p3scan/Makefile b/mail/p3scan/Makefile
index 14042f17ecef..723539d48205 100644
--- a/mail/p3scan/Makefile
+++ b/mail/p3scan/Makefile
@@ -20,6 +20,8 @@ USE_GMAKE= yes
USE_GETOPT_LONG=yes
MAKE_ENV= _LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" GMAKE=${GMAKE}
SCRIPTS_ENV= PKG_PREFIX=${PREFIX} NONEXISTENT=${NONEXISTENT} PASSWD=/etc/passwd
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= UVSCAN "Use UVSCAN" on
@@ -51,6 +53,6 @@ do-install:
post-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${SED} -e 's,PREFIX,${PREFIX},g' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/mail/p3scan/pkg-message b/mail/p3scan/files/pkg-message.in
index 442fe457c9ae..1ecf5eea932f 100644
--- a/mail/p3scan/pkg-message
+++ b/mail/p3scan/files/pkg-message.in
@@ -1,11 +1,11 @@
**********************************************************************
By default, P3Scan is configured to work with McAfee UVSCAN.
-Please copy PREFIX/etc/p3scan.conf.sample to p3scan.conf and modify
-PREFIX/etc/p3scan.conf and/or PREFIX/etc/rc.d/p3scan.sh to
+Please copy %%PREFIX%%/etc/p3scan.conf.sample to p3scan.conf and modify
+%%PREFIX%%/etc/p3scan.conf and/or %%PREFIX%%/etc/rc.d/p3scan.sh to
fit your environment.
-Don't forget to copy PREFIX/etc/p3scan.mail.sample to p3scan.mail
+Don't forget to copy %%PREFIX%%/etc/p3scan.mail.sample to p3scan.mail
and edit your own template for virus notifications.
By the way, you need to enable IPFIREWALL and IPFIREWALL_FORWARD options