aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2005-10-23 07:38:48 +0800
committernobutaka <nobutaka@FreeBSD.org>2005-10-23 07:38:48 +0800
commit45fc6323b15f528bc671eab90737ba89f1165325 (patch)
tree5a0d249d1ec37cfa65918830bc5ef7a20ba949a5
parent5e8052ddf625cbd12176f0d87da335bf0b0ed002 (diff)
downloadfreebsd-ports-gnome-45fc6323b15f528bc671eab90737ba89f1165325.tar.gz
freebsd-ports-gnome-45fc6323b15f528bc671eab90737ba89f1165325.tar.zst
freebsd-ports-gnome-45fc6323b15f528bc671eab90737ba89f1165325.zip
Rename WITH_LIBTHEORA and WITH_LIBCACA knobs to WITH_THEORA and WITH_CACA.
PR: ports/87374 Submitted by: Zahemszky Gabor <gabor@zahemszky.hu>
-rw-r--r--multimedia/libxine/Makefile24
-rw-r--r--multimedia/libxine/pkg-plist4
2 files changed, 14 insertions, 14 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 65ac4925b146..2b4dee4718e3 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -75,11 +75,11 @@ PLIST_SUB+= WITH_ARTS=""
PLIST_SUB+= WITH_ARTS="@comment "
.endif
-.if !defined(WITHOUT_LIBCACA) && (exists(${LOCALBASE}/lib/libcaca.a) || defined(WITH_LIBCACA))
+.if !defined(WITHOUT_CACA) && (exists(${LOCALBASE}/lib/libcaca.a) || defined(WITH_CACA))
BUILD_DEPENDS+= caca-config:${PORTSDIR}/graphics/libcaca
-PLIST_SUB+= WITH_LIBCACA=""
+PLIST_SUB+= WITH_CACA=""
.else
-PLIST_SUB+= WITH_LIBCACA="@comment "
+PLIST_SUB+= WITH_CACA="@comment "
.endif
.if !defined(WITHOUT_ESOUND) && (${HAVE_GNOME:Mesound} != "" || defined(WITH_ESOUND))
@@ -117,11 +117,11 @@ PLIST_SUB+= WITH_XVMC=""
PLIST_SUB+= WITH_XVMC="@comment "
.endif
-.if !defined(WITHOUT_LIBTHEORA) && (exists(${LOCALBASE}/lib/libtheora.so.1) || defined (WITH_LIBTHEORA))
+.if !defined(WITHOUT_THEORA) && (exists(${LOCALBASE}/lib/libtheora.so.1) || defined (WITH_THEORA))
LIB_DEPENDS+= theora.1:${PORTSDIR}/multimedia/libtheora
-PLIST_SUB+= WITH_LIBTHEORA=""
+PLIST_SUB+= WITH_THEORA=""
.else
-PLIST_SUB+= WITH_LIBTHEORA="@comment "
+PLIST_SUB+= WITH_THEORA="@comment "
.endif
.if !defined(WITHOUT_SMB) && (exists(${LOCALBASE}/lib/libsmbclient.so.0) || defined (WITH_SMB))
@@ -140,10 +140,10 @@ pre-everything::
.else
@${ECHO_MSG} "===> WITH_ARTS (arts support, enabled)"
.endif
-.if !exists(${LOCALBASE}/lib/libcaca.a) && !defined(WITH_LIBCACA)
- @${ECHO_MSG} "===> WITH_LIBCACA (libcaca support)"
+.if !exists(${LOCALBASE}/lib/libcaca.a) && !defined(WITH_CACA)
+ @${ECHO_MSG} "===> WITH_CACA (libcaca support)"
.else
- @${ECHO_MSG} "===> WITH_LIBCACA (libcaca support, enabled)"
+ @${ECHO_MSG} "===> WITH_CACA (libcaca support, enabled)"
.endif
.if !(${HAVE_GNOME:Mgnomevfs2} != "") && !defined(WITH_GNOMEVFS2)
@${ECHO_MSG} "===> WITH_GNOMEVFS2 (gnomevfs2 support)"
@@ -165,10 +165,10 @@ pre-everything::
.else
@${ECHO_MSG} "===> WITH_SMB (SMB support, enabled)"
.endif
-.if !exists(${LOCALBASE}/lib/libtheora.so.1) && !defined(WITH_LIBTHEORA)
- @${ECHO_MSG} "===> WITH_LIBTHEORA (libtheora support)"
+.if !exists(${LOCALBASE}/lib/libtheora.so.1) && !defined(WITH_THEORA)
+ @${ECHO_MSG} "===> WITH_THEORA (libtheora support)"
.else
- @${ECHO_MSG} "===> WITH_LIBTHEORA (libtheora support, enabled)"
+ @${ECHO_MSG} "===> WITH_THEORA (libtheora support, enabled)"
.endif
.if !exists(${X11BASE}/lib/libXvMCNVIDIA.so.1) && !defined(WITH_XVMC)
@${ECHO_MSG} "===> WITH_XVMC (XvMC support)"
diff --git a/multimedia/libxine/pkg-plist b/multimedia/libxine/pkg-plist
index cc37059ea138..775a31e07939 100644
--- a/multimedia/libxine/pkg-plist
+++ b/multimedia/libxine/pkg-plist
@@ -82,8 +82,8 @@ lib/xine/plugins/1.1.0/xineplug_decode_spucc.so
lib/xine/plugins/1.1.0/xineplug_decode_spucmml.so
lib/xine/plugins/1.1.0/xineplug_decode_spudvb.so
lib/xine/plugins/1.1.0/xineplug_decode_sputext.so
-%%WITH_LIBTHEORA%%lib/xine/plugins/1.1.0/xineplug_decode_theora.so
-%%WITH_LIBCACA%%lib/xine/plugins/1.1.0/xineplug_vo_out_caca.so
+%%WITH_THEORA%%lib/xine/plugins/1.1.0/xineplug_decode_theora.so
+%%WITH_CACA%%lib/xine/plugins/1.1.0/xineplug_vo_out_caca.so
lib/xine/plugins/1.1.0/xineplug_decode_vorbis.so
%%WITH_VIDIX%%lib/xine/plugins/1.1.0/xineplug_decode_w32dll.so
lib/xine/plugins/1.1.0/xineplug_decode_yuv.so