aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-02-01 15:56:38 +0800
committervanilla <vanilla@FreeBSD.org>2013-02-01 15:56:38 +0800
commit4744eb2ed78141ed20defaaddba3438f5b23f4bb (patch)
treeb075070c24de9976f38a4ab64018cdd59c929106
parenta094ec132e112c5412cf60e3ef3ecf548c07a981 (diff)
downloadfreebsd-ports-gnome-4744eb2ed78141ed20defaaddba3438f5b23f4bb.tar.gz
freebsd-ports-gnome-4744eb2ed78141ed20defaaddba3438f5b23f4bb.tar.zst
freebsd-ports-gnome-4744eb2ed78141ed20defaaddba3438f5b23f4bb.zip
Add pecl-solr 1.0.2, the Apache Solr PHP extension.
PR: ports/173574 Submitted by: Hung-Yi Chen <gaod@hychen.org>
-rw-r--r--www/Makefile1
-rw-r--r--www/pecl-solr/Makefile20
-rw-r--r--www/pecl-solr/distinfo2
-rw-r--r--www/pecl-solr/files/patch-config.m436
-rw-r--r--www/pecl-solr/files/patch-php_solr.c11
-rw-r--r--www/pecl-solr/pkg-descr6
6 files changed, 76 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 933b4373856d..ad4c08c4f601 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1383,6 +1383,7 @@
SUBDIR += pecl-APC
SUBDIR += pecl-amfext
SUBDIR += pecl-http
+ SUBDIR += pecl-solr
SUBDIR += pecl-sphinx
SUBDIR += pecl-swish
SUBDIR += pecl-yaf
diff --git a/www/pecl-solr/Makefile b/www/pecl-solr/Makefile
new file mode 100644
index 000000000000..6166b96cf089
--- /dev/null
+++ b/www/pecl-solr/Makefile
@@ -0,0 +1,20 @@
+# Created by: Hung-Yi Chen <gaod@hychen.org>
+# $FreeBSD$
+
+PORTNAME= solr
+PORTVERSION= 1.0.2
+CATEGORIES= www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gaod@hychen.org
+COMMENT= The Apache Solr PHP extension
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ xml2:${PORTSDIR}/textproc/libxml2
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/www/pecl-solr/distinfo b/www/pecl-solr/distinfo
new file mode 100644
index 000000000000..28936115d99c
--- /dev/null
+++ b/www/pecl-solr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (solr-1.0.2.tgz) = d5868daab01290f820b4b754e3c560dc6e983f82d9f6640b3146cede4d9a8581
+SIZE (solr-1.0.2.tgz) = 101292
diff --git a/www/pecl-solr/files/patch-config.m4 b/www/pecl-solr/files/patch-config.m4
new file mode 100644
index 000000000000..0254417537ea
--- /dev/null
+++ b/www/pecl-solr/files/patch-config.m4
@@ -0,0 +1,36 @@
+--- config.m4.orig 2011-11-29 10:49:53.000000000 +0800
++++ config.m4 2013-01-27 23:53:10.000000000 +0800
+@@ -56,8 +56,8 @@ else
+ fi
+
+ PHP_ADD_INCLUDE($CURL_DIR/include)
+-PHP_EVAL_LIBLINE($CURL_LIBS, CURL_SHARED_LIBADD)
+-PHP_ADD_LIBRARY_WITH_PATH(curl, $CURL_DIR/$PHP_LIBDIR, CURL_SHARED_LIBADD)
++PHP_EVAL_LIBLINE($CURL_LIBS, SOLR_SHARED_LIBADD)
++PHP_ADD_LIBRARY_WITH_PATH(curl, $CURL_DIR/$PHP_LIBDIR, SOLR_SHARED_LIBADD)
+
+ PHP_ARG_ENABLE(solr, whether to enable the Solr extension,
+ [ --enable-solr Enable solr support])
+@@ -72,11 +72,11 @@ dnl Setting up the apache Solr extension
+ if test "$PHP_SOLR" != "no"; then
+
+ if test "$PHP_CURL" = "no"; then
+- AC_MSG_ERROR([SOAP extension requires curl extension, add --with-curl])
++ AC_MSG_ERROR([SOLR extension requires curl extension, add --with-curl])
+ fi
+
+ if test "$PHP_LIBXML" = "no"; then
+- AC_MSG_ERROR([SOAP extension requires LIBXML extension, add --enable-libxml])
++ AC_MSG_ERROR([SOLR extension requires LIBXML extension, add --enable-libxml])
+ fi
+
+ PHP_SETUP_LIBXML(SOLR_SHARED_LIBADD, [
+@@ -100,7 +100,7 @@ if test "$PHP_SOLR" != "no"; then
+ solr_functions_response.c \
+ solr_functions_debug.c],
+ $ext_shared)
+- PHP_SUBST(SOAP_SHARED_LIBADD)
++ PHP_SUBST(SOLR_SHARED_LIBADD)
+ ], [
+ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
+ ])
diff --git a/www/pecl-solr/files/patch-php_solr.c b/www/pecl-solr/files/patch-php_solr.c
new file mode 100644
index 000000000000..48a84f539fa1
--- /dev/null
+++ b/www/pecl-solr/files/patch-php_solr.c
@@ -0,0 +1,11 @@
+--- php_solr.c.orig 2013-01-28 00:00:42.000000000 +0800
++++ php_solr.c 2013-01-28 00:00:54.000000000 +0800
+@@ -879,8 +879,6 @@ static zend_function_entry solr_utils_me
+
+ /* {{{ solr_module_deps */
+ static zend_module_dep solr_module_deps[] = {
+- ZEND_MOD_REQUIRED(PHP_CURL_EXTENSION_NAME)
+- ZEND_MOD_REQUIRED(PHP_LIBXML_EXTENSION_NAME)
+
+ { NULL, NULL, NULL }
+ };
diff --git a/www/pecl-solr/pkg-descr b/www/pecl-solr/pkg-descr
new file mode 100644
index 000000000000..9391794389b5
--- /dev/null
+++ b/www/pecl-solr/pkg-descr
@@ -0,0 +1,6 @@
+The Apache Solr PHP extension is an extremely fast,
+light-weight, feature-rich library that allows PHP
+applications to communicate easily and efficiently
+with Apache Solr server instances using an object-oriented API.
+
+WWW: http://pecl.php.net/package/solr/