aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-31 18:05:26 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-31 18:05:26 +0800
commit4782ae53b389d6e552dfcff82ebe2b2cf840fb3d (patch)
tree1079ea9fecdb0a1dda86419b2b50f9eb0b152977
parent96fd0b7b9f6a9a766c855c6af726833d93bccb74 (diff)
downloadfreebsd-ports-gnome-4782ae53b389d6e552dfcff82ebe2b2cf840fb3d.tar.gz
freebsd-ports-gnome-4782ae53b389d6e552dfcff82ebe2b2cf840fb3d.tar.zst
freebsd-ports-gnome-4782ae53b389d6e552dfcff82ebe2b2cf840fb3d.zip
- Remove unnecessary MASTER_SITE_SUBDIR
- Add BUILD_DEPENDS - Update *_DEPENDS - Sort PLIST - Reformat pkg-descr
-rw-r--r--graphics/p5-Image-Magick-Iterator/Makefile8
-rw-r--r--graphics/p5-Image-Magick-Iterator/pkg-descr17
-rw-r--r--graphics/p5-Image-Magick-Iterator/pkg-plist10
3 files changed, 17 insertions, 18 deletions
diff --git a/graphics/p5-Image-Magick-Iterator/Makefile b/graphics/p5-Image-Magick-Iterator/Makefile
index 3ae5f512b68e..9ab05cb3511e 100644
--- a/graphics/p5-Image-Magick-Iterator/Makefile
+++ b/graphics/p5-Image-Magick-Iterator/Makefile
@@ -6,16 +6,16 @@ PORTVERSION= 0.01
PORTREVISION= 4
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= Image
PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Sequentially read Image::Magick object from a filehandle
-RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
- p5-Image-PBMlib>=0:${PORTSDIR}/graphics/p5-Image-PBMlib
+BUILD_DEPENDS= ImageMagick>=0:${PORTSDIR}/graphics/ImageMagick \
+ p5-Image-PBMlib>=1.05:${PORTSDIR}/graphics/p5-Image-PBMlib
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
USE_PERL5= configure
+USES= perl5
.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Magick-Iterator/pkg-descr b/graphics/p5-Image-Magick-Iterator/pkg-descr
index 42cf14c4fa25..fd053530a131 100644
--- a/graphics/p5-Image-Magick-Iterator/pkg-descr
+++ b/graphics/p5-Image-Magick-Iterator/pkg-descr
@@ -1,12 +1,11 @@
-Image::Magick::Iterator adds iteration support to Image::Magick. This
-means that if you have a stream of concatenated images, you can access
-each image in the stream as an independent Image::Magick object.
+Image::Magick::Iterator adds iteration support to Image::Magick. This means that
+if you have a stream of concatenated images, you can access each image in the
+stream as an independent Image::Magick object.
-Iteration functionality is not present in Image::Magick itself as of
-version 5.56. Passing a stream of concatenated images would result in
-essentially a "stack" of images which would all be manipulated in
-parallel by any Image::Magick calls. Calls to Write() either output an
-animated series of image (a la animated GIFs), or the first image in
-the series.
+Iteration functionality is not present in Image::Magick itself as of version
+5.56. Passing a stream of concatenated images would result in essentially a
+"stack" of images which would all be manipulated in parallel by any
+Image::Magick calls. Calls to Write() either output an animated series of image
+(a la animated GIFs), or the first image in the series.
WWW: http://search.cpan.org/dist/Image-Magick-Iterator/
diff --git a/graphics/p5-Image-Magick-Iterator/pkg-plist b/graphics/p5-Image-Magick-Iterator/pkg-plist
index c55bfa3ae3f3..9d4788e43401 100644
--- a/graphics/p5-Image-Magick-Iterator/pkg-plist
+++ b/graphics/p5-Image-Magick-Iterator/pkg-plist
@@ -1,11 +1,11 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Magick/Iterator/.packlist
%%SITE_PERL%%/Image/Magick/Iterator.pm
%%SITE_PERL%%/Image/Magick/Iterator/PPM.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Magick/Iterator/.packlist
%%PERL5_MAN3%%/Image::Magick::Iterator.3.gz
%%PERL5_MAN3%%/Image::Magick::Iterator::PPM.3.gz
-@dirrmtry %%SITE_PERL%%/Image/Magick/Iterator
-@dirrmtry %%SITE_PERL%%/Image/Magick
-@dirrmtry %%SITE_PERL%%/Image
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Magick/Iterator
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Magick/Iterator
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Magick
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image
+@dirrm %%SITE_PERL%%/Image/Magick/Iterator
+@dirrmtry %%SITE_PERL%%/Image/Magick
+@dirrmtry %%SITE_PERL%%/Image