aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-03 23:25:16 +0800
committerantoine <antoine@FreeBSD.org>2014-09-03 23:25:16 +0800
commit4788f71c2f9a0f3adbedab601c5e24a096b8d8e2 (patch)
tree9e98737bc9c65b0875515b15b1a36e3052150a09
parent1d092234e89f2f2515bee50a7185d9633d5aaafb (diff)
downloadfreebsd-ports-gnome-4788f71c2f9a0f3adbedab601c5e24a096b8d8e2.tar.gz
freebsd-ports-gnome-4788f71c2f9a0f3adbedab601c5e24a096b8d8e2.tar.zst
freebsd-ports-gnome-4788f71c2f9a0f3adbedab601c5e24a096b8d8e2.zip
Fix packaging
-rw-r--r--astro/planets/Makefile8
-rw-r--r--astro/planets/pkg-plist5
-rw-r--r--devel/aifad/Makefile4
-rw-r--r--devel/aifad/pkg-plist16
-rw-r--r--ftp/ocaml-ocurl/Makefile1
-rw-r--r--ftp/ocaml-ocurl/pkg-plist1
6 files changed, 24 insertions, 11 deletions
diff --git a/astro/planets/Makefile b/astro/planets/Makefile
index 5dc7582666bb..7cdbdf70a531 100644
--- a/astro/planets/Makefile
+++ b/astro/planets/Makefile
@@ -20,15 +20,11 @@ ALL_TARGET= ${PORTNAME}
OPTIONS_DEFINE= DOCS
-PORTDOCS= KEYBINDINGS.txt getting_started.html
-PLIST_FILES= bin/planets man/man1/planets.1.gz
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/planets.1 ${STAGEDIR}${MANPREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/KEYBINDINGS.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/getting_started.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/astro/planets/pkg-plist b/astro/planets/pkg-plist
new file mode 100644
index 000000000000..9251ea31bf5d
--- /dev/null
+++ b/astro/planets/pkg-plist
@@ -0,0 +1,5 @@
+bin/planets
+man/man1/planets.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/KEYBINDINGS.txt
+%%PORTDOCS%%%%DOCSDIR%%/getting_started.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/devel/aifad/Makefile b/devel/aifad/Makefile
index d94ad1b4aeb9..d5c5f87e59d8 100644
--- a/devel/aifad/Makefile
+++ b/devel/aifad/Makefile
@@ -23,10 +23,6 @@ NO_OCAML_RUNDEPENDS=yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix ${STAGEDIR}${PREFIX}
-PORTDOCS= *
-PORTEXAMPLES= *
-PLIST_FILES= bin/${PORTNAME}
-
OPTIONS_DEFINE= DOCS EXAMPLES
post-install:
diff --git a/devel/aifad/pkg-plist b/devel/aifad/pkg-plist
new file mode 100644
index 000000000000..d81f0dcdcf47
--- /dev/null
+++ b/devel/aifad/pkg-plist
@@ -0,0 +1,16 @@
+bin/aifad
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/TODO.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/breast_cancer1.add
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/breast_cancer1.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/breast_cancer2.add
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/breast_cancer2.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c45.data
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c45.names
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/large.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.add
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.ads
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
diff --git a/ftp/ocaml-ocurl/Makefile b/ftp/ocaml-ocurl/Makefile
index bef0bdb2da9a..d3616c762e28 100644
--- a/ftp/ocaml-ocurl/Makefile
+++ b/ftp/ocaml-ocurl/Makefile
@@ -26,5 +26,6 @@ MAKE_JOBS_UNSAFE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
+OCAML_PKGDIRS= curl
.include <bsd.port.mk>
diff --git a/ftp/ocaml-ocurl/pkg-plist b/ftp/ocaml-ocurl/pkg-plist
index 11962ef45b0c..38d4eb2254a4 100644
--- a/ftp/ocaml-ocurl/pkg-plist
+++ b/ftp/ocaml-ocurl/pkg-plist
@@ -4,4 +4,3 @@
%%OCAML_SITELIBDIR%%/curl/curl.cmi
%%OCAML_SITELIBDIR%%/curl/curl.cmxa
%%OCAML_SITELIBDIR%%/curl/libcurl-helper.a
-@dirrm %%OCAML_SITELIBDIR%%/curl
d knobs to disable it or set theknu2000-06-051-4/+38 * make startup script work (start/stop)andreas2000-05-253-20/+26 * upgrade postgresql to v 7.0 releaseandreas2000-05-249-1018/+1150 * portlintmharo2000-04-202-4/+3 * Update to postgresql 7 beta 5andreas2000-04-184-272/+290 * Standardize all user defined options to the booleans WITH_FOO andreg2000-04-171-27/+21 * Close PRandreas2000-04-173-2/+173 * update with the new PORTNAME/PORTVERSION variablesmharo2000-04-091-2/+2 * Long awaited upgrade to postgresql 6.5.3andreas2000-01-032-2/+2 * remove toasted MASTER_SITEbillf1999-11-231-1/+0 * More reasonable MANPATHandreas1999-11-091-1/+1 * Update to version 6.5.2.cpiazza1999-10-118-22/+25 * FreeBSD.ORG -> FreeBSD.orgmharo1999-08-311-2/+2 * $Id$ -> $FreeBSD$peter1999-08-292-2/+2 * Change Id->FreeBSD.obrien1999-08-251-1/+1 * chmod -> ${CHMOD}mharo1999-08-231-4/+4 * Update postgresql to 6.5.1andreas1999-07-214-240/+253 * Forgot to add the two PLIST files... Sorry.andreas1999-07-022-0/+21 * These were missing as wellandreas1999-06-302-0/+22 * Forgot to add this patchandreas1999-06-301-0/+32 * upgrade to postgresql 6.5andreas1999-06-306-248/+899 * BROKEN='unfetchable, version 6.5 is the latest'obrien1999-06-271-1/+3 * As threatened, enforce the "Capital, no period" rule. Ellipses arehoek1999-06-271-1/+1 * This one doesn't build on the Alpha yet, but should soon.steve1999-06-231-1/+5 * Add some more MASTER_SITES which does absolutly nothing until someonebillf1999-06-191-4/+7 * s,/usr/local,${PREFIX},mharo1999-06-061-3/+3 * add another mastersitemharo1999-04-211-2/+4 * Move WWW_SITE to pkg/DESCR:WWW from Makefilescrappy1999-04-142-2/+3 * add a note, that in order to install and run postgresql, you need kernel withandreas1999-04-131-1/+3 * Proper URLs that reference directories end in '/'billf1999-04-091-2/+2 * Commit all Y2K/WWW_SITE changes to Makefiles...scrappy1999-03-121-1/+2 * Forgot the PLIST changes.steve1999-02-041-4/+27 * Fix build for ELF and update PLIST to match the current state of affairs.steve1999-02-041-0/+16 * Update from 6.4 to 6.4.2andreas1999-01-202-4/+3 * Add a Y2K= variable to Makefile pointing at Y2K statement for softwarescrappy1999-01-131-1/+3 * respect CFLAGS, not set it.billf1998-12-241-1/+8 * Fix bogon in previous commit by scrappy -- move ldconfig lines back toasami1998-12-221-2/+2 * Add PKGNAME without the "v" in version number.asami1998-11-241-1/+2 * Upgrade to PostgreSQL v6.4scrappy1998-11-233-44/+165 * Unbreak.jseger1998-10-163-11/+8 * Mark BROKEN for ELF:jseger1998-10-121-1/+3 * tcl80 has been ELFized.asami1998-09-251-2/+2 * Long live feminism! No manpages! Nyah-hah-hah!hoek1998-08-171-81/+0 * Andreas forgot to delete PATCH_DEBUG....asami1998-04-221-3/+2 * Upgrade postgresql to version 6.3.2andreas1998-04-224-77/+148 * Postgresql binary isn't fetchable, was removed from the master sites.andreas1998-03-231-3/+2 * Forgot cvs add for the previous commit.andreas1998-02-011-0/+69 * No need to use += on first appearance of variables.alex1997-12-241-3/+3 * Delete the database before installation if PACKAGE_BUILDING is definedasami1997-12-041-1/+4 * Remove bad MASTER_SITE and fix version required line.jseger1997-11-271-3/+2 * update to 6.2.1, possibly more committs to come (PLIST)andreas1997-10-302-3/+3 * a symlink was missingandreas1997-10-061-0/+1 * - remove the ampersand, postmaster process automatically goes intoandreas1997-10-062-5/+11 * Point to pgaccess in the post-installation notes.andreas1997-10-051-1/+4 * libpq and libpgtcl shared libs get both a major and minor release number.andreas1997-10-051-5/+5 * make pgaccess finally work ;-)andreas1997-10-051-2/+4 * make USE_TCL=yes compiles libpgtcl subdir which is neededandreas1997-10-052-2/+23 * forgot the backslashes in the script.andreas1997-10-041-3/+3 * Upgrade from version 6.1.1 to 6.2andreas1997-10-036-48/+121 * Upgrade from 6.1 to 6.1.1andreas1997-09-283-6/+4 * ldconfig -> ${LDCONFIG}.max1997-07-17