aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-08-21 13:09:21 +0800
committermarcus <marcus@FreeBSD.org>2004-08-21 13:09:21 +0800
commit47b01bb8e91fe89128d1f195628587d5b75a3634 (patch)
treea8443099278e04f61e451aa28dd33b9e96d30b20
parentcb83d718e67c5161c12c0800db71640097a802ad (diff)
downloadfreebsd-ports-gnome-47b01bb8e91fe89128d1f195628587d5b75a3634.tar.gz
freebsd-ports-gnome-47b01bb8e91fe89128d1f195628587d5b75a3634.tar.zst
freebsd-ports-gnome-47b01bb8e91fe89128d1f195628587d5b75a3634.zip
Properly pass environment variables to the command line. This fixes a
problem where the root password would also be reported as wrong if, for example, LANG was set in the environment.
-rw-r--r--sysutils/gnome-system-tools/Makefile1
-rw-r--r--sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c27
-rw-r--r--sysutils/gnomesystemtools/Makefile1
-rw-r--r--sysutils/gnomesystemtools/files/patch-src_common_gst-auth.c27
4 files changed, 56 insertions, 0 deletions
diff --git a/sysutils/gnome-system-tools/Makefile b/sysutils/gnome-system-tools/Makefile
index 127fd1c3f2c8..69241d508afd 100644
--- a/sysutils/gnome-system-tools/Makefile
+++ b/sysutils/gnome-system-tools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomesystemtools
PORTVERSION= 0.91.0
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-system-tools/0.91
diff --git a/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c b/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c
new file mode 100644
index 000000000000..7a5e54ecaaf6
--- /dev/null
+++ b/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c
@@ -0,0 +1,27 @@
+--- src/common/gst-auth.c.orig Sat Aug 21 01:01:33 2004
++++ src/common/gst-auth.c Sat Aug 21 01:06:24 2004
+@@ -300,6 +300,7 @@
+ lc_all = getenv ("LC_ALL");
+ lang = getenv ("LANG");
+
++#ifndef __FreeBSD__
+ if (lc_all)
+ g_string_append_printf (command, "export LC_ALL=\"%s\" && ", lc_all);
+ else if (lc_messages)
+@@ -308,6 +309,16 @@
+ g_string_append_printf (command, "export LANG=\"%s\" && ", lang);
+ else if (language)
+ g_string_append_printf (command, "export LANGUAGE=\"%s\" && ", language);
++#else
++ if (lc_all)
++ g_string_append_printf (command, "env LC_ALL=\"%s\" ", lc_all);
++ else if (lc_messages)
++ g_string_append_printf (command, "env LC_MESSAGES=\"%s\" ", lc_messages);
++ else if (lang)
++ g_string_append_printf (command, "env LANG=\"%s\" ", lang);
++ else if (language)
++ g_string_append_printf (command, "env LANGUAGE=\"%s\" ", language);
++#endif
+ }
+
+ void
diff --git a/sysutils/gnomesystemtools/Makefile b/sysutils/gnomesystemtools/Makefile
index 127fd1c3f2c8..69241d508afd 100644
--- a/sysutils/gnomesystemtools/Makefile
+++ b/sysutils/gnomesystemtools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomesystemtools
PORTVERSION= 0.91.0
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-system-tools/0.91
diff --git a/sysutils/gnomesystemtools/files/patch-src_common_gst-auth.c b/sysutils/gnomesystemtools/files/patch-src_common_gst-auth.c
new file mode 100644
index 000000000000..7a5e54ecaaf6
--- /dev/null
+++ b/sysutils/gnomesystemtools/files/patch-src_common_gst-auth.c
@@ -0,0 +1,27 @@
+--- src/common/gst-auth.c.orig Sat Aug 21 01:01:33 2004
++++ src/common/gst-auth.c Sat Aug 21 01:06:24 2004
+@@ -300,6 +300,7 @@
+ lc_all = getenv ("LC_ALL");
+ lang = getenv ("LANG");
+
++#ifndef __FreeBSD__
+ if (lc_all)
+ g_string_append_printf (command, "export LC_ALL=\"%s\" && ", lc_all);
+ else if (lc_messages)
+@@ -308,6 +309,16 @@
+ g_string_append_printf (command, "export LANG=\"%s\" && ", lang);
+ else if (language)
+ g_string_append_printf (command, "export LANGUAGE=\"%s\" && ", language);
++#else
++ if (lc_all)
++ g_string_append_printf (command, "env LC_ALL=\"%s\" ", lc_all);
++ else if (lc_messages)
++ g_string_append_printf (command, "env LC_MESSAGES=\"%s\" ", lc_messages);
++ else if (lang)
++ g_string_append_printf (command, "env LANG=\"%s\" ", lang);
++ else if (language)
++ g_string_append_printf (command, "env LANGUAGE=\"%s\" ", language);
++#endif
+ }
+
+ void