aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2005-08-31 11:13:57 +0800
committerkris <kris@FreeBSD.org>2005-08-31 11:13:57 +0800
commit47c44314dacb7ef070cac53294e1ee1d26bf55df (patch)
tree746d19703461d2f6038f0152a0a264c47431ca34
parent7df16db1f95ee6fa7d7d491ddddd8c5ab73f5c2d (diff)
downloadfreebsd-ports-gnome-47c44314dacb7ef070cac53294e1ee1d26bf55df.tar.gz
freebsd-ports-gnome-47c44314dacb7ef070cac53294e1ee1d26bf55df.tar.zst
freebsd-ports-gnome-47c44314dacb7ef070cac53294e1ee1d26bf55df.zip
BROKEN on !i386: Does not compile
-rw-r--r--devel/ustl/Makefile8
-rw-r--r--dns/totd/Makefile8
-rw-r--r--net/nam/Makefile2
3 files changed, 15 insertions, 3 deletions
diff --git a/devel/ustl/Makefile b/devel/ustl/Makefile
index b8bf2a07713e..449d550dee43 100644
--- a/devel/ustl/Makefile
+++ b/devel/ustl/Makefile
@@ -28,6 +28,12 @@ ALL_TARGET= # empty
PLIST_FILES= lib/libustl.a
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,/bin/sh," ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|SIZE_MAX|UINT_MAX|" ${WRKSRC}/memblock.h
@@ -39,4 +45,4 @@ post-install:
@${FIND} ${PREFIX}/include/ustl* -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/totd/Makefile b/dns/totd/Makefile
index 95fce5477284..19231ac1a006 100644
--- a/dns/totd/Makefile
+++ b/dns/totd/Makefile
@@ -20,6 +20,12 @@ USE_REINPLACE= YES
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/%zd/%d/g' ${WRKSRC}/*.c
@@ -29,4 +35,4 @@ post-install:
${FILESDIR}/totd.sh > ${PREFIX}/etc/rc.d/totd.sh
@${CHMOD} ${BINMODE} ${PREFIX}/etc/rc.d/totd.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/nam/Makefile b/net/nam/Makefile
index 5bf73e9c7fc5..3defb454219b 100644
--- a/net/nam/Makefile
+++ b/net/nam/Makefile
@@ -29,7 +29,7 @@ ALL_TARGET= # empty
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
+.if ${ARCH} != "i386"
BROKEN= "Does not compile"
.endif