aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2007-03-21 19:32:36 +0800
committertobez <tobez@FreeBSD.org>2007-03-21 19:32:36 +0800
commit47d2971f25bae5fed356d5f20ed74838bd7fdd04 (patch)
treefea9dd2a6cda2f43d0ea237a0f6c4cf89ba1e9a2
parent48fa08efac11fd67e4b3d4d7350ae3dca3bad9a5 (diff)
downloadfreebsd-ports-gnome-47d2971f25bae5fed356d5f20ed74838bd7fdd04.tar.gz
freebsd-ports-gnome-47d2971f25bae5fed356d5f20ed74838bd7fdd04.tar.zst
freebsd-ports-gnome-47d2971f25bae5fed356d5f20ed74838bd7fdd04.zip
Add www/p5-Yahoo-Search 1.10.13, a Perl interface to the Yahoo! Search
public API.
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Yahoo-Search/Makefile30
-rw-r--r--www/p5-Yahoo-Search/distinfo3
-rw-r--r--www/p5-Yahoo-Search/pkg-descr5
-rw-r--r--www/p5-Yahoo-Search/pkg-plist10
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2c9cee78ce45..798e4487eb78 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -877,6 +877,7 @@
SUBDIR += p5-WebService-Technorati
SUBDIR += p5-WebService-YouTube
SUBDIR += p5-Xango
+ SUBDIR += p5-Yahoo-Search
SUBDIR += p5-libapreq
SUBDIR += p5-libapreq-static
SUBDIR += p5-libapreq2
diff --git a/www/p5-Yahoo-Search/Makefile b/www/p5-Yahoo-Search/Makefile
new file mode 100644
index 000000000000..4e3b7ca36d12
--- /dev/null
+++ b/www/p5-Yahoo-Search/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Yahoo-Search
+# Date created: 21 March 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Yahoo-Search
+PORTVERSION= 1.10.13
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Yahoo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl interface to the Yahoo Search public API
+
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Yahoo::Search.3 \
+ Yahoo::Search::Request.3 \
+ Yahoo::Search::Response.3 \
+ Yahoo::Search::Result.3 \
+ Yahoo::Search::XML.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Yahoo-Search/distinfo b/www/p5-Yahoo-Search/distinfo
new file mode 100644
index 000000000000..4c7c5362a3ca
--- /dev/null
+++ b/www/p5-Yahoo-Search/distinfo
@@ -0,0 +1,3 @@
+MD5 (Yahoo-Search-1.10.13.tar.gz) = c13bbc74e5a46f11d639c9c5a3e84bfd
+SHA256 (Yahoo-Search-1.10.13.tar.gz) = 06b9bf27fcbbe3e53adc3ff5fa551cda8011591067025c618bfdae68d500f8ca
+SIZE (Yahoo-Search-1.10.13.tar.gz) = 36157
diff --git a/www/p5-Yahoo-Search/pkg-descr b/www/p5-Yahoo-Search/pkg-descr
new file mode 100644
index 000000000000..2340cec64c3a
--- /dev/null
+++ b/www/p5-Yahoo-Search/pkg-descr
@@ -0,0 +1,5 @@
+Yahoo::Search provides a rich and full-featured set of classes for
+accessing the various features of Yahoo! Search, and also offers a
+variety of shortcuts to allow simple access.
+
+WWW: http://search.cpan.org/dist/Yahoo-Search/
diff --git a/www/p5-Yahoo-Search/pkg-plist b/www/p5-Yahoo-Search/pkg-plist
new file mode 100644
index 000000000000..57c1d555d266
--- /dev/null
+++ b/www/p5-Yahoo-Search/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Yahoo/Search.pm
+%%SITE_PERL%%/Yahoo/Search/Request.pm
+%%SITE_PERL%%/Yahoo/Search/Response.pm
+%%SITE_PERL%%/Yahoo/Search/Result.pm
+%%SITE_PERL%%/Yahoo/Search/XML.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Yahoo/Search/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Yahoo/Search
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Yahoo
+@dirrmtry %%SITE_PERL%%/Yahoo/Search
+@dirrmtry %%SITE_PERL%%/Yahoo