aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2009-08-22 21:03:31 +0800
committerfluffy <fluffy@FreeBSD.org>2009-08-22 21:03:31 +0800
commit495e256119b3af10b5f10608067368a862f5c188 (patch)
tree1b0d86c8b4d7126525c7bc1e2e1570a4441328b7
parent46139aa9476fa63264f93b6112b718ad497f9ba1 (diff)
downloadfreebsd-ports-gnome-495e256119b3af10b5f10608067368a862f5c188.tar.gz
freebsd-ports-gnome-495e256119b3af10b5f10608067368a862f5c188.tar.zst
freebsd-ports-gnome-495e256119b3af10b5f10608067368a862f5c188.zip
[maintainer update] Update port: multimedia/mlt - add options to disable mmx and sse
Submitted by: Alberto Villa <villa.alberto AT gmail DOT com> Approved by: tabthorpe (mentor)
-rw-r--r--multimedia/mlt/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index 33c2066e624c..81bacdf1a580 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -6,6 +6,7 @@
PORTNAME= mlt
PORTVERSION= 0.4.4
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SFE
@@ -37,9 +38,11 @@ OPTIONS= AVFORMAT "Avformat module" on \
GTK2 "GTK2 module" on \
JACKRACK "JACK Rack module" on \
KINO "Kino module" on \
+ MMX "MMX support (might cause problems on x86-64)" off \
QIMAGE "Qimage module" on \
RESAMPLE "Secret Rabbit Code module" on \
SOX "Sound eXchange module" on \
+ SSE "SSE support (requires MMX, caution on x86-64)" off \
VORBIS "Vorbis module" on
.include <bsd.port.pre.mk>
@@ -101,6 +104,12 @@ CONFIGURE+ARGS+= --disable-kino
PLIST_SUB+= KINO="@comment "
.endif
+.ifdef(WITH_MMX)
+CONFIGURE_ARGS+= --enable-mmx
+.else
+CONFIGURE_ARGS+= --disable-mmx
+.endif
+
.ifdef(WITH_QIMAGE)
CONFIGURE_ARGS+= --enable-qimage \
--qimage-includedir="${QT_INCDIR}" \
@@ -130,6 +139,12 @@ CONFIGURE_ARGS+= --disable-sox
PLIST_SUB+= SOX="@comment "
.endif
+.ifdef(WITH_SSE)
+CONFIGURE_ARGS+= --enable-sse
+.else
+CONFIGURE_ARGS+= --disable-sse
+.endif
+
.ifdef(WITH_VORBIS)
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --enable-vorbis
@@ -147,7 +162,6 @@ pre-configure:
${WRKSRC}/src/framework/Makefile \
${WRKSRC}/src/melt/Makefile \
${WRKSRC}/src/modules/*/Makefile
- # required by FreeBSD 6
@${REINPLACE_CMD} -E -e 's|^(LDFLAGS.*)|\1 -lthr|' \
${WRKSRC}/src/framework/Makefile \
${WRKSRC}/src/modules/avformat/Makefile \