aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-31 15:25:30 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-31 15:25:30 +0800
commit4983a122aafc7ebce74e9b9fac6f9b1ddf7b4d7b (patch)
treeb2dabb1b20437a988f890b9120ed3686201d7872
parenta533949c8997fdc9d6a0bbf8b638d3279a74821c (diff)
downloadfreebsd-ports-gnome-4983a122aafc7ebce74e9b9fac6f9b1ddf7b4d7b.tar.gz
freebsd-ports-gnome-4983a122aafc7ebce74e9b9fac6f9b1ddf7b4d7b.tar.zst
freebsd-ports-gnome-4983a122aafc7ebce74e9b9fac6f9b1ddf7b4d7b.zip
update net/sdl_net:
- Utilize USE_SDL - PERL -> REINPLACE_CMD PR: 55064 Submitted by: KATO Tsuguru <tkato@prontomail.com>
-rw-r--r--net/sdl_net/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
index f82e1b177755..fbeac7acd4b1 100644
--- a/net/sdl_net/Makefile
+++ b/net/sdl_net/Makefile
@@ -14,22 +14,18 @@ DISTNAME= SDL_net-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A small sample cross-platform networking library
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- GUI.0:${PORTSDIR}/graphics/guilib
+LIB_DEPENDS= GUI.0:${PORTSDIR}/graphics/guilib
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
-USE_LIBTOOL= yes
+USE_SDL= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-
-post-extract:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
post-configure:
- @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
- ${WRKSRC}/libtool
+ @${REINPLACE_CMD} -e \
+ 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
.include <bsd.port.mk>