aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-04-12 08:45:29 +0800
committerak <ak@FreeBSD.org>2012-04-12 08:45:29 +0800
commit4aa4ee83d143a63a12278837045d082926f74d19 (patch)
treef9c5525c8aaca5b5aa51359aee3dcf27c61e7756
parent570723f42c65c8ea452dad8d6506b4d61ed6ca1e (diff)
downloadfreebsd-ports-gnome-4aa4ee83d143a63a12278837045d082926f74d19.tar.gz
freebsd-ports-gnome-4aa4ee83d143a63a12278837045d082926f74d19.tar.zst
freebsd-ports-gnome-4aa4ee83d143a63a12278837045d082926f74d19.zip
Get rid of USE_* variables
Approved by: Timothy Beyer <beyert@cs.ucr.edu> (maintainer), eadler (mentor)
-rw-r--r--x11/metalock/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/x11/metalock/Makefile b/x11/metalock/Makefile
index 6d63e601f88d..c2211f54f3b4 100644
--- a/x11/metalock/Makefile
+++ b/x11/metalock/Makefile
@@ -28,31 +28,29 @@ OPTIONS= IMLIB2 "Use Imlib2" on \
.include <bsd.port.options.mk>
+MAKE_ARGS= PREFIX="${LOCALBASE}" DEST_PREFIX="${PREFIX}" CC="${CC}"
+
.if !defined(WITHOUT_ULTRAGETOPT)
LIB_DEPENDS+= ultragetopt.0:${PORTSDIR}/devel/ultragetopt
-USE_ULTRAGETOPT= yes
+MAKE_ARGS+= USE_ULTRAGETOPT=yes
.else
-USE_ULTRAGETOPT= no
+MAKE_ARGS+= USE_ULTRAGETOPT=no
.endif
.if !defined(WITHOUT_IMLIB2)
USE_EFL= imlib2
-USE_IMLIB2= yes
+MAKE_ARGS+= USE_IMLIB2=yes
.else
-USE_IMLIB2= no
+MAKE_ARGS+= USE_IMLIB2=no
.endif
.if !defined(WITHOUT_XFT)
USE_XORG+= xft
-USE_XFT= yes
+MAKE_ARGS+= USE_XFT=yes
.else
-USE_XFT= no
+MAKE_ARGS+= USE_XFT=no
.endif
-MAKE_ARGS= PREFIX="${LOCALBASE}" DEST_PREFIX="${PREFIX}" CC="${CC}" \
- USE_XFT="${USE_XFT}" USE_ULTRAGETOPT="${USE_ULTRAGETOPT}" \
- USE_IMLIB2="${USE_IMLIB2}"
-
WRKSRC= ${WRKDIR}/${DISTNAME}/src
post-extract: