aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2016-01-21 00:26:57 +0800
committernivit <nivit@FreeBSD.org>2016-01-21 00:26:57 +0800
commit4ae5948092aacba26abfaed298ae125def83b63e (patch)
tree05c433cb53c8b49d5f467258e336864392f2a9f2
parent4f567da9ffd0768d0798219d0b3859c94b34986f (diff)
downloadfreebsd-ports-gnome-4ae5948092aacba26abfaed298ae125def83b63e.tar.gz
freebsd-ports-gnome-4ae5948092aacba26abfaed298ae125def83b63e.tar.zst
freebsd-ports-gnome-4ae5948092aacba26abfaed298ae125def83b63e.zip
- Update to 2.1
- Remove files/patch-CVE-2015-8557
-rw-r--r--textproc/py-pygments/Makefile4
-rw-r--r--textproc/py-pygments/distinfo4
-rw-r--r--textproc/py-pygments/files/patch-CVE-2015-855749
3 files changed, 4 insertions, 53 deletions
diff --git a/textproc/py-pygments/Makefile b/textproc/py-pygments/Makefile
index 2206450974d5..6547f81a3fe3 100644
--- a/textproc/py-pygments/Makefile
+++ b/textproc/py-pygments/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= pygments
-PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTVERSION= 2.1
+PORTREVISION= 0
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/textproc/py-pygments/distinfo b/textproc/py-pygments/distinfo
index 46716d875b6d..b9010fe82d07 100644
--- a/textproc/py-pygments/distinfo
+++ b/textproc/py-pygments/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Pygments-2.0.2.tar.gz) = 7320919084e6dac8f4540638a46447a3bd730fca172afc17d2c03eed22cf4f51
-SIZE (Pygments-2.0.2.tar.gz) = 3462280
+SHA256 (Pygments-2.1.tar.gz) = 13a0ef5fafd7b16cf995bc28fe7aab0780dab1b2fda0fc89e033709af8b8a47b
+SIZE (Pygments-2.1.tar.gz) = 2078224
diff --git a/textproc/py-pygments/files/patch-CVE-2015-8557 b/textproc/py-pygments/files/patch-CVE-2015-8557
deleted file mode 100644
index 0a6bd2a93fce..000000000000
--- a/textproc/py-pygments/files/patch-CVE-2015-8557
+++ /dev/null
@@ -1,49 +0,0 @@
-# HG changeset patch
-# User Tim Hatch <tim@timhatch.com>
-# Date 1445007300 25200
-# Node ID 0036ab1c99e256298094505e5e92fdacdfc5b0a8
-# Parent c0c0d4049a7c325cd69b764c6ceb7747d319212d
-Avoid the shell entirely when finding fonts.
-
-Manually tested on OS X.
-
---- pygments/formatters/img.py.orig 2014-11-10 19:17:51 UTC
-+++ pygments/formatters/img.py
-@@ -15,6 +15,8 @@ from pygments.formatter import Formatter
- from pygments.util import get_bool_opt, get_int_opt, get_list_opt, \
- get_choice_opt, xrange
-
-+import subprocess
-+
- # Import this carefully
- try:
- from PIL import Image, ImageDraw, ImageFont
-@@ -75,14 +77,11 @@ class FontManager(object):
- self._create_nix()
-
- def _get_nix_font_path(self, name, style):
-- try:
-- from commands import getstatusoutput
-- except ImportError:
-- from subprocess import getstatusoutput
-- exit, out = getstatusoutput('fc-list "%s:style=%s" file' %
-- (name, style))
-- if not exit:
-- lines = out.splitlines()
-+ proc = subprocess.Popen(['fc-list', "%s:style=%s" % (name, style), 'file'],
-+ stdout=subprocess.PIPE, stderr=None)
-+ stdout, _ = proc.communicate()
-+ if proc.returncode == 0:
-+ lines = stdout.splitlines()
- if lines:
- path = lines[0].strip().strip(':')
- return path
-@@ -197,7 +196,7 @@ class ImageFormatter(Formatter):
- bold and italic fonts will be generated. This really should be a
- monospace font to look sane.
-
-- Default: "Bitstream Vera Sans Mono"
-+ Default: "Bitstream Vera Sans Mono" on Windows, Courier New on *nix
-
- `font_size`
- The font size in points to be used.