aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-02-08 01:13:58 +0800
committerjbeich <jbeich@FreeBSD.org>2015-02-08 01:13:58 +0800
commit4b20f646d9ce5f78e8234fac0ed2dd7cb3570b40 (patch)
treec436bf8b48f9473ca9fd26e27dd8acf265847539
parent825af00693fdfbb4485be17a29e54c8351b11c6d (diff)
downloadfreebsd-ports-gnome-4b20f646d9ce5f78e8234fac0ed2dd7cb3570b40.tar.gz
freebsd-ports-gnome-4b20f646d9ce5f78e8234fac0ed2dd7cb3570b40.tar.zst
freebsd-ports-gnome-4b20f646d9ce5f78e8234fac0ed2dd7cb3570b40.zip
Add new port: graphics/librasterlite2
PR: 197228 Submitted by: coder@tuxfamily.org Approved by: mentors (implicit) librasterlite2 is an open source library that stores and retrieves huge raster coverages using a SpatiaLite DBMS. WWW: https://www.gaia-gis.it/fossil/librasterlite2/index
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/librasterlite2/Makefile44
-rw-r--r--graphics/librasterlite2/distinfo2
-rw-r--r--graphics/librasterlite2/pkg-descr4
-rw-r--r--graphics/librasterlite2/pkg-plist16
5 files changed, 67 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 34768ed6c498..f7c0fe99b14c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -513,6 +513,7 @@
SUBDIR += libpuzzle
SUBDIR += libqrencode
SUBDIR += librasterlite
+ SUBDIR += librasterlite2
SUBDIR += libraw
SUBDIR += libreatlas
SUBDIR += librsvg2
diff --git a/graphics/librasterlite2/Makefile b/graphics/librasterlite2/Makefile
new file mode 100644
index 000000000000..f5e978a3d491
--- /dev/null
+++ b/graphics/librasterlite2/Makefile
@@ -0,0 +1,44 @@
+# Created by: lbartoletti <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= librasterlite2
+PORTVERSION= 1.0.0
+DISTVERSIONSUFFIX=-rc0
+CATEGORIES= graphics geography
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Library that stores and retrieves raster coverages using a SpatiaLite
+
+LICENSE= MPL GPLv2 LGPL21
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libspatialite.so:${PORTSDIR}/databases/spatialite \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
+ libgeotiff.so:${PORTSDIR}/graphics/libgeotiff \
+ libjbig.so:${PORTSDIR}/graphics/jbigkit \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libgif.so:${PORTSDIR}/graphics/giflib \
+ libgeos.so:${PORTSDIR}/graphics/geos \
+ libproj.so:${PORTSDIR}/graphics/proj \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libfreexl.so:${PORTSDIR}/textproc/freexl \
+ libwebp.so:${PORTSDIR}/graphics/webp \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libcurl.so:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USES= gmake iconv libtool pathfix pkgconfig
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+# Work around PKG_CHECK_MODULES before base r276898
+.if !exists(/usr/libdata/pkgconfig/liblzma.pc)
+CONFIGURE_ENV+= LIBLZMA_CFLAGS=" " LIBLZMA_LIBS="-llzma"
+.endif
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/graphics/librasterlite2/distinfo b/graphics/librasterlite2/distinfo
new file mode 100644
index 000000000000..5aeaaf7ce658
--- /dev/null
+++ b/graphics/librasterlite2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (librasterlite2-1.0.0-rc0.tar.gz) = 8ddf8e7640ecc2591804a97cc78f54263362e67eb8af3089f014dc058060ef4f
+SIZE (librasterlite2-1.0.0-rc0.tar.gz) = 16400254
diff --git a/graphics/librasterlite2/pkg-descr b/graphics/librasterlite2/pkg-descr
new file mode 100644
index 000000000000..14b2ed45e7df
--- /dev/null
+++ b/graphics/librasterlite2/pkg-descr
@@ -0,0 +1,4 @@
+librasterlite2 is an open source library that stores and retrieves huge raster
+coverages using a SpatiaLite DBMS.
+
+WWW: https://www.gaia-gis.it/fossil/librasterlite2/index
diff --git a/graphics/librasterlite2/pkg-plist b/graphics/librasterlite2/pkg-plist
new file mode 100644
index 000000000000..0119b5df94e7
--- /dev/null
+++ b/graphics/librasterlite2/pkg-plist
@@ -0,0 +1,16 @@
+bin/rl2tool
+bin/wmslite
+include/rasterlite2/rasterlite2.h
+include/rasterlite2/rl2graphics.h
+include/rasterlite2/rl2svg.h
+include/rasterlite2/rl2tiff.h
+include/rasterlite2/rl2wms.h
+include/rasterlite2/sqlite.h
+lib/librasterlite2.a
+lib/librasterlite2.so
+lib/librasterlite2.so.1
+lib/librasterlite2.so.1.0.0
+lib/mod_rasterlite2.so
+lib/mod_rasterlite2.so.1
+lib/mod_rasterlite2.so.1.0.0
+libdata/pkgconfig/rasterlite2.pc