aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-05-29 16:41:47 +0800
committerrene <rene@FreeBSD.org>2013-05-29 16:41:47 +0800
commit4b351a5e17e424fc9cc9f11ce74c2dd4bb11bcce (patch)
tree1c3dd39d587f5f0578620c899ee53dfeec492953
parent237a06baf5a87d0472349b84d382be2af8ed5d58 (diff)
downloadfreebsd-ports-gnome-4b351a5e17e424fc9cc9f11ce74c2dd4bb11bcce.tar.gz
freebsd-ports-gnome-4b351a5e17e424fc9cc9f11ce74c2dd4bb11bcce.tar.zst
freebsd-ports-gnome-4b351a5e17e424fc9cc9f11ce74c2dd4bb11bcce.zip
Manually install the desktop file instead of using DESKTOP_ENTRIES, this
allows to set the MimeTypes. PR: ports/175369 (still open) Submitted by: Lawrence Chen (lchen@zen.lhaven.homeip.net) The BSD Dreamer (beastie@tardisi.com)
-rw-r--r--www/chromium/Makefile10
-rw-r--r--www/chromium/files/chromium-browser.desktop.in11
-rw-r--r--www/chromium/pkg-plist1
3 files changed, 18 insertions, 4 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 70cea288bdac..2e5f85d72a18 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -42,7 +42,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/a
ONLY_FOR_ARCHS= i386 amd64
USE_XZ= yes
-USES= bison pkgconfig
+USES= bison pkgconfig desktop-file-utils
USE_GMAKE= yes
USE_PERL5_BUILD= yes
USE_PYTHON_BUILD= 2.6+
@@ -50,9 +50,6 @@ USE_XORG= scrnsaverproto x11 xproto xscrnsaver xtst
USE_GNOME= glib20 gtk20 dconf libxslt
MAN1= chrome.1
-DESKTOP_ENTRIES="Chromium" "Web browser" "${DATADIR}/product_logo_48.png" \
- "chrome %U" "Network;WebBrowser;GTK;" true
-
ALL_TARGET= chrome
# See build/common.gypi for all the available variables.
@@ -78,6 +75,10 @@ GYP_DEFINES+= use_cups=1 \
prefix_dir=${LOCALBASE} \
python_ver=${PYTHON_VER}
+SUB_FILES= chromium-browser.desktop
+SUB_LIST= COMMENT="${COMMENT}" \
+ DATADIR=${DATADIR}
+
OPTIONS_DEFINE= CODECS GCONF PULSEAUDIO CLANG DEBUG
CODECS_DESC= Compile and enable patented codecs like H.264
@@ -196,6 +197,7 @@ do-install:
.endfor
cd ${WRKSRC}/out/${BUILDTYPE} && \
${COPYTREE_SHARE} "locales resources" ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/chromium-browser.desktop ${DESKTOPDIR}
${LN} -sf ${DATADIR}/chrome ${PREFIX}/bin
post-install:
diff --git a/www/chromium/files/chromium-browser.desktop.in b/www/chromium/files/chromium-browser.desktop.in
new file mode 100644
index 000000000000..5da408dbb151
--- /dev/null
+++ b/www/chromium/files/chromium-browser.desktop.in
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Encoding=UTF-8
+Name=Chromium
+Comment=%%COMMENT%%
+Icon=%%DATADIR%%/product_logo_48.png
+Exec=chrome %U
+Categories=Application;Network;WebBrowser;
+MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;/x-scheme-handler/https;x-scheme-handler/ftp;
+StartupNotify=true
diff --git a/www/chromium/pkg-plist b/www/chromium/pkg-plist
index 3c84842f19e3..d9fe096927cb 100644
--- a/www/chromium/pkg-plist
+++ b/www/chromium/pkg-plist
@@ -1,4 +1,5 @@
bin/chrome
+share/applications/chromium-browser.desktop
%%DATADIR%%/chrome
%%DATADIR%%/chrome-wrapper
%%DATADIR%%/chrome.pak