aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-04-11 00:11:49 +0800
committerswills <swills@FreeBSD.org>2011-04-11 00:11:49 +0800
commit4ba20296257e718607fb126f249fe24047a3c63b (patch)
tree2fd28f41ca2afdceff41094c0ee5df1cf35bc3bb
parent20159dd279f8334e5b3d001657659dcbe61b5859 (diff)
downloadfreebsd-ports-gnome-4ba20296257e718607fb126f249fe24047a3c63b.tar.gz
freebsd-ports-gnome-4ba20296257e718607fb126f249fe24047a3c63b.tar.zst
freebsd-ports-gnome-4ba20296257e718607fb126f249fe24047a3c63b.zip
- Update to 2.6.7
- Updates optional patch to use improved package provider - Adds patch to fix user/password provider hash usage PR: ports/156239 Submitted by: Russell Jackson <raj at csub.edu> (maintainer)
-rw-r--r--sysutils/puppet/Makefile3
-rw-r--r--sysutils/puppet/distinfo4
-rw-r--r--sysutils/puppet/files/optpatch-package_origin205
-rw-r--r--sysutils/puppet/files/patch-fix_password_provider42
4 files changed, 193 insertions, 61 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index 7311bbbb3d74..70fcd6164ae2 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= puppet
-PORTVERSION= 2.6.6
+PORTVERSION= 2.6.7
CATEGORIES= sysutils
MASTER_SITES= http://www.puppetlabs.com/downloads/puppet/
@@ -50,6 +50,7 @@ RUN_DEPENDS+= rubygem-mongrel>=0:${PORTSDIR}/www/rubygem-mongrel
.if defined(WITH_PACKAGE_ORIGIN)
EXTRA_PATCHES+= ${FILESDIR}/optpatch-package_origin
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bz2.so:${PORTSDIR}/archivers/ruby-bz2
.endif
.include <bsd.port.pre.mk>
diff --git a/sysutils/puppet/distinfo b/sysutils/puppet/distinfo
index ed0859f7c100..17dcc99b92e7 100644
--- a/sysutils/puppet/distinfo
+++ b/sysutils/puppet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (puppet-2.6.6.tar.gz) = bc613c2764345947268a080ca0595aa6d4dbb0b9eab65d1476ff6542caf1647a
-SIZE (puppet-2.6.6.tar.gz) = 1514638
+SHA256 (puppet-2.6.7.tar.gz) = 90c0741f66d15716cfd76f0b8cd15f5b867056f0180ba160ce868350c6dd4ddc
+SIZE (puppet-2.6.7.tar.gz) = 1530756
diff --git a/sysutils/puppet/files/optpatch-package_origin b/sysutils/puppet/files/optpatch-package_origin
index f47dc9425d39..e1cef54cfb52 100644
--- a/sysutils/puppet/files/optpatch-package_origin
+++ b/sysutils/puppet/files/optpatch-package_origin
@@ -1,19 +1,24 @@
-diff --git a/lib/puppet/provider/package/freebsd.rb b/lib/puppet/provider/package/freebsd.rb
-index e10a20b..fbda52d 100755
+diff --git lib/puppet/provider/package/freebsd.rb lib/puppet/provider/package/freebsd.rb
+index e10a20b..f36e29e 100755
--- lib/puppet/provider/package/freebsd.rb
+++ lib/puppet/provider/package/freebsd.rb
-@@ -1,36 +1,79 @@
- Puppet::Type.type(:package).provide :freebsd, :parent => :openbsd do
+@@ -1,37 +1,165 @@
+-Puppet::Type.type(:package).provide :freebsd, :parent => :openbsd do
- desc "The specific form of package management on FreeBSD. This is an
- extremely quirky packaging system, in that it freely mixes between
- ports and packages. Apparently all of the tools are written in Ruby,
- so there are plans to rewrite this support to directly use those
- libraries."
-+ include Puppet::Util::Execution
++require 'open-uri'
++require 'net/ftp'
++require 'bz2'
- commands :pkginfo => "/usr/sbin/pkg_info",
- :pkgadd => "/usr/sbin/pkg_add",
- :pkgdelete => "/usr/sbin/pkg_delete"
++Puppet::Type.type(:package).provide :freebsd, :parent => Puppet::Provider::Package do
++ include Puppet::Util::Execution
++
+ desc "The specific form of package management on FreeBSD. Resource names must be
+ specified as the port origin: <port_category>/<port_name>."
+
@@ -24,84 +29,168 @@ index e10a20b..fbda52d 100755
confine :operatingsystem => :freebsd
+ defaultfor :operatingsystem => :freebsd
+
-+ def self.instances
-+ packages = []
-+
-+ output = pkginfo "-aoQ"
-+ output.split("\n").each do |data|
-+ lhs, pkg_origin = data.split(":")
-+ pkg_name = lhs.split("-").slice(0..-2).join("-")
-+ pkg_version = lhs.split("-")[-1]
-+
-+ packages << new({
-+ :provider => self.name,
-+ :name => pkg_origin,
-+ :ensure => pkg_version,
-+ })
-+ end
++ @@lock = Mutex.new
++ @@ports_index = nil
- def self.listcmd
- command(:pkginfo)
-+ packages
++ # fix bug in URI::FTP merge method that tries to set typecode
++ # even when other is a string.
++ class URI::FTP
++ def merge(other)
++ tmp = super(other)
++ if self != tmp
++ tmp.set_typecode(other.typecode) rescue NoMethodError
++ end
++ return tmp
++ end
end
- def install
- should = @resource.should(:ensure)
+- def install
+- should = @resource.should(:ensure)
++ def self.parse_pkg_string(pkg_string)
++ {
++ :pkg_name => pkg_string.split("-").slice(0..-2).join("-"),
++ :pkg_version => pkg_string.split("-")[-1],
++ }
++ end
++
++ def self.unparse_pkg_info(pkg_info)
++ [:pkg_name, :pkg_version].map { |key| pkg_info[key] }.join("-")
++ end
+
-+ origin = {}
-+ [:category, :name].zip(@resource[:name].split("/")).each { |a,b| origin[a] = b }
-+ Puppet.debug "origin => #{origin.inspect}"
-+ if origin[:name] == nil
-+ raise Puppet::Error.new "package name must be in origin format: <category>/<name>"
++ def self.parse_origin(origin_path)
++ begin
++ origin = {
++ :port_category => origin_path.split("/").fetch(-2),
++ :port_name => origin_path.split("/").fetch(-1),
++ }
++ rescue IndexError
++ raise Puppet::Error.new "#{origin_path}: not in required origin format: .*/<port_category>/<port_name>"
+ end
-+
-+ # source parameter is set
-+ if @resource[:source]
-+ source = URI.parse(@resource[:source])
-+ Puppet.debug "source => #{source.inspect}"
++ origin
++ end
- if @resource[:source] =~ /\/$/
- if @resource[:source] =~ /^(ftp|https?):/
- Puppet::Util::Execution::withenv :PACKAGESITE => @resource[:source] do
- pkgadd "-r", @resource[:name]
-+ # URI is for local file path.
-+ if (source.scheme == "file" || source.scheme == nil) && source.path
-+ # Pass pkg_add only the URI path.
-+ pkgadd source.path
++ def self.instances
++ packages = []
++ output = pkginfo "-aoQ"
++ output.split("\n").each do |data|
++ pkg_string, pkg_origin = data.split(":")
++ pkg_info = self.parse_pkg_string(pkg_string)
++
++ packages << new({
++ :provider => self.name,
++ :name => pkg_origin,
++ :ensure => pkg_info[:pkg_version],
++ })
++ end
++ packages
++ end
+
-+ # URI scheme is something other than 'file'.
-+ elsif source.scheme && source.host && source.path
-+ if source.path.end_with?(".tbz") # URI references a package.
-+ # Pass pkg_add the entire URI.
-+ pkgadd source.to_s
-+ else # Assume URI references a directory.
-+ # Set PACKAGESITE in execution environment to source URI.
-+ # Pass pkg_add the origin name.
-+ withenv :PACKAGESITE => source.path.end_with?("/") ? source.to_s : source.to_s << "/" do
-+ Puppet.debug "ENV['PACKAGESITE'] => #{ENV['PACKAGESITE']}"
-+ pkgadd "-rf", origin[:name]
++ def ports_index
++ @@lock.synchronize do
++ if @@ports_index.nil?
++ @@ports_index = {}
++ uri = source.merge "INDEX.bz2"
++ Puppet.debug "Fetching INDEX: #{uri.inspect}"
++ begin
++ open(uri, "r") do |f|
++ BZ2::Reader.open(f.path) do |f|
++ while (line = f.gets)
++ fields = line.split("|")
++ pkg_info = self.class.parse_pkg_string(fields[0])
++ origin = self.class.parse_origin(fields[1])
++ @@ports_index[origin] = pkg_info
++ end
++ end
+ end
++ rescue IOError, OpenURI::HTTPError, Net::FTPError
++ @@ports_index = nil
++ raise Puppet::Error.new "Could not fetch ports INDEX: #{$!}"
end
-+
-+ # URI is not usable by pkg_add
- else
+- else
- Puppet::Util::Execution::withenv :PKG_PATH => @resource[:source] do
- pkgadd @resource[:name]
-- end
-+ raise Puppet::Error.new "source URI is inappropriate: #{source.inspect}"
++ end
++ end
++ @@ports_index
++ end
++
++ def uri_path
++ Facter.loadfacts
++ File.join(
++ "/", "pub", "FreeBSD", "ports",
++ Facter.value(:hardwareisa),
++ [
++ "packages",
++ Facter.value(:kernelmajversion).split(".")[0],
++ "stable",
++ ].join("-")
++ ) << "/"
++ end
++
++ def source
++ if !defined? @source
++ if @resource[:source]
++ @source = URI.parse(@resource[:source])
++ if @source.path.empty?
++ @source.merge! uri_path
+ end
++ else # source parameter not set; build default source URI
++ @source = URI::FTP.build({
++ :host => "ftp.freebsd.org",
++ :path => uri_path,
++ })
end
++ Puppet.debug "Package: #{@resource[:name]}: source => #{@source.inspect}"
++ end
++ @source
++ end
++
++ def origin
++ if !defined? @origin
++ @origin = self.class.parse_origin(@resource[:name])
++ Puppet.debug "Package: #{@resource[:name]}: origin => #{@origin.inspect}"
++ end
++ @origin
++ end
++
++ def package_uri
++ begin
++ pkg_name = self.class.unparse_pkg_info(ports_index.fetch(origin))
++ rescue IndexError
++ raise Puppet::Error.new "package not found in INDEX"
++ end
++ uri = source.merge File.join("All", pkg_name + ".tbz")
++ Puppet.debug "Package: #{@resource[:name]}: package_uri => #{uri.inspect}"
++ uri
++ end
++
++ def install
++ should = @resource.should(:ensure)
++ origin # call origin so we check the package name for correctness early
+
-+ # source parameter is not set.
++ # Source URI is for local file path.
++ if !source.absolute? or source.scheme == "file"
++ pkgadd source.path
++ # Source URI is to specific package file
++ elsif source.absolute? && source.path.end_with?(".tbz")
++ pkgadd source.to_s
++ # Source URI is to a package repository
else
- Puppet.warning "source is defined but does not have trailing slash, ignoring #{@resource[:source]}" if @resource[:source]
- pkgadd "-r", @resource[:name]
-+ # fetch package using default PACKAGESITE directory logic.
-+ # Pass pkg_add the origin name.
-+ pkgadd "-rf", origin[:name]
++ pkgadd "-f", package_uri.to_s
end
++ nil
end
-@@ -44,7 +87,7 @@ Puppet::Type.type(:package).provide :freebsd, :parent => :openbsd do
+ def query
+@@ -44,7 +172,7 @@ Puppet::Type.type(:package).provide :freebsd, :parent => :openbsd do
end
def uninstall
diff --git a/sysutils/puppet/files/patch-fix_password_provider b/sysutils/puppet/files/patch-fix_password_provider
new file mode 100644
index 000000000000..8fd0e20fac78
--- /dev/null
+++ b/sysutils/puppet/files/patch-fix_password_provider
@@ -0,0 +1,42 @@
+diff --git lib/puppet/provider/user/pw.rb lib/puppet/provider/user/pw.rb
+index a5988ca..c2fff37 100644
+--- lib/puppet/provider/user/pw.rb
++++ lib/puppet/provider/user/pw.rb
+@@ -1,10 +1,11 @@
+ require 'puppet/provider/nameservice/pw'
++require 'open3'
+
+ Puppet::Type.type(:user).provide :pw, :parent => Puppet::Provider::NameService::PW do
+ desc "User management via `pw` on FreeBSD."
+
+ commands :pw => "pw"
+- has_features :manages_homedir, :allows_duplicates
++ has_features :manages_homedir, :allows_duplicates, :manages_passwords
+
+ defaultfor :operatingsystem => :freebsd
+
+@@ -37,5 +38,24 @@ Puppet::Type.type(:user).provide :pw, :parent => Puppet::Provider::NameService::
+
+ cmd
+ end
++
++ # use pw to update password hash
++ def password=(cryptopw)
++ Puppet.debug "change password for user '#{@resource[:name]}' method called with hash '#{cryptopw}'"
++ stdin, stdout, stderr = Open3.popen3("pw user mod #{@resource[:name]} -H 0")
++ stdin.puts(cryptopw)
++ stdin.close
++ Puppet.debug "finished password for user '#{@resource[:name]}' method called with hash '#{cryptopw}'"
++ end
++
++ # get password from /etc/master.passwd
++ def password
++ Puppet.debug "checking password for user '#{@resource[:name]}' method called"
++ current_passline = `getent passwd #{@resource[:name]}`
++ current_password = current_passline.chomp.split(':')[1] if current_passline
++ Puppet.debug "finished password for user '#{@resource[:name]}' method called : '#{current_password}'"
++ current_password
++ end
++
+ end
+
h'>| * - Add a new port: finance/R-cran-varstota2012-02-064-0/+35 | | | | | | | | Estimation, lag selection, diagnostic testing, forecasting, causality analysis, forecast error variance decomposition and impulse response functions of VAR models and estimation of SVAR/SVEC models. WWW: http://cran.r-project.org/web/packages/vars/ * - Add a new port: finance/R-cran-urcatota2012-02-064-0/+29 | | | | | | | Unit root and cointegration tests encountered in applied econometric analysis are implemented. WWW: http://cran.r-project.org/web/packages/urca/ * - Add a new port: finance/R-cran-strucchangetota2012-02-064-0/+39 | | | | | | | | | | | | | | | Testing, monitoring and dating structural changes in (linear) regression models. strucchange features tests/methods from the generalized fluctuation test framework as well as from the F test (Chow test) framework. This includes methods to fit, plot and test fluctuation processes (e.g., CUSUM, MOSUM, recursive/moving estimates) and F statistics, respectively. It is possible to monitor incoming data online using fluctuation processes. Finally, the breakpoints in regression models with structural changes can be estimated together with confidence intervals. Emphasis is always given to methods for visualizing the data. WWW: http://cran.r-project.org/web/packages/strucchange/ * Correct distinfo.crees2012-02-051-2/+2 | | | | | Noticed by: Matthew Seaman <m.seaman@infracaninophile.co.uk> Submitted by: Alexandr Kovalenko <never@nevermind.kiev.ua> (maintainer) * - Add a new port: finance/R-cran-plmtota2012-02-044-0/+36 | | | | | | | | | | Panel data econometrics is obviously one of the main fields in the profession, but most of the models used are difficult to estimate with R. plm is a package for R which intends to make the estimation of linear panel models straightforward. plm provides functions to estimate a wide variety of models and to make (robust) inference. WWW: http://cran.r-project.org/web/packages/plm/ * - Update to 1.2.0 with a commit I made upstream to fix the Grantlee pluginrakuco2012-02-044-13/+190 | | | | | | | | installation path. - By the way, the port now depends on devel/grantlee. - Pass maintainership to kde@, as suggested by makc. Approved by: makc (maintainer) * At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450eadler2012-01-2231-31/+31 | | | | | | | | | | ports use BUILD_DEPENDS:= ${RUN_DEPENDS}. This patch fixes ports that are currently broken. This is a temporary measure until we organically stop using := or someone(s) spend a lot of time changing all the ports over. Explicit duplication > := > = and this just moves ports one step to the left Approved by: portmgr * - Fix crash upon Gnucash importscheidell2012-01-192-0/+33 | | | | | | PR: ports/164234 Submitted by: maintainer Approved by: gabor (mentor, implicit) * update math/R to 2.14.1, and adjust dependent portsbf2012-01-192-2/+2 | * Fix plist, %%DOCSDIR%%/common is a symlink not a directorybapt2012-01-152-2/+2 | | | | | | PR: ports/164044 Submitted by: bapt (myself) Approved by: Cezary Morga <cm@therek.net> (maintainer) * In the rc.d scripts, change assignments to rcvar to use thedougb2012-01-143-3/+3 | | | | | | | | | | | literal name_enable wherever possible, and ${name}_enable when it's not, to prepare for the demise of set_rcvar(). In cases where I had to hand-edit unusual instances also modify formatting slightly to be more uniform (and in some cases, correct). This includes adding some $FreeBSD$ tags, and most importantly moving rcvar= to right after name= so it's clear that one is derived from the other. * - update to 5.0.21rm2012-01-063-4/+5 | | | | | PR: 163836 Submitted by: Jason E. Hale <bsdkaffee at gmail dot com> (maintainer) * - update to 1.37rm2012-01-063-4/+4 | | | | | PR: 163835 Submitted by: Jason E. Hale <bsdkaffee at gmail dot com> (maintainer) * - Add missing BUILD_DEPENDS to allow the module to work, silence buildswills2012-01-061-2/+4 | | | | | | | warning and allow testing - Bump PORTREVISION due to added dependency - Expand value of BUILD_DEPENDS before assigning to RUN_DEPENDS as suggested by the Porters Handbook * - Add missing BUILD_DEPENDS to allow the module to work, silence buildswills2012-01-061-2/+4 | | | | | | | warning and allow testing - Bump PORTREVISION due to added dependency - Expand value of BUILD_DEPENDS before assigning to RUN_DEPENDS as suggested by the Porters Handbook * - Reassignment of ECHO_MSG breaks 'make readme', so remove and reformat IGNORE.jgh2012-01-051-8/+6 | | | | | Submitted by: jgh (me) Approved by: crees (mentor) * End WWW CPAN URL with a "/"ehaupt2011-12-283-3/+3 | * Mark as broken on powerpc: fails to install.linimon2011-12-281-0/+4 | | | | Hat: portmgr * - update to 4.0.0scheidell2011-12-232-4/+5 | | | | | | PR: ports/163383 Submitted by: Philip M. Gollucci <pgollucci@p6m7g8.com> Approved by: freebsdports@chillibear.com (maintainer), gabor (mentor) * Fix compilation with clang. This does not fix the port, since there is ase2011-12-211-0/+11 | | | | libtool error (missing librdhfile.la) later on. * update math/R to 2.14.0, math/R-cran-sp to 0.9-91, and adjustbf2011-11-272-2/+2 | | | | | | | dependent ports Approved by: linimon (portmgr), thierry, tota, wen Feature safe: yes * - Move PKGNAMEPREFIX defined in each R-cran- related ports Makefiletota2011-11-162-2/+0 | | | | | | | | | | | | | to Mk/bsd.cran.mk PR: ports/162238 Submitted by: tota (myself) Approved by: wen (maintainer of Mk/bsd.cran.mk and many related ports), David Naylor <naylor_DOT_b_DOT_david_AT_gmail_DOT_com> (maintainer of math/R-cran-RSvgDevice and math/R-cran-car), Dan Rue <drue_AT_therub_DOT_org> (maintainer of math/R-cran-psych, timeout > 2 weeks) Feature safe: yes * - Unbreak - fix build with latest x11-toolkits/fltkgahr2011-11-1510-4/+343 | | | | Feature safe: yes * - Update to 1.0.5miwi2011-11-142-4/+3 | | | | | | PR: 162555 Submitted by: Armin Pirkovitsch <armin@frozen-zone.org> Feature safe: yes * - Update to 4.6.1miwi2011-11-133-5/+170 | | | | | | PR: 162391 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) Feature safe: yes * - Mark BROKEN: does not compile with new fltkpav2011-11-051-0/+2 | | | | Reported by: pointyhat * - Update to 3.22clsung2011-10-273-3/+6 | * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-2/+0 | | | | | | | | | | | | | | | | had both lines: Author: ... WWW: .... So standardize on that, and move them to the end of the file when necessary. Also fix some more whitespace, and remove more "signature tags" of varying forms, like -- name, etc. s/AUTHOR/Author/ A few other various formatting issues * Remove more tags from pkg-descr files fo the form:dougb2011-10-241-3/+0 | | | | | | | | - Name em@i.l or variations thereof. While I'm here also fix some whitespace and other formatting errors, including moving WWW: to the last line in the file. * - Update dependencies after KDE ports upgrade.avilla2011-10-174-5/+2 | | | | | - Avoid removing kdehier4 directories. - Bump PORTREVISION. * update math/R to 2.13.2, and adjust dependent portsbf2011-10-112-0/+2 | * - Fix LICENSE (Artistic 1 instead of Artistic 2)culot2011-10-071-1/+1 | | | | | | | - Pet portlint(1) PR: ports/161336 Submitted by: Simon Olofsson <simon@olofsson.de> * - Update RUN_DEPENDS [1]sbz2011-10-051-1/+4 | | | | | | | | - Add LICENSE PR: ports/161276 Submitted by: Ruslan Mahmatkhanov <cvs-src at yandex.ru> [1] Approved by: jadawin@ (mentor) * - Chase devel/gwenhywfar has a shlib version bumpswills2011-10-031-0/+1 | | | | | PR: ports/160998 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) * - Chase devel/gwenhywfar has a shlib version bumpswills2011-10-031-1/+1 | | | | | PR: ports/160998 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> * - Update to 5.0.16swills2011-10-033-5/+6 | | | | | PR: ports/160998 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) * - Update to 1.35dhn2011-09-253-4/+3 | | | | | PR: ports/160999 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-2410-17/+13 | | | | | | | | | - Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav * - Add a new port: finance/R-cran-gmmtota2011-09-234-0/+36 | | | | | | | | | | | | It is a complete suite to estimate models based on moment conditions. It includes the two step Generalized method of moments (GMM) of Hansen(1982), the iterated GMM and continuous updated estimator (CUE) of Hansen-Eaton-Yaron(1996) and several methods that belong to the Generalized Empirical Likelihood (GEL) family of estimators, as presented by Smith(1997), Kitamura(1997), Newey-Smith(2004) and Anatolyev(2005). WWW: http://cran.r-project.org/web/packages/gmm/ * - Add a new port: finance/R-cran-RFinanceYJtota2011-09-164-0/+31 | | | | | | Japanese stock market from Yahoo!-finance-Japan WWW: http://cran.r-project.org/web/packages/RFinanceYJ/ * - Update to 0.02az2011-09-094-10/+14 | | | | - Pet portlint * - Replace ../../authors in MASTER_SITE_SUBDIR with CPAN:CPANID macro.az2011-09-083-4/+4 | | | | | | | See http://wiki.freebsd.org/Perl for details. - Change maintainership from ports@ to perl@ for ports in this changeset. With perl@ hat * - Update To 6.0.3beech2011-09-078-58/+190 | | | | | PR: ports/160310 Submitted by: Laurent Berthelet <laurent@ospowa.com> (maintainer) * Update to 0.9.1.rakuco2011-09-073-103/+66 | | | | Approved by: makc (mentor) * - Update to 3.7.1swills2011-09-052-8/+4 | | | | | | | | - Works with Ruby 1.9 now PR: ports/160244 Submitted by: swills (me) Approved by: Eric <freebsdports@chillibear.com> (maintainer) * - Update to 4.6.0beech2011-08-313-21/+45 | | | | | PR: ports/160162 Submitted by: Jason E. Hale <bsdkaffee@gmail.com (maintainer) * - Update to 1.19sunpoet2011-08-303-5/+3 | | | | Changes: http://search.cpan.org/dist/Finance-QuoteHist/Changes * - Pet portlintsunpoet2011-08-301-6/+9 | * - Update to 1.17sunpoet2011-08-282-4/+10 | | | | Changes: http://search.cpan.org/dist/Finance-QuoteHist/Changes * - Update to 1.34miwi2011-08-263-7/+7 | | | | | PR: 160200 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) * Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where ↵kwm2011-08-241-1/+1 | | | | needed. * - Pass maintainership to new voluteer <via email>wen2011-08-222-2/+2 | * Add option for experimental localized tax categories [1]kwm2011-08-201-5/+10 | | | | | | | | Pet portlint by moving LICENSE block to correct place and moving CPPFLAGS out of configure_env. PR: ports/159822 [1] Submitted by: Armin Gruner <ag@muc.de> [1] * - Update to 2.6.3beech2011-08-184-8/+10 | | | | | | | | | | - Master site set to github (SF does not have latest releases) - Project homepage changed - License variable set PR: ports/159639 Submitted by: Kaspars Bankovskis <kaspars@bankovskis.lv> Approved by: Woody Carey <woodycarey@hotmail.com> (maintainer) * Update master_sitebapt2011-08-021-1/+1 | * Update to 4.3.1arved2011-08-023-7/+10 | | | | | PR: 159359 Submitted by: maintainer * Chase devel/gwenhywfar shlib bump.kwm2011-08-012-1/+2 | * Update to 5.0.14.kwm2011-08-014-10/+22 | | | | | | | | pet portlint by moving LICENSE block. Add a patch to fix symbol visibility support with cc. PR: ports/159032 Submitted by: maintainer * - Chase guile shared lib bumpjlaffaye2011-07-311-0/+1 | | | | - Add an entry to UPDATING * Convert custom *_DEPENDS lines of devel/py-gobject to USE_GNOME=pygobject orkwm2011-07-301-3/+2 | | | | pygtk2 (which depends already on py-gobject). * - Mark broken with Ruby 1.9swills2011-07-271-1/+5 | | | | With hat: ruby@ * - Chase gpgme shared lib bump.jlaffaye2011-07-211-1/+1 | | | | | | - Add an entry to UPDATING Reviewed by: tabthorpe * Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,linimon2011-07-211-1/+1 | | | | | | | | | | | | | | | | remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp * Update to 2.4.1.kwm2011-07-173-34/+477 | * Update to 2.4.7.kwm2011-07-172-5/+5 | * - Update to 3.7.0pgollucci2011-06-262-3/+3 | | | | | | | PR: ports/158213 Submitted by: myself (pgollucci) Approved by: freebsdports@chillibear.com (maintainer) Sponsored by: RideCharge Inc. / TaxiMagic * - Cannoicalize the WWW: [again],pgollucci2011-06-241-1/+1 | | | | - Save redirects s/http/https/ for github * - Replace ../../authors in MASTER_SITE_SUBDIR with CPAN:CPANID macro.az2011-06-211-1/+2 | | | | | | | See http://wiki.freebsd.org/Perl for details. - Change maintainership from ports@ to perl@ for ports in this changeset. - Remove MD5 checksum - Utilize CPAN macro * - Fix dependency versionspgollucci2011-06-211-1/+1 | * - update to 1.30bapt2011-06-182-3/+3 | * Update to 1.33jlaffaye2011-06-113-4/+4 | | | | | | PR: ports/157741 Sbmitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) Approved by: bapt (mentor) * Maintainers addresses are not valid anymore put the port back to the poolbapt2011-06-101-1/+1 | * - Update to 0.94wen2011-06-025-37/+41 | | | | | PR: ports/157515 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) * - Update to 5.0.7wen2011-06-022-7/+5 | | | | | PR: ports/157511 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) * - Update to 1.1jadawin2011-05-303-5/+55 | | | | | PR: ports/157329 Submitted by: dikshie <dikshie _AT_ sfc.wide.ad.jp> * Upgrade to 0.8.6 (bug fixes).thierry2011-05-232-5/+5 | * A library assists in handling money and different currencies.swills2011-05-034-0/+30 | | | | | | | | | | It features a Money class which encapsulates all information about an certain amount of money, such as its value and its currency. WWW: http://money.rubyforge.org/ PR: ports/156679 Submitted by: Eric Freeman <freebsdports at chillibear.com> * One more bunch of unmaintained expired ports removalbapt2011-05-0214-154/+0 | | | | | | | | | | 2011-05-01 audio/dap: Upstream disapear and distfile is no more available 2011-05-01 audio/gdrdao: Upstream disapear and no more distfiles available 2011-05-01 databases/gmysql: Upstream disapear and distfile is no more available 2011-05-01 deskutils/kuake: Upstream disapear and distfile is no more available 2011-05-01 finance/xinvest: Outdated, abandoned 2011-05-01 finance/xquote: Outdated, abandoned 2011-05-01 french/plgrenouille: Upstream disapear and distfile is no more available * Bump PORTREVISION after open-mofit updatemakc2011-05-021-1/+1 | * Fix build with open-motif-2.3.3makc2011-05-022-1/+13 | | | | | | PR: ports/154044 Submitted by: Mikhail Tsatsenko <m.tsatsenko at gmail.com> Exp-runs by: pav * The former maintainer only adopted these ports to save themdougb2011-04-272-0/+6 | | | | | | | | | from deprecation because they were fetchable, however, "Frankly, xquote should be deprecated, as it's an old-style Motif app that's so ugly I'll bet no one uses it. I only took it (and the related xinvest) because they got reinstated after I pointed out they were still fetchable at a new location." * By Maintainer's request, toss these ports back into the pooldougb2011-04-27