aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2011-12-04 03:27:22 +0800
committerscheidell <scheidell@FreeBSD.org>2011-12-04 03:27:22 +0800
commit4fed5c3261c1243a99557ec656f06261275f9d9c (patch)
treef19d572a79eaede0e876a704308317db73f8749b
parent9e10f8b7768db98a7e51ed04b617ebd6cfa9c579 (diff)
downloadfreebsd-ports-gnome-4fed5c3261c1243a99557ec656f06261275f9d9c.tar.gz
freebsd-ports-gnome-4fed5c3261c1243a99557ec656f06261275f9d9c.tar.zst
freebsd-ports-gnome-4fed5c3261c1243a99557ec656f06261275f9d9c.zip
-The base __aligned attribute no longer exists in gcc46+
-patch uses __attribute__ which is upward compatible with gcc42+ PR: ports/156881 Submitted by: Zhihao Yuan <lichray@gmail.com> Approved by: maintainer(timeout), gaboe(mentor) Feature safe: yes
-rw-r--r--devel/valgrind/Makefile8
-rw-r--r--devel/valgrind/files/patch-include_vki_vki-x86-freebsd.h20
2 files changed, 22 insertions, 6 deletions
diff --git a/devel/valgrind/Makefile b/devel/valgrind/Makefile
index 993e32ff74df..fc3e81d904a3 100644
--- a/devel/valgrind/Makefile
+++ b/devel/valgrind/Makefile
@@ -7,15 +7,11 @@
PORTNAME= valgrind
PORTVERSION= 3.6.1
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
-.if ${PORTREVISION} > 0
-DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}-${PORTREVISION}
-.else
-DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
-.endif
+DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}-2
MAINTAINER= ports@FreeBSD.org
COMMENT= A (memory) debugging and profiling tool
diff --git a/devel/valgrind/files/patch-include_vki_vki-x86-freebsd.h b/devel/valgrind/files/patch-include_vki_vki-x86-freebsd.h
new file mode 100644
index 000000000000..3b2cc22ca577
--- /dev/null
+++ b/devel/valgrind/files/patch-include_vki_vki-x86-freebsd.h
@@ -0,0 +1,20 @@
+--- include/vki/vki-x86-freebsd.h.orig 2011-04-27 02:47:18.000000000 -0500
++++ include/vki/vki-x86-freebsd.h 2011-05-08 05:39:46.293802771 -0500
+@@ -145,7 +145,7 @@ struct vki_sigcontext {
+ int fpformat;
+ int ownedfp;
+ int spare1[1];
+- struct _vki_fpstate fpstate __aligned(16);
++ struct _vki_fpstate fpstate __attribute__((__aligned__(16)));
+ int fsbase;
+ int gsbase;
+ int spare2[6];
+@@ -215,7 +215,7 @@ struct vki_mcontext {
+ int fpformat;
+ int ownedfp;
+ int spare1[1];
+- struct _vki_fpstate fpstate __aligned(16);
++ struct _vki_fpstate fpstate __attribute__((__aligned__(16)));
+ int fsbase;
+ int gsbase;
+ int spare2[6];