aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2018-02-02 05:53:37 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:33:16 +0800
commit51ddcc11e35eb9bfc0c9a098a24e0cf016faaf9c (patch)
treecae5f81262cc191e67d85093bd2ad93c1b5802a6
parent91c68310289c05275c3263f83447019c63d7410b (diff)
downloadfreebsd-ports-gnome-51ddcc11e35eb9bfc0c9a098a24e0cf016faaf9c.tar.gz
freebsd-ports-gnome-51ddcc11e35eb9bfc0c9a098a24e0cf016faaf9c.tar.zst
freebsd-ports-gnome-51ddcc11e35eb9bfc0c9a098a24e0cf016faaf9c.zip
devel/py-codecov: Update to 2.0.15
Changelog: https://github.com/codecov/codecov-python/blob/master/CHANGELOG.md#2015
-rw-r--r--devel/py-codecov/Makefile2
-rw-r--r--devel/py-codecov/distinfo6
-rw-r--r--devel/py-codecov/files/patch-tests_test.py12
3 files changed, 14 insertions, 6 deletions
diff --git a/devel/py-codecov/Makefile b/devel/py-codecov/Makefile
index 4f9209eecb6d..6861887702ae 100644
--- a/devel/py-codecov/Makefile
+++ b/devel/py-codecov/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= codecov
-PORTVERSION= 2.0.14
+PORTVERSION= 2.0.15
DISTVERSIONPREFIX= v
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/py-codecov/distinfo b/devel/py-codecov/distinfo
index 5c2919736eeb..6b5b800413a3 100644
--- a/devel/py-codecov/distinfo
+++ b/devel/py-codecov/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516386800
-SHA256 (codecov-codecov-python-v2.0.14_GH0.tar.gz) = 58dfb64c8f4650bbaf8c6c8ec1cfd2bad42b0ba40c035a7077200fb0e8a8c0da
-SIZE (codecov-codecov-python-v2.0.14_GH0.tar.gz) = 22560
+TIMESTAMP = 1517521483
+SHA256 (codecov-codecov-python-v2.0.15_GH0.tar.gz) = 474700e009b4175a3614cf8678a25d591e66cea2af2c1bbe80b53faec10621f3
+SIZE (codecov-codecov-python-v2.0.15_GH0.tar.gz) = 22748
diff --git a/devel/py-codecov/files/patch-tests_test.py b/devel/py-codecov/files/patch-tests_test.py
index 93cde7a6b85d..733d2a233da6 100644
--- a/devel/py-codecov/files/patch-tests_test.py
+++ b/devel/py-codecov/files/patch-tests_test.py
@@ -1,4 +1,4 @@
---- tests/test.py.orig 2018-01-13 11:23:57 UTC
+--- tests/test.py.orig 2018-01-29 15:52:17 UTC
+++ tests/test.py
@@ -2,9 +2,9 @@ import os
import sys
@@ -20,7 +20,15 @@
def test_send(self):
with patch('requests.post') as post:
with patch('requests.put') as put:
-@@ -249,7 +249,7 @@ class TestUploader(unittest.TestCase):
+@@ -204,6 +204,7 @@ class TestUploader(unittest.TestCase):
+ else:
+ raise Exception("Did not raise AssertionError")
+
++ @unittest.skip('Skip test')
+ def test_prefix(self):
+ self.fake_report()
+ res = self.run_cli(prefix='/foo/bar/', dump=True, token='a', branch='b', commit='c')
+@@ -254,7 +255,7 @@ class TestUploader(unittest.TestCase):
else:
raise Exception("Did not raise AssertionError")