aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-09-19 17:53:55 +0800
committermiwi <miwi@FreeBSD.org>2009-09-19 17:53:55 +0800
commit52a470a131937bfeba5c26513ec762787b5c089c (patch)
treed8c22843a9d453a9bcb1139a6693730cc05170ec
parent5240b566b924371c40fa30fd48affe48956677b9 (diff)
downloadfreebsd-ports-gnome-52a470a131937bfeba5c26513ec762787b5c089c.tar.gz
freebsd-ports-gnome-52a470a131937bfeba5c26513ec762787b5c089c.tar.zst
freebsd-ports-gnome-52a470a131937bfeba5c26513ec762787b5c089c.zip
Checkmol is a command-line utility program which reads molecular
structure files in different formats and analyzes the input molecule for the presence of various functional groups and structural elements. At present, approx. 200 different functional groups are recognized. This output can be easily placed into a database table, permitting the creation of chemical databases with a functional group search option. Checkmol also outputs a set of statistical values derived from a given molecule, which can also be used for quick retrieval from a database. These values include: the number of atoms, bonds, and rings, the number of differently hybridized carbon, oxgen, and nitrogen atoms, the number of C=O double bonds, the number of rings of different sizes, the number of rings containing nitrogen, oxygen, sulfur, the number of aromatic rings, the number of heterocyclic rings, etc. The combination of all of these values for a given molecule represents some kind of "fingerprint" which is useful for rapid pre-selection in a database structure/substructure search prior to a full atom-by-atom match. WWW: http://merian.pch.univie.ac.at/~nhaider/cheminf/cmmm.html PR: ports/138670 Feature safe:yes Submitted by: Fernan Aguero <fernan at iib.unsam.edu.ar>
-rw-r--r--science/Makefile1
-rw-r--r--science/checkmol/Makefile31
-rw-r--r--science/checkmol/distinfo3
-rw-r--r--science/checkmol/pkg-descr27
4 files changed, 62 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 74a8bbaacb72..caaab18f9b80 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -19,6 +19,7 @@
SUBDIR += cdf
SUBDIR += cdo
SUBDIR += cgnslib
+ SUBDIR += checkmol
SUBDIR += chemical-mime-data
SUBDIR += chemtool
SUBDIR += chemtool-devel
diff --git a/science/checkmol/Makefile b/science/checkmol/Makefile
new file mode 100644
index 000000000000..614a4c2728aa
--- /dev/null
+++ b/science/checkmol/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: checkmol
+# Date created: 23 Feb 2009
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= checkmol
+PORTVERSION= 0.4a
+CATEGORIES= science
+MASTER_SITES= http://merian.pch.univie.ac.at/pch/download/chemistry/checkmol/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .pas
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Analyze molecules for the presence of functional groups
+
+USE_FPC= yes
+PLIST_FILES= bin/checkmol bin/matchmol
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/
+do-build:
+ cd ${WRKDIR}; ${LOCALBASE}/bin/fpc ${DISTFILES} -S2 -O3 -Op3
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
+ ${LN} ${PREFIX}/bin/${PORTNAME} ${PREFIX}/bin/matchmol
+
+.include <bsd.port.mk>
diff --git a/science/checkmol/distinfo b/science/checkmol/distinfo
new file mode 100644
index 000000000000..0d3f6287739f
--- /dev/null
+++ b/science/checkmol/distinfo
@@ -0,0 +1,3 @@
+MD5 (checkmol.pas) = 01e7eacacf82e4ead63bf0c1113691e9
+SHA256 (checkmol.pas) = c69bc8dfd99b0735b4359995ce1480883022d6dab0cb751a4fc22685496bd5d7
+SIZE (checkmol.pas) = 443374
diff --git a/science/checkmol/pkg-descr b/science/checkmol/pkg-descr
new file mode 100644
index 000000000000..8a25fdab05b4
--- /dev/null
+++ b/science/checkmol/pkg-descr
@@ -0,0 +1,27 @@
+Checkmol is a command-line utility program which reads molecular
+structure files in different formats and analyzes the input
+molecule for the presence of various functional groups and structural
+elements. At present, approx. 200 different functional groups are
+recognized. This output can be easily placed into a database table,
+permitting the creation of chemical databases with a functional group
+search option. Checkmol also outputs a set of statistical values derived
+from a given molecule, which can also be used for quick retrieval from a
+database. These values include: the number of atoms, bonds, and rings,
+the number of differently hybridized carbon, oxgen, and nitrogen atoms,
+the number of C=O double bonds, the number of rings of different sizes,
+the number of rings containing nitrogen, oxygen, sulfur, the number of
+aromatic rings, the number of heterocyclic rings, etc. The combination
+of all of these values for a given molecule represents some kind of
+"fingerprint" which is useful for rapid pre-selection in a database
+structure/substructure search prior to a full atom-by-atom match.
+
+Matchmol complements the capabilities of checkmol. It compares two (or
+more) molecular structures and determines whether one of them is a
+substructure of the other one. This is done by a full atom-by-atom
+comparison of the input structures. Thus, matchmol can be used as a
+back-end program for structure/substructure search operations in
+chemical databases.
+
+The port installs both checkmol and matchmol.
+
+WWW: http://merian.pch.univie.ac.at/~nhaider/cheminf/cmmm.html