aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-25 21:59:18 +0800
committermakc <makc@FreeBSD.org>2013-03-25 21:59:18 +0800
commit52c8b8dbfabe030aebbed0798a9bb28a55a6bdb5 (patch)
tree1d27ca2d039529c76a566a8c0a9c299a70c97787
parentcbe6c6cf034e14dfe24ebae988e72183782c537a (diff)
downloadfreebsd-ports-gnome-52c8b8dbfabe030aebbed0798a9bb28a55a6bdb5.tar.gz
freebsd-ports-gnome-52c8b8dbfabe030aebbed0798a9bb28a55a6bdb5.tar.zst
freebsd-ports-gnome-52c8b8dbfabe030aebbed0798a9bb28a55a6bdb5.zip
- Add global options (DOCS, NLS, etc) to the OPTIONS_DEFINE if it's
already defined - Remove OPTIONS_DEFINE, if it contains only global options
-rw-r--r--devel/qdevelop/Makefile2
-rw-r--r--games/warmux/Makefile2
-rw-r--r--graphics/xaos/Makefile2
-rw-r--r--math/qtiplot/Makefile2
-rw-r--r--multimedia/minitube/Makefile2
-rw-r--r--print/hplip/Makefile2
-rw-r--r--textproc/qstardict/Makefile2
7 files changed, 6 insertions, 8 deletions
diff --git a/devel/qdevelop/Makefile b/devel/qdevelop/Makefile
index 81676fb7873f..8fcaa9c42dfc 100644
--- a/devel/qdevelop/Makefile
+++ b/devel/qdevelop/Makefile
@@ -30,7 +30,7 @@ DESKTOP_ENTRIES= "QDevelop" \
"Development;IDE;Qt;" \
"false"
-OPTIONS_DEFINE= TOOLS
+OPTIONS_DEFINE= TOOLS DOCS NLS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
TOOLS_DESC= Install Qt4 dev. tools (qmake, moc, etc.)
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
index 9ec7fc3c196b..6a3277c798a8 100644
--- a/games/warmux/Makefile
+++ b/games/warmux/Makefile
@@ -30,7 +30,7 @@ USE_DOS2UNIX= fixed_class.h
MANCOMPRESSED= no
MAN6= warmux.6
-OPTIONS_DEFINE= FRIBIDI SERVER
+OPTIONS_DEFINE= FRIBIDI SERVER NLS
FRIBIDI_DESC= Enable bi-directional unicode support
SERVER_DESC= Enable dedicated server
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index 28db455f8588..cc3005f4533b 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -16,7 +16,7 @@ USE_XORG= x11 xext
GNU_CONFIGURE= yes
USE_GMAKE= yes
-OPTIONS_DEFINE= GTK2 PTHREAD
+OPTIONS_DEFINE= GTK2 PTHREAD NLS
GTK2_DESC= GTK+ User Interface (experimental)
PTHREAD_DESC= Enable SMP support (experimental)
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 283abca378eb..1434caa159ef 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -33,7 +33,7 @@ DESKTOP_ENTRIES="QtiPlot" "Data analysis and plotting" \
"${DATADIR}/qtiplot.png" \
"qtiplot" "" false
-OPTIONS_DEFINE= DOCS PYTHON
+OPTIONS_DEFINE= DOCS PYTHON NLS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
DOCS_DESC= Install the QtiPlot Handbook
diff --git a/multimedia/minitube/Makefile b/multimedia/minitube/Makefile
index bbb5f9fc0bdc..73caf38ac9e4 100644
--- a/multimedia/minitube/Makefile
+++ b/multimedia/minitube/Makefile
@@ -22,8 +22,6 @@ LRELEASE= ${LOCALBASE}/bin/lrelease-qt4
STRIP_FILES= bin/minitube
-OPTIONS_DEFINE= NLS
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 78263913f70d..1ad61664a984 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -73,7 +73,7 @@ FILES4FIX= Makefile.in \
ui/setupform.py \
ui4/devmgr5.py
-OPTIONS_DEFINE= QT FAX SNMP SCAN XSANE
+OPTIONS_DEFINE= QT FAX SNMP SCAN XSANE DOCS
OPTIONS_DEFAULT= QT
QT_DESC= Graphical User Interface (Qt4)
diff --git a/textproc/qstardict/Makefile b/textproc/qstardict/Makefile
index 147f8b9d2170..6b72fcff3526 100644
--- a/textproc/qstardict/Makefile
+++ b/textproc/qstardict/Makefile
@@ -20,7 +20,7 @@ USE_DOS2UNIX= qstardict.pri
DICPATH= ${LOCALBASE}/share/stardict/dic
-OPTIONS_DEFINE= DBUS
+OPTIONS_DEFINE= DBUS DOCS NLS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
.include <bsd.port.options.mk>