aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-25 17:38:40 +0800
committermiwi <miwi@FreeBSD.org>2011-06-25 17:38:40 +0800
commit530d641e531a4ef175536e73fe330705f16aa595 (patch)
treeb8bc59a798fe3349b77e7041912d2203bb4cf8cb
parent15ef543df6242e934ab5fb706d4e4a6898e90961 (diff)
downloadfreebsd-ports-gnome-530d641e531a4ef175536e73fe330705f16aa595.tar.gz
freebsd-ports-gnome-530d641e531a4ef175536e73fe330705f16aa595.tar.zst
freebsd-ports-gnome-530d641e531a4ef175536e73fe330705f16aa595.zip
Sphinx is a full-text search engine, distributed under GPL version
2. Commercial license is also available for embedded use. Generally, it's a standalone search engine, meant to provide fast, size-efficient and relevant fulltext search functions to other applications. Sphinx was specially designed to integrate well with SQL databases and scripting languages. Currently built-in data sources support fetching data either via direct connection to MySQL, or from an XML pipe. As for the name, Sphinx is an acronym which is officially decoded as SQL Phrase Index. WWW: http://www.sphinxsearch.com/ PR: ports/157654 Submitted by: Max Baryshnikov <mephius at gmail.com>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libsphinxclient/Makefile39
-rw-r--r--textproc/libsphinxclient/distinfo2
-rw-r--r--textproc/libsphinxclient/files/patch-sphinxclient.c12
-rw-r--r--textproc/libsphinxclient/pkg-descr14
-rw-r--r--textproc/libsphinxclient/pkg-plist6
6 files changed, 74 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 18aa2e1ded7f..66d3dfe31ad7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -335,6 +335,7 @@
SUBDIR += libparsifal
SUBDIR += libpathan
SUBDIR += libroxml
+ SUBDIR += libsphinxclient
SUBDIR += libstree
SUBDIR += libtext-charwidth-perl
SUBDIR += libtext-wrapi18n-perl
diff --git a/textproc/libsphinxclient/Makefile b/textproc/libsphinxclient/Makefile
new file mode 100644
index 000000000000..d80970a4c5a2
--- /dev/null
+++ b/textproc/libsphinxclient/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: libsphinxclient
+# Date created: 2011-06-6
+# Whom: Max Baryshnikov <mephius@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsphinxclient
+DISTVERSION= 1.10b
+CATEGORIES= textproc databases
+MASTER_SITES= http://sphinxsearch.com/files/
+DISTNAME= sphinx-1.10-beta
+
+MAINTAINER= mephius@gmail.com
+COMMENT= Sphinx Full-Text Search Engine C++ client library
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/api/libsphinxclient
+
+USE_LDCONFIG= yes
+
+LICENSE= GPLv2
+
+USE_AUTOTOOLS= libtool
+
+.include <bsd.port.options.mk>
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CC=${CC}
+SUB_LIST+= PORTNAME=${PORTNAME}
+
+do-install:
+ ${INSTALL_LIB} ${WRKSRC}/.libs/libsphinxclient-0.0.1.so ${PREFIX}/lib/libsphinxclient-0.0.1.so
+ ${INSTALL_DATA} ${WRKSRC}/libsphinxclient.la ${PREFIX}/lib/libsphinxclient.la
+ ${INSTALL_DATA} ${WRKSRC}/.libs/libsphinxclient.a ${PREFIX}/lib/libsphinxclient.a
+ ${INSTALL_DATA} ${WRKSRC}/sphinxclient.h ${PREFIX}/include/sphinxclient.h
+ ${LN} -s ${PREFIX}/lib/libsphinxclient-0.0.1.so ${PREFIX}/lib/libsphinxclient.so.0
+ ${LN} -s ${PREFIX}/lib/libsphinxclient-0.0.1.so ${PREFIX}/lib/libsphinxclient.so
+
+.include <bsd.port.mk>
diff --git a/textproc/libsphinxclient/distinfo b/textproc/libsphinxclient/distinfo
new file mode 100644
index 000000000000..764a131835bc
--- /dev/null
+++ b/textproc/libsphinxclient/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sphinx-1.10-beta.tar.gz) = 51b3e5f3254b4d93d6dce91a44451486e5b0f82a1e44799481158e1f95fc1c60
+SIZE (sphinx-1.10-beta.tar.gz) = 1518778
diff --git a/textproc/libsphinxclient/files/patch-sphinxclient.c b/textproc/libsphinxclient/files/patch-sphinxclient.c
new file mode 100644
index 000000000000..068ffee92c41
--- /dev/null
+++ b/textproc/libsphinxclient/files/patch-sphinxclient.c
@@ -0,0 +1,12 @@
+--- sphinxclient.c.orig 2010-07-15 15:05:40.000000000 +0400
++++ sphinxclient.c 2011-06-03 17:56:23.000000000 +0400
+@@ -17,9 +17,6 @@
+ // VS 2005 and above
+ #define _CRT_SECURE_NO_DEPRECATE 1
+ #define _CRT_NONSTDC_NO_DEPRECATE 1
+-#else
+-// VS 2003 and below
+-#define vsnprintf _vsnprintf
+ #endif
+
+ #include <stdlib.h>
diff --git a/textproc/libsphinxclient/pkg-descr b/textproc/libsphinxclient/pkg-descr
new file mode 100644
index 000000000000..59b3fdaa98a7
--- /dev/null
+++ b/textproc/libsphinxclient/pkg-descr
@@ -0,0 +1,14 @@
+Sphinx is a full-text search engine, distributed under GPL version
+2. Commercial license is also available for embedded use.
+
+Generally, it's a standalone search engine, meant to provide fast,
+size-efficient and relevant fulltext search functions to other
+applications. Sphinx was specially designed to integrate well with SQL
+databases and scripting languages. Currently built-in data sources
+support fetching data either via direct connection to MySQL, or from
+an XML pipe.
+
+As for the name, Sphinx is an acronym which is officially decoded as
+SQL Phrase Index.
+
+WWW: http://www.sphinxsearch.com/
diff --git a/textproc/libsphinxclient/pkg-plist b/textproc/libsphinxclient/pkg-plist
new file mode 100644
index 000000000000..111d4be31e02
--- /dev/null
+++ b/textproc/libsphinxclient/pkg-plist
@@ -0,0 +1,6 @@
+lib/libsphinxclient-0.0.1.so
+lib/libsphinxclient.so.0
+lib/libsphinxclient.a
+lib/libsphinxclient.la
+lib/libsphinxclient.so
+include/sphinxclient.h