aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2008-02-27 09:48:58 +0800
committeralepulver <alepulver@FreeBSD.org>2008-02-27 09:48:58 +0800
commit53f90c7b523aa2c13d58ca8b8e23200a4c1bdae8 (patch)
tree4d383d4ab31f8ed60c3d06f08fcfe817042b2f05
parent412ea7140a1e36f56e38c0f9b83088a6b6233cbf (diff)
downloadfreebsd-ports-gnome-53f90c7b523aa2c13d58ca8b8e23200a4c1bdae8.tar.gz
freebsd-ports-gnome-53f90c7b523aa2c13d58ca8b8e23200a4c1bdae8.tar.zst
freebsd-ports-gnome-53f90c7b523aa2c13d58ca8b8e23200a4c1bdae8.zip
- Add patch to fix building in 5.x [1].
- Use ${LOCALBASE}/bin/gperf in dependency as that's the one passed to configure, and it won't be installed if the base system one is found. Reported by: pointyhat (pav, erwin) [1]
-rw-r--r--x11/xcb-util/Makefile2
-rw-r--r--x11/xcb-util/files/patch-image__test_xcb_image_shm.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11/xcb-util/Makefile b/x11/xcb-util/Makefile
index 281e74cbd79c..e6a1e195c5ff 100644
--- a/x11/xcb-util/Makefile
+++ b/x11/xcb-util/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ntarmos@ceid.upatras.gr
COMMENT= A module with libxcb/libX11 extension/replacement libraries
LIB_DEPENDS= xcb.1:${PORTSDIR}/x11/libxcb
-BUILD_DEPENDS= gperf:${PORTSDIR}/devel/gperf
+BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/x11/xcb-util/files/patch-image__test_xcb_image_shm.c b/x11/xcb-util/files/patch-image__test_xcb_image_shm.c
new file mode 100644
index 000000000000..257e8b284a14
--- /dev/null
+++ b/x11/xcb-util/files/patch-image__test_xcb_image_shm.c
@@ -0,0 +1,10 @@
+--- ./image/test_xcb_image_shm.c.orig 2006-10-07 16:41:22.000000000 -0300
++++ ./image/test_xcb_image_shm.c 2008-02-26 23:14:44.000000000 -0300
+@@ -1,6 +1,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++#include <sys/types.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+