aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2003-10-29 00:31:34 +0800
committerbland <bland@FreeBSD.org>2003-10-29 00:31:34 +0800
commit53fe87f622dc232017409d4a8f0b83a8081f6a20 (patch)
tree8abde99d196ed085793b96e3740035ca63d34845
parentd03cf6353027d86ab91d464f8d5aad1f4f6b8a77 (diff)
downloadfreebsd-ports-gnome-53fe87f622dc232017409d4a8f0b83a8081f6a20.tar.gz
freebsd-ports-gnome-53fe87f622dc232017409d4a8f0b83a8081f6a20.tar.zst
freebsd-ports-gnome-53fe87f622dc232017409d4a8f0b83a8081f6a20.zip
Speedup raster image printing for metafile. Let's say dramatically.
-rw-r--r--print/libgnomeprint/Makefile1
-rw-r--r--print/libgnomeprint/files/patch-libgnomeprint::gnome-meta.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index b31c561e7782..9c65386568de 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libgnomeprint
PORTVERSION= 2.4.0
+PORTREVISION= 1
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4
diff --git a/print/libgnomeprint/files/patch-libgnomeprint::gnome-meta.c b/print/libgnomeprint/files/patch-libgnomeprint::gnome-meta.c
new file mode 100644
index 000000000000..5526dceaa446
--- /dev/null
+++ b/print/libgnomeprint/files/patch-libgnomeprint::gnome-meta.c
@@ -0,0 +1,10 @@
+--- libgnomeprint/gnome-print-meta.c.orig Wed Oct 29 00:53:15 2003
++++ libgnomeprint/gnome-print-meta.c Wed Oct 29 01:06:23 2003
+@@ -312,6 +312,7 @@
+ gpm_encode_int (pc, w);
+ gpm_encode_int (pc, ch);
+
++ gpm_ensure_space(pc, w * ch * h);
+ for (y = 0; y < h; y++){
+ gpm_encode_block (pc, px, w * ch);
+ px += rowstride;