aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-04-25 05:11:29 +0800
committeralepulver <alepulver@FreeBSD.org>2006-04-25 05:11:29 +0800
commit54c0a12a45ddc19bcb5f76af677788871f9babb3 (patch)
treee59d4928253b0e3d8f2d2070c3dd2dfb4878f626
parent03e6a24a88518f3d0d053a6f414f0a9d2c316000 (diff)
downloadfreebsd-ports-gnome-54c0a12a45ddc19bcb5f76af677788871f9babb3.tar.gz
freebsd-ports-gnome-54c0a12a45ddc19bcb5f76af677788871f9babb3.tar.zst
freebsd-ports-gnome-54c0a12a45ddc19bcb5f76af677788871f9babb3.zip
- Remove USE_REINPLACE.
- Fix OPTIONS handling. - Remove '@' from installation commands. - Bump PORTREVISION. Approved by: garga (mentor)
-rw-r--r--games/quake-source/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/games/quake-source/Makefile b/games/quake-source/Makefile
index a2cae26b56ce..881dafc1d454 100644
--- a/games/quake-source/Makefile
+++ b/games/quake-source/Makefile
@@ -7,6 +7,7 @@
PORTNAME= source
PORTVERSION= 1.01
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
MASTER_SITE_SUBDIR= source
@@ -28,10 +29,9 @@ LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
.include <bsd.port.pre.mk>
-.if defined(WITH_QUAKEWORLD)
+.if !defined(WITHOUT_QUAKEWORLD)
MASTER_SITES+= ${MASTER_SITE_IDSOFTWARE:S|$|quakeworld/unix/:qw|}
DISTFILES+= qwsv-2.30-glibc-i386-unknown-linux2.0${EXTRACT_SUFX}:qw
-USE_REINPLACE= yes
PLIST_SUB+= QUAKEWORLD=""
.else
PLIST_SUB+= QUAKEWORLD="@comment "
@@ -46,13 +46,13 @@ post-patch:
@${RM} ${WRKSRC}/send/v101qc/progs.src.orig
do-install:
- @${MKDIR} ${DATADIR}
- @${CP} -R ${WRKSRC}/send/v101qc ${DATADIR}
-.if defined(WITH_QUAKEWORLD)
- @${MKDIR} ${DATADIR}/qw
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/send/v101qc ${DATADIR}
+.if !defined(WITHOUT_QUAKEWORLD)
+ ${MKDIR} ${DATADIR}/qw
. for f in *.h *.qc *.src
@${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" ${WRKSRC}/qw/${f}
- @${INSTALL_DATA} ${WRKSRC}/qw/${f} ${DATADIR}/qw
+ ${INSTALL_DATA} ${WRKSRC}/qw/${f} ${DATADIR}/qw
. endfor
.endif