aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoremaste <emaste@FreeBSD.org>2015-06-25 21:12:20 +0800
committeremaste <emaste@FreeBSD.org>2015-06-25 21:12:20 +0800
commit557064547448318d6edb89f245f337b66c5039e9 (patch)
tree9b9269b9d085d7b77c3d36aefccd563f4864f4b4
parentb1edc1ad4e18659f01f5d6006dc4306e6eb521f6 (diff)
downloadfreebsd-ports-gnome-557064547448318d6edb89f245f337b66c5039e9.tar.gz
freebsd-ports-gnome-557064547448318d6edb89f245f337b66c5039e9.tar.zst
freebsd-ports-gnome-557064547448318d6edb89f245f337b66c5039e9.zip
lang/lua{51,52,53}: Add -fPIC for arm64
Reviewed by: andrew Approved by: bapt Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D2904
-rw-r--r--lang/lua51/Makefile1
-rw-r--r--lang/lua52/Makefile1
-rw-r--r--lang/lua53/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/lang/lua51/Makefile b/lang/lua51/Makefile
index 15404b31d7fe..a2c1140856f0 100644
--- a/lang/lua51/Makefile
+++ b/lang/lua51/Makefile
@@ -52,6 +52,7 @@ LUA_SUBDIR?= lua${PKGNAMESUFFIX}
LUA_INCDIR?= ${LUA_PREFIX}/include/${LUA_SUBDIR}
LUA_LIBDIR?= ${LUA_PREFIX}/lib
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_powerpc= -fPIC
diff --git a/lang/lua52/Makefile b/lang/lua52/Makefile
index 516f474e85ea..eff60af9e418 100644
--- a/lang/lua52/Makefile
+++ b/lang/lua52/Makefile
@@ -57,6 +57,7 @@ SUB_LIST= version=${PORTVERSION} \
libdir=${LUA_LIBDIR} \
soname=lua-${LUA_VER}
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_powerpc= -fPIC
diff --git a/lang/lua53/Makefile b/lang/lua53/Makefile
index 638b0d5d767e..a07f7fe89304 100644
--- a/lang/lua53/Makefile
+++ b/lang/lua53/Makefile
@@ -57,6 +57,7 @@ SUB_LIST= version=${PORTVERSION} \
libdir=${LUA_LIBDIR} \
soname=lua-${LUA_VER}
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_powerpc= -fPIC