diff options
author | bdrewery <bdrewery@FreeBSD.org> | 2012-10-16 00:14:35 +0800 |
---|---|---|
committer | bdrewery <bdrewery@FreeBSD.org> | 2012-10-16 00:14:35 +0800 |
commit | 568c058b2436b30e1a1c287837593cef059479da (patch) | |
tree | 757baee885b778a3bae9419bce25da5a7346e7b0 | |
parent | 5d78c3dbb5074f0cb01eb4fada115b3cdf0364ae (diff) | |
download | freebsd-ports-gnome-568c058b2436b30e1a1c287837593cef059479da.tar.gz freebsd-ports-gnome-568c058b2436b30e1a1c287837593cef059479da.tar.zst freebsd-ports-gnome-568c058b2436b30e1a1c287837593cef059479da.zip |
- Add ports-mgmt/pkg as a RUN_DEPENDS if enabling pkgng support
- Add UPDATING entry and pkg-message to assist in converting
Feature safe: yes
-rw-r--r-- | UPDATING | 13 | ||||
-rw-r--r-- | ports-mgmt/portmaster/Makefile | 6 | ||||
-rw-r--r-- | ports-mgmt/portmaster/pkg-message | 10 |
3 files changed, 28 insertions, 1 deletions
@@ -6,6 +6,19 @@ You should get into the habit of checking this file for changes each time you update your ports collection, before attempting any port upgrades. 20121015: + AFFECTS: users of ports-mgmt/portmaster + AUTHOR: bdrewery@FreeBSD.org + + Portmaster now support pkgng. To use pkgng, enable the patch in the port, + enable pkgng in your make.conf, and convert your existing /var/db/pkg + database. Also see UPDATING entry 20121010 if you are on a recent CURRENT + and do not want to use pkg. + + # make -C /usr/ports/ports-mgmt/portmaster config build deinstall install clean + # echo 'WITH_PKGNG=yes' >> /etc/make.conf + # pkg2ng + +20121015: AFFECTS: users of ports-mgmt/portupgrade AUTHOR: bdrewery@FreeBSD.org diff --git a/ports-mgmt/portmaster/Makefile b/ports-mgmt/portmaster/Makefile index fe98313d1470..40beee04888d 100644 --- a/ports-mgmt/portmaster/Makefile +++ b/ports-mgmt/portmaster/Makefile @@ -2,7 +2,7 @@ PORTNAME= portmaster PORTVERSION= 3.14 -PORTREVISION= 2 +PORTREVISION= 3 CATEGORIES= ports-mgmt MASTER_SITES= GH \ http://mirror.shatow.net/freebsd/portmaster/ @@ -30,6 +30,7 @@ MAN8= portmaster.8 .include <bsd.port.options.mk> .if ${PORT_OPTIONS:MPKGNGPATCH} +RUN_DEPENDS+= pkg>0:${PORTSDIR}/ports-mgmt/pkg PATCH_SITES+= http://mirror.shatow.net/freebsd/portmaster/ PATCHFILES+= patch-portmaster-pkgng.gz .endif @@ -67,5 +68,8 @@ post-install: ${INSTALL_DATA} ${WRKSRC}/files/zsh-completions \ ${PREFIX}/share/zsh/site-functions/_portmaster .endif +.if ${PORT_OPTIONS:MPKGNGPATCH} + ${CAT} ${PKGMESSAGE} +.endif .include <bsd.port.mk> diff --git a/ports-mgmt/portmaster/pkg-message b/ports-mgmt/portmaster/pkg-message new file mode 100644 index 000000000000..b6113c63eae0 --- /dev/null +++ b/ports-mgmt/portmaster/pkg-message @@ -0,0 +1,10 @@ +If you are upgrading from the old package format, there are 2 +extra steps required. + +Enable PKGNG as your package format: + + # echo 'WITH_PKGNG=yes' >> /etc/make.conf + +Then convert your /var/db/pkg database to the new pkg format: + + # pkg2ng |