aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-02-17 12:23:00 +0800
committeradamw <adamw@FreeBSD.org>2016-02-17 12:23:00 +0800
commit56ee6a514383ce45c4b95a2d2d543a7a24f26a8e (patch)
tree729515e0c2ca6f8fa7c3291c77683aff7c2c0054
parentc1915694a1de9c2777056df6e8229d255efc2c48 (diff)
downloadfreebsd-ports-gnome-56ee6a514383ce45c4b95a2d2d543a7a24f26a8e.tar.gz
freebsd-ports-gnome-56ee6a514383ce45c4b95a2d2d543a7a24f26a8e.tar.zst
freebsd-ports-gnome-56ee6a514383ce45c4b95a2d2d543a7a24f26a8e.zip
Add security/p5-Crypt-XTEA, and its dependency lang/p5-Scalar-Util-Numeric.
Crypt::XTEA implements the fast and light XTEA cipher that supports the Crypt::CBC interface. https://metacpan.org/pod/Crypt::XTEA Scalar::Util::Numeric implements some scalar classification routines with an XS module. https://metacpan.org/pod/Scalar::Util::Numeric
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-Scalar-Util-Numeric/Makefile22
-rw-r--r--lang/p5-Scalar-Util-Numeric/distinfo2
-rw-r--r--lang/p5-Scalar-Util-Numeric/pkg-descr5
-rw-r--r--lang/p5-Scalar-Util-Numeric/pkg-plist3
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-XTEA/Makefile26
-rw-r--r--security/p5-Crypt-XTEA/distinfo2
-rw-r--r--security/p5-Crypt-XTEA/pkg-descr13
-rw-r--r--security/p5-Crypt-XTEA/pkg-plist3
10 files changed, 78 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 2b0282b14a9a..3e0c464d5271 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -221,6 +221,7 @@
SUBDIR += p5-Pugs-Compiler-Rule
SUBDIR += p5-Quantum-Superpositions
SUBDIR += p5-Scalar-List-Utils
+ SUBDIR += p5-Scalar-Util-Numeric
SUBDIR += p5-Switch
SUBDIR += p5-Tcl
SUBDIR += p5-Test-XPath
diff --git a/lang/p5-Scalar-Util-Numeric/Makefile b/lang/p5-Scalar-Util-Numeric/Makefile
new file mode 100644
index 000000000000..1be2e91c9742
--- /dev/null
+++ b/lang/p5-Scalar-Util-Numeric/Makefile
@@ -0,0 +1,22 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Scalar-Util-Numeric
+PORTVERSION= 0.40
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Numeric tests for perl scalars
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Scalar/Util/Numeric/Numeric.so
+
+.include <bsd.port.mk>
diff --git a/lang/p5-Scalar-Util-Numeric/distinfo b/lang/p5-Scalar-Util-Numeric/distinfo
new file mode 100644
index 000000000000..0dfdb7635656
--- /dev/null
+++ b/lang/p5-Scalar-Util-Numeric/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Scalar-Util-Numeric-0.40.tar.gz) = d7501b6d410703db5b1c1942fbfc41af8964a35525d7f766058acf5ca2cc4440
+SIZE (Scalar-Util-Numeric-0.40.tar.gz) = 52757
diff --git a/lang/p5-Scalar-Util-Numeric/pkg-descr b/lang/p5-Scalar-Util-Numeric/pkg-descr
new file mode 100644
index 000000000000..0d001ed34b89
--- /dev/null
+++ b/lang/p5-Scalar-Util-Numeric/pkg-descr
@@ -0,0 +1,5 @@
+This module exports a number of wrappers around perl's builtin grok_number
+function, which returns the numeric type of its argument, or 0 if it isn't
+numeric.
+
+WWW: https://metacpan.org/pod/Scalar::Util::Numeric
diff --git a/lang/p5-Scalar-Util-Numeric/pkg-plist b/lang/p5-Scalar-Util-Numeric/pkg-plist
new file mode 100644
index 000000000000..dfd381cbfaaa
--- /dev/null
+++ b/lang/p5-Scalar-Util-Numeric/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_ARCH%%/Scalar/Util/Numeric.pm
+%%SITE_ARCH%%/auto/Scalar/Util/Numeric/Numeric.so
+%%PERL5_MAN3%%/Scalar::Util::Numeric.3.gz
diff --git a/security/Makefile b/security/Makefile
index c513f93389e4..9645a0357cff 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -572,6 +572,7 @@
SUBDIR += p5-Crypt-UnixCrypt
SUBDIR += p5-Crypt-UnixCrypt_XS
SUBDIR += p5-Crypt-X509
+ SUBDIR += p5-Crypt-XTEA
SUBDIR += p5-Crypt-xDBM_File
SUBDIR += p5-CryptX
SUBDIR += p5-Dancer-Plugin-Auth-Extensible
diff --git a/security/p5-Crypt-XTEA/Makefile b/security/p5-Crypt-XTEA/Makefile
new file mode 100644
index 000000000000..aeeadcc29488
--- /dev/null
+++ b/security/p5-Crypt-XTEA/Makefile
@@ -0,0 +1,26 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Crypt-XTEA
+PORTVERSION= 0.0107
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Implementation of the eXtended Tiny Encryption Algorithm
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Scalar-Util-Numeric>=0.40:${PORTSDIR}/lang/p5-Scalar-Util-Numeric
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Crypt/XTEA/XTEA.so
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-XTEA/distinfo b/security/p5-Crypt-XTEA/distinfo
new file mode 100644
index 000000000000..45294bcfc293
--- /dev/null
+++ b/security/p5-Crypt-XTEA/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-XTEA-0.0107.tar.gz) = bb25595caaca4847ce9462b63727e5e17978e3c48c2778a6fe4f535d81414722
+SIZE (Crypt-XTEA-0.0107.tar.gz) = 57495
diff --git a/security/p5-Crypt-XTEA/pkg-descr b/security/p5-Crypt-XTEA/pkg-descr
new file mode 100644
index 000000000000..392cc8051f2b
--- /dev/null
+++ b/security/p5-Crypt-XTEA/pkg-descr
@@ -0,0 +1,13 @@
+In cryptography, XTEA (eXtended TEA) is a block cipher designed to correct
+weaknesses in TEA. The cipher's designers were David Wheeler and Roger Needham
+of the Cambridge Computer Laboratory, and the algorithm was presented in an
+unpublished technical report in 1997 (Needham and Wheeler, 1997). It is not
+subject to any patents.
+
+Like TEA, XTEA is a 64-bit block Feistel cipher with a 128-bit key and a
+suggested 64 Feistel rounds (i.e 32 cycles). Crypt::XTEA uses the recommended
+value of 32 cycles by default.
+
+This module implements XTEA encryption. It supports the Crypt::CBC interface.
+
+WWW: https://metacpan.org/pod/Crypt::XTEA
diff --git a/security/p5-Crypt-XTEA/pkg-plist b/security/p5-Crypt-XTEA/pkg-plist
new file mode 100644
index 000000000000..abba8c3c7ff3
--- /dev/null
+++ b/security/p5-Crypt-XTEA/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_ARCH%%/Crypt/XTEA.pm
+%%SITE_ARCH%%/auto/Crypt/XTEA/XTEA.so
+%%PERL5_MAN3%%/Crypt::XTEA.3.gz