aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-01-05 19:48:17 +0800
committergarga <garga@FreeBSD.org>2010-01-05 19:48:17 +0800
commit572f8ea4e0f59173c231d2320b3111d9cb689b75 (patch)
tree19b0f3eefac63801da34931c3c28e4161780b508
parent7b02c392e7e44fd63a3797d56b3605b0803c9af0 (diff)
downloadfreebsd-ports-gnome-572f8ea4e0f59173c231d2320b3111d9cb689b75.tar.gz
freebsd-ports-gnome-572f8ea4e0f59173c231d2320b3111d9cb689b75.tar.zst
freebsd-ports-gnome-572f8ea4e0f59173c231d2320b3111d9cb689b75.zip
Define rules for PORTSCOUT checking in some of my ports
-rw-r--r--archivers/arj/Makefile2
-rw-r--r--mail/qmail/Makefile2
-rw-r--r--mail/razor-agents/Makefile2
-rw-r--r--security/clamav-devel/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/archivers/arj/Makefile b/archivers/arj/Makefile
index da2c6d9fc0c3..c87669e432c9 100644
--- a/archivers/arj/Makefile
+++ b/archivers/arj/Makefile
@@ -34,6 +34,8 @@ PLIST_DIRS= lib/arj
MAN1= arj-register.1 arj.1 arjdisp.1 rearj.1
+PORTSCOUT= skipv:3.10g
+
post-patch:
@${REINPLACE_CMD} -e 's!/etc!${LOCALBASE}/etc!' \
${WRKSRC}/arj.c ${WRKSRC}/file_reg.c ${WRKSRC}/rearj.c
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index e8f344237464..852b5bf9c68c 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -24,6 +24,8 @@ CONFLICTS+= qmail-vida-[0-9]*
MAKE_JOBS_UNSAFE= yes
+PORTSCOUT= skipv:1.04
+
.if defined(SLAVE_LDAP) || \
defined(SLAVE_MYSQL)
BARRIER_MAILDIRQUOTA_PATCH= yes
diff --git a/mail/razor-agents/Makefile b/mail/razor-agents/Makefile
index 09374ed421a6..e318fffb1425 100644
--- a/mail/razor-agents/Makefile
+++ b/mail/razor-agents/Makefile
@@ -29,6 +29,8 @@ MAN3= Razor2::Errorhandler.3 Razor2::Preproc::deHTMLxs.3 \
Razor2::Syslog.3
MAN5= razor-agents.5 razor-whitelist.5 razor-agent.conf.5
+PORTSCOUT= skipv:2.85
+
post-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e 's|/etc/razor|${PREFIX}/etc|g'
@${PERL} -pi -e 's,share/man,man,g' ${WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index bb28733b4524..1e0be3f810a2 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -109,6 +109,8 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
CLAMAVGROUP=${CLAMAVGROUP}
+PORTSCOUT= ignore:1
+
.include <bsd.port.pre.mk>
.if defined(WITH_ARC)