aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-04-25 00:20:31 +0800
committermat <mat@FreeBSD.org>2015-04-25 00:20:31 +0800
commit57f570808d77147533b31ea372cce8f6d525f3f6 (patch)
tree1c5538437c9365d2220789eb77ec1a0dc205e18a
parent4d75df1a941b052e39be2996a3c808cacfdad265 (diff)
downloadfreebsd-ports-gnome-57f570808d77147533b31ea372cce8f6d525f3f6.tar.gz
freebsd-ports-gnome-57f570808d77147533b31ea372cce8f6d525f3f6.tar.zst
freebsd-ports-gnome-57f570808d77147533b31ea372cce8f6d525f3f6.zip
Fix security/p5-Crypt-{TEA,GOST} and undeprecate dependency.
Sponsored by: Absolight
-rw-r--r--net/p5-OurNet-BBS/Makefile3
-rw-r--r--security/p5-Crypt-GOST/Makefile11
-rw-r--r--security/p5-Crypt-GOST/files/patch-GOST.xs15
-rw-r--r--security/p5-Crypt-TEA/Makefile11
-rw-r--r--security/p5-Crypt-TEA/files/patch-TEA.xs15
5 files changed, 32 insertions, 23 deletions
diff --git a/net/p5-OurNet-BBS/Makefile b/net/p5-OurNet-BBS/Makefile
index 47aaa12a55d3..3e541ffdfbf0 100644
--- a/net/p5-OurNet-BBS/Makefile
+++ b/net/p5-OurNet-BBS/Makefile
@@ -43,7 +43,4 @@ PORTSCOUT= skipv:1.67
USES= perl5
USE_PERL5= configure
-DEPRECATED= Needs p5-Crypt-Tea that does not work with 5.18 or above
-EXPIRATION_DATE=2015-07-31
-
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-GOST/Makefile b/security/p5-Crypt-GOST/Makefile
index 7152e42e76e8..b470e70ee09b 100644
--- a/security/p5-Crypt-GOST/Makefile
+++ b/security/p5-Crypt-GOST/Makefile
@@ -14,13 +14,4 @@ COMMENT= Perl extension for GOST Encryption Algorithm
USES= perl5
USE_PERL5= configure
-DEPRECATED= Does not work with 5.18 or above
-EXPIRATION_DATE=2015-07-31
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_VER} >= 5.18
-BROKEN= Does not build with Perl 5.18 or above
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-GOST/files/patch-GOST.xs b/security/p5-Crypt-GOST/files/patch-GOST.xs
new file mode 100644
index 000000000000..04b4b02b7055
--- /dev/null
+++ b/security/p5-Crypt-GOST/files/patch-GOST.xs
@@ -0,0 +1,15 @@
+--- GOST.xs.orig 2001-05-13 14:11:35 UTC
++++ GOST.xs
+@@ -54,9 +54,11 @@ gost_crypt(self, input, output, decrypt)
+ output = sv_newmortal();
+ outlen = 8;
+
+- if (SvREADONLY(output) || !SvUPGRADE(output, SVt_PV))
++ if (SvREADONLY(output))
+ croak("cannot use output as lvalue");
+
++ SvUPGRADE(output, SVt_PV);
++
+ gost_crypt(self,
+ (unsigned char *)input,
+ (unsigned char *)SvGROW(output, outlen),
diff --git a/security/p5-Crypt-TEA/Makefile b/security/p5-Crypt-TEA/Makefile
index e8a013bdab1d..d145b76b3e8b 100644
--- a/security/p5-Crypt-TEA/Makefile
+++ b/security/p5-Crypt-TEA/Makefile
@@ -14,13 +14,4 @@ COMMENT= Perl extension to Tiny Encryption Algorithm
USES= perl5
USE_PERL5= configure
-DEPRECATED= Does not work with 5.18 or above
-EXPIRATION_DATE=2015-07-31
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_VER} >= 5.18
-BROKEN= Does not build with Perl 5.18 or above
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-TEA/files/patch-TEA.xs b/security/p5-Crypt-TEA/files/patch-TEA.xs
new file mode 100644
index 000000000000..a84a24f0c68c
--- /dev/null
+++ b/security/p5-Crypt-TEA/files/patch-TEA.xs
@@ -0,0 +1,15 @@
+--- TEA.xs.orig 2001-05-21 17:32:59 UTC
++++ TEA.xs
+@@ -55,9 +55,11 @@ tea_crypt(self, input, output, decrypt)
+ output = sv_newmortal();
+ outlen = 8;
+
+- if (SvREADONLY(output) || !SvUPGRADE(output, SVt_PV))
++ if (SvREADONLY(output))
+ croak("cannot use output as lvalue");
+
++ SvUPGRADE(output, SVt_PV);
++
+ tea_crypt(self,
+ (unsigned char *)input,
+ (unsigned char *)SvGROW(output, outlen),