aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-08-08 21:38:16 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-08-08 21:38:16 +0800
commit58c76bfde408f533b89ae39a95a8259499f3d319 (patch)
tree60a416d90a6f3e4f25fcc715967d360f58339932
parent5551bb21aa8b9f4423dc0ca6dac6f1e65ea10168 (diff)
downloadfreebsd-ports-gnome-58c76bfde408f533b89ae39a95a8259499f3d319.tar.gz
freebsd-ports-gnome-58c76bfde408f533b89ae39a95a8259499f3d319.tar.zst
freebsd-ports-gnome-58c76bfde408f533b89ae39a95a8259499f3d319.zip
- Fix MASTER_SITES
- Add LICENSE - Support USE_TK_WRAPPER - Support NOPORTDOCS PR: 159437 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
-rw-r--r--editors/impress/Makefile23
-rw-r--r--editors/impress/files/patch-Makefile43
-rw-r--r--editors/impress/files/patch-src_Makefile98
-rw-r--r--editors/impress/files/patch-src_impress_tcl11
-rw-r--r--editors/impress/pkg-plist26
5 files changed, 18 insertions, 183 deletions
diff --git a/editors/impress/Makefile b/editors/impress/Makefile
index 7f20c61207ca..02fe345f139d 100644
--- a/editors/impress/Makefile
+++ b/editors/impress/Makefile
@@ -7,18 +7,31 @@
PORTNAME= impress
PORTVERSION= 1.1b9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors tk
-MASTER_SITES= TUCOWS http://fresh.t-systems-sfr.com/unix/src/privat2/ \
- ftp://ftp.plig.net/pub/OpenBSD/distfiles/ \
- ftp://ftp.openoffice.pl/bsd/FreeBSD/ports/distfiles/
+MASTER_SITES= TUCOWS \
+ http://www.ntlug.org/~ccox/impress/
DISTNAME= imp${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Publishing and presentation tool
-USE_TK_RUN= 84
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_TK_WRAPPER= yes
+
+PORTDOCS= *
+PLIST_FILES= bin/impress
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/impress.tcl ${PREFIX}/bin/impress
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/src/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/editors/impress/files/patch-Makefile b/editors/impress/files/patch-Makefile
deleted file mode 100644
index 2c8910e0e81d..000000000000
--- a/editors/impress/files/patch-Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
---- Makefile.orig Fri Jun 29 10:22:48 2001
-+++ Makefile Fri Jun 29 10:25:52 2001
-@@ -1,33 +1,11 @@
--cmp=/usr/bin/cmp
--cp=/bin/cp
--mv=/bin/mv
--strip=/usr/bin/strip
--ln=/bin/ln
--PREFIX=/usr
-+PREFIX?=/usr/local
-
--all: make_impress make_font3d make_pstoedit
-+all: make_impress
-
--make_font3d:
-- (cd font3d;make LDFLAGS=-static)
-- @-${strip} font3d/font3d
-- @-${cmp} font3d/font3d bin/font3d 2>/dev/null || \
-- ${cp} font3d/font3d bin/font3d
--
--make_pstoedit:
-- (cd pstoedit/config;./configure)
-- (cd pstoedit/src;make LINK="c++ -static")
-- @-${strip} pstoedit/src/pstoedit
-- @-${cmp} pstoedit/src/pstoedit bin/pstoedit 2>/dev/null || \
-- ${cp} pstoedit/src/pstoedit bin/pstoedit
--
- make_impress:
-- (cd src;make all install)
--
--$(PREFIX)/bin/pstoedit.orig:
-- @-mv $(PREFIX)/bin/pstoedit $(PREFIX)/bin/pstoedit.orig
-+ (cd src;make all)
-
--install: $(PREFIX)/bin/pstoedit.orig
-- install -c bin/impress $(PREFIX)/bin && rm -f $(PREFIX)/bin/impress.tcl && ${ln} -s $(PREFIX)/bin/impress $(PREFIX)/bin/impress.tcl
-- install -c bin/transeps $(PREFIX)/bin
-- install -c bin/font3d $(PREFIX)/bin
-- install -c bin/pstoedit $(PREFIX)/bin
-+install:
-+ install -c -m 755 src/impress $(PREFIX)/bin
-+ @mkdir $(PREFIX)/share/doc/impress
-+ @cp src/doc/* $(PREFIX)/share/doc/impress
diff --git a/editors/impress/files/patch-src_Makefile b/editors/impress/files/patch-src_Makefile
deleted file mode 100644
index fe0b78497865..000000000000
--- a/editors/impress/files/patch-src_Makefile
+++ /dev/null
@@ -1,98 +0,0 @@
---- src/Makefile.orig Fri Jun 29 10:26:19 2001
-+++ src/Makefile Fri Jun 29 10:27:01 2001
-@@ -1,94 +1,8 @@
--cmp=/usr/bin/cmp
--cp=/bin/cp
--mv=/bin/mv
--ln=/bin/ln
--
--all: impress transeps
-+all: impress
-
- impress: impress.tcl
- cat impress.tcl >impress
- chmod a+x impress
--
--../pstoedit/src/drvbase.h.orig:
-- @-${mv} ../pstoedit/src/drvbase.h ../pstoedit/src/drvbase.h.orig
--
--../pstoedit/src/drvtk.cpp.orig:
-- @-${mv} ../pstoedit/src/drvtk.cpp ../pstoedit/src/drvtk.cpp.orig
--
--../pstoedit/src/drvtk.h.orig:
-- @-${mv} ../pstoedit/src/drvtk.h ../pstoedit/src/drvtk.h.orig
--
--installdrvtk: ../pstoedit/src/drvtk.cpp.orig ../pstoedit/src/drvtk.h.orig
-- @-${cmp} drvtk.cpp ../pstoedit/src/drvtk.cpp 2>/dev/null || \
-- echo "Updating drvtk.cpp" >&2 && ${cp} drvtk.cpp ../pstoedit/src
-- @-${cmp} drvtk.h ../pstoedit/src/drvtk.h 2>/dev/null || \
-- echo "Updating drvtk.h" >&2 && ${cp} drvtk.h ../pstoedit/src
-- @-${cmp} drvbase.h ../pstoedit/src/drvbase.h 2>/dev/null || \
-- echo "Updating drvbase.h" >&2 && ${cp} drvbase.h ../pstoedit/src
--
--install: impress impress.tcl transeps COPYING CHANGES OPTIONS README tkFont-patch.diff tkUnixWm-patch.diff installdrvtk
-- @-mkdir ../bin
-- @-${cmp} impress ../bin/impress 2>/dev/null || \
-- echo "Updating impress" >&2 && ${cp} impress ../bin
-- @-${cmp} transeps ../bin/transeps 2>/dev/null || \
-- echo "Updating transeps" >&2 && ${cp} transeps ../bin
-- @-${cmp} COPYING ../COPYING 2>/dev/null || \
-- echo "Updating COPYING" >&2 && ${cp} COPYING ..
-- @-${cmp} README ../README 2>/dev/null || \
-- echo "Updating README" >&2 && ${cp} README ..
-- @-${cmp} CHANGES ../CHANGES 2>/dev/null || \
-- echo "Updating CHANGES" >&2 && ${cp} CHANGES ..
-- @-${cmp} OPTIONS ../OPTIONS 2>/dev/null || \
-- echo "Updating OPTIONS" >&2 && ${cp} OPTIONS ..
-- @-${cmp} tkFont-patch.diff ../tkFont-patch.diff 2>/dev/null || \
-- echo "Updating tkFont-patch.diff" >&2 && ${cp} tkFont-patch.diff ..
-- @-${cmp} tkUnixWm-patch.diff ../tkUnixWm-patch.diff 2>/dev/null || \
-- echo "Updating tkUnixWm-patch.diff" >&2 && ${cp} tkUnixWm-patch.diff ..
-- @-mkdir ../doc
-- @-${cmp} doc/arrows.jpg ../doc/arrows.jpg 2>/dev/null || \
-- echo "Updating arrows.jpg" >&2 && ${cp} doc/arrows.jpg ../doc
-- @-${cmp} doc/custcolor.jpg ../doc/custcolor.jpg 2>/dev/null || \
-- echo "Updating custcolor.jpg" >&2 && ${cp} doc/custcolor.jpg ../doc
-- @-${cmp} doc/file.jpg ../doc/file.jpg 2>/dev/null || \
-- echo "Updating file.jpg" >&2 && ${cp} doc/file.jpg ../doc
-- @-${cmp} doc/fonts.jpg ../doc/fonts.jpg 2>/dev/null || \
-- echo "Updating fonts.jpg" >&2 && ${cp} doc/fonts.jpg ../doc
-- @-${cmp} doc/grid.jpg ../doc/grid.jpg 2>/dev/null || \
-- echo "Updating grid.jpg" >&2 && ${cp} doc/grid.jpg ../doc
-- @-${cmp} doc/impdoc.html ../doc/impdoc.html 2>/dev/null || \
-- echo "Updating impdoc.html" >&2 && ${cp} doc/impdoc.html ../doc
-- @-${cmp} doc/implogo.gif ../doc/implogo.gif 2>/dev/null || \
-- echo "Updating implogo.gif" >&2 && ${cp} doc/implogo.gif ../doc
-- @-${cmp} doc/impressbuttons.jpg ../doc/impressbuttons.jpg 2>/dev/null || \
-- echo "Updating impressbuttons.jpg" >&2 && ${cp} doc/impressbuttons.jpg ../doc
-- @-${cmp} doc/impressmain2.jpg ../doc/impressmain2.jpg 2>/dev/null || \
-- echo "Updating impressmain2.jpg" >&2 && ${cp} doc/impressmain2.jpg ../doc
-- @-${cmp} doc/lgtoolbar.jpg ../doc/lgtoolbar.jpg 2>/dev/null || \
-- echo "Updating lgtoolbar.jpg" >&2 && ${cp} doc/lgtoolbar.jpg ../doc
-- @-${cmp} doc/openurldialog.jpg ../doc/openurldialog.jpg 2>/dev/null || \
-- echo "Updating openurldialog.jpg" >&2 && ${cp} doc/openurldialog.jpg ../doc
-- @-${cmp} doc/page.jpg ../doc/page.jpg 2>/dev/null || \
-- echo "Updating page.jpg" >&2 && ${cp} doc/page.jpg ../doc
-- @-${cmp} doc/palette.jpg ../doc/palette.jpg 2>/dev/null || \
-- echo "Updating palette.jpg" >&2 && ${cp} doc/palette.jpg ../doc
-- @-${cmp} doc/print.jpg ../doc/print.jpg 2>/dev/null || \
-- echo "Updating print.jpg" >&2 && ${cp} doc/print.jpg ../doc
-- @-${cmp} doc/props.jpg ../doc/props.jpg 2>/dev/null || \
-- echo "Updating props.jpg" >&2 && ${cp} doc/props.jpg ../doc
-- @-${cmp} doc/pstoedit.jpg ../doc/pstoedit.jpg 2>/dev/null || \
-- echo "Updating pstoedit.jpg" >&2 && ${cp} doc/pstoedit.jpg ../doc
-- @-${cmp} doc/selection.jpg ../doc/selection.jpg 2>/dev/null || \
-- echo "Updating selection.jpg" >&2 && ${cp} doc/selection.jpg ../doc
-- @-${cmp} doc/slide.jpg ../doc/slide.jpg 2>/dev/null || \
-- echo "Updating slide.jpg" >&2 && ${cp} doc/slide.jpg ../doc
-- @-${cmp} doc/tclet.jpg ../doc/tclet.jpg 2>/dev/null || \
-- echo "Updating tclet.jpg" >&2 && ${cp} doc/tclet.jpg ../doc
-- @-${cmp} doc/toolbarpref.jpg ../doc/toolbarpref.jpg 2>/dev/null || \
-- echo "Updating toolbarpref.jpg" >&2 && ${cp} doc/toolbarpref.jpg ../doc
-- @-${cmp} doc/urldialog.jpg ../doc/urldialog.jpg 2>/dev/null || \
-- echo "Updating urldialog.jpg" >&2 && ${cp} doc/urldialog.jpg ../doc
-- @-${cmp} doc/miniview.jpg ../doc/miniview.jpg 2>/dev/null || \
-- echo "Updating miniview.jpg" >&2 && ${cp} doc/miniview.jpg ../doc
-
- clean:
- rm -f impress transeps
diff --git a/editors/impress/files/patch-src_impress_tcl b/editors/impress/files/patch-src_impress_tcl
deleted file mode 100644
index 5dbe98cf2df0..000000000000
--- a/editors/impress/files/patch-src_impress_tcl
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/impress.tcl.orig Fri Jun 29 10:21:58 2001
-+++ src/impress.tcl Fri Jun 29 10:22:10 2001
-@@ -19,7 +19,7 @@
- # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- #
- # restart trick \
--exec wish "$0" "$@"
-+exec wish8.4 "$0" "$@"
-
- option add *Radiobutton*borderWidth 1
- option add *Button*borderWidth 1
diff --git a/editors/impress/pkg-plist b/editors/impress/pkg-plist
deleted file mode 100644
index 181005d34025..000000000000
--- a/editors/impress/pkg-plist
+++ /dev/null
@@ -1,26 +0,0 @@
-bin/impress
-%%DOCSDIR%%/add.txt
-%%DOCSDIR%%/arrows.jpg
-%%DOCSDIR%%/custcolor.jpg
-%%DOCSDIR%%/file.jpg
-%%DOCSDIR%%/fonts.jpg
-%%DOCSDIR%%/grid.jpg
-%%DOCSDIR%%/impdoc.html
-%%DOCSDIR%%/implogo.gif
-%%DOCSDIR%%/impressbuttons.jpg
-%%DOCSDIR%%/impressmain2.jpg
-%%DOCSDIR%%/keys.jpg
-%%DOCSDIR%%/lgtoolbar.jpg
-%%DOCSDIR%%/miniview.jpg
-%%DOCSDIR%%/openurldialog.jpg
-%%DOCSDIR%%/page.jpg
-%%DOCSDIR%%/palette.jpg
-%%DOCSDIR%%/print.jpg
-%%DOCSDIR%%/props.jpg
-%%DOCSDIR%%/pstoedit.jpg
-%%DOCSDIR%%/selection.jpg
-%%DOCSDIR%%/slide.jpg
-%%DOCSDIR%%/tclet.jpg
-%%DOCSDIR%%/toolbarpref.jpg
-%%DOCSDIR%%/urldialog.jpg
-@dirrm %%DOCSDIR%%