aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-09-15 03:51:37 +0800
committermarcus <marcus@FreeBSD.org>2002-09-15 03:51:37 +0800
commit59be92f8d61b8be632f86a4cda2baf8e69e0a612 (patch)
tree70620b856fc67c0da41bc4ea9ac3cc61ecea0e7d
parent2e39649152284725b86066e2f987bd823132ba12 (diff)
downloadfreebsd-ports-gnome-59be92f8d61b8be632f86a4cda2baf8e69e0a612.tar.gz
freebsd-ports-gnome-59be92f8d61b8be632f86a4cda2baf8e69e0a612.tar.zst
freebsd-ports-gnome-59be92f8d61b8be632f86a4cda2baf8e69e0a612.zip
Add appropriate --disable-* CONFIGURE_ARGS to disable things such as esound
support from being built when esound is already installed on the system. Reported by: alane Approved by: timeout from maintainer
-rw-r--r--audio/xmms/Makefile5
-rw-r--r--multimedia/xmms/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/audio/xmms/Makefile b/audio/xmms/Makefile
index 024c51af3903..2eb5e77956e3 100644
--- a/audio/xmms/Makefile
+++ b/audio/xmms/Makefile
@@ -42,6 +42,7 @@ LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
INPUT_PLUGINS+= mikmod
PLIST_SUB+= MIKMODPLUGIN:=""
.else
+CONFIGURE_ARGS+= --disable-mikmod
PLIST_SUB+= MIKMODPLUGIN:="@comment "
.endif
@@ -50,6 +51,7 @@ LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
INPUT_PLUGINS+= vorbis
PLIST_SUB+= VORBISPLUGIN:=""
.else
+CONFIGURE_ARGS+= --disable-vorbis
PLIST_SUB+= VORBISPLUGIN:="@comment "
.endif
@@ -63,6 +65,7 @@ PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-esound
PKGNAMESUFFIX= -esound
.endif
.else
+CONFIGURE_ARGS+= --disable-esd
PLIST_SUB+= ESDPLUGIN:="@comment "
.endif
@@ -75,7 +78,7 @@ PKGNAMESUFFIX= -gnome
.endif
PLIST_SUB+= DATADIR="share/gnome"
.else
-CONFIGURE_ARGS= --without-gnome
+CONFIGURE_ARGS+= --without-gnome
PLIST_SUB+= DATADIR="share"
.endif
diff --git a/multimedia/xmms/Makefile b/multimedia/xmms/Makefile
index 024c51af3903..2eb5e77956e3 100644
--- a/multimedia/xmms/Makefile
+++ b/multimedia/xmms/Makefile
@@ -42,6 +42,7 @@ LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
INPUT_PLUGINS+= mikmod
PLIST_SUB+= MIKMODPLUGIN:=""
.else
+CONFIGURE_ARGS+= --disable-mikmod
PLIST_SUB+= MIKMODPLUGIN:="@comment "
.endif
@@ -50,6 +51,7 @@ LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
INPUT_PLUGINS+= vorbis
PLIST_SUB+= VORBISPLUGIN:=""
.else
+CONFIGURE_ARGS+= --disable-vorbis
PLIST_SUB+= VORBISPLUGIN:="@comment "
.endif
@@ -63,6 +65,7 @@ PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-esound
PKGNAMESUFFIX= -esound
.endif
.else
+CONFIGURE_ARGS+= --disable-esd
PLIST_SUB+= ESDPLUGIN:="@comment "
.endif
@@ -75,7 +78,7 @@ PKGNAMESUFFIX= -gnome
.endif
PLIST_SUB+= DATADIR="share/gnome"
.else
-CONFIGURE_ARGS= --without-gnome
+CONFIGURE_ARGS+= --without-gnome
PLIST_SUB+= DATADIR="share"
.endif