aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-08-14 05:29:28 +0800
committerrene <rene@FreeBSD.org>2011-08-14 05:29:28 +0800
commit59ef17bb6e7393c03ce7a07657d8146db8d4caea (patch)
treea13a93c5fc734c28db8878d4c89187786323be36
parent0dddadd85ff89ac4975cf9a7bb5cea6f925c3955 (diff)
downloadfreebsd-ports-gnome-59ef17bb6e7393c03ce7a07657d8146db8d4caea.tar.gz
freebsd-ports-gnome-59ef17bb6e7393c03ce7a07657d8146db8d4caea.tar.zst
freebsd-ports-gnome-59ef17bb6e7393c03ce7a07657d8146db8d4caea.zip
Fix build on 7.X and 8.0
Submitted by: George Liaskos
-rw-r--r--www/chromium/Makefile6
-rw-r--r--www/chromium/files/extra-patch-base__base.gypi-freebsd (renamed from www/chromium/files/patch-base__base.gypi)0
-rw-r--r--www/chromium/files/extra-patch-base__base.gypi-stub37
3 files changed, 43 insertions, 0 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index d849a7cf5e3d..15945c7cc02b 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -84,6 +84,12 @@ CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
.endif
+.if ${OSVERSION} < 801000
+EXTRA_PATCHES+= files/extra-patch-base__base.gypi-stub
+.else
+EXTRA_PATCHES+= files/extra-patch-base__base.gypi-freebsd
+.endif
+
.if defined(WITH_CODECS)
GYP_DEFINES+= ffmpeg_branding=Chrome
GYP_DEFINES+= use_proprietary_codecs=1
diff --git a/www/chromium/files/patch-base__base.gypi b/www/chromium/files/extra-patch-base__base.gypi-freebsd
index 850b5505b09b..850b5505b09b 100644
--- a/www/chromium/files/patch-base__base.gypi
+++ b/www/chromium/files/extra-patch-base__base.gypi-freebsd
diff --git a/www/chromium/files/extra-patch-base__base.gypi-stub b/www/chromium/files/extra-patch-base__base.gypi-stub
new file mode 100644
index 000000000000..614b04da186a
--- /dev/null
+++ b/www/chromium/files/extra-patch-base__base.gypi-stub
@@ -0,0 +1,37 @@
+--- base/base.gypi.orig 2011-08-13 18:38:35.292399627 +0300
++++ base/base.gypi 2011-08-13 18:50:20.106856527 +0300
+@@ -189,6 +189,7 @@
+ 'process_posix.cc',
+ 'process_util.cc',
+ 'process_util.h',
++ 'process_util_freebsd.cc',
+ 'process_util_linux.cc',
+ 'process_util_mac.mm',
+ 'process_util_posix.cc',
+@@ -371,11 +372,9 @@
+ 'message_pump_glib_x.cc',
+ ],
+ }],
+- [ 'OS != "linux"', {
++ [ 'OS != "linux" and OS != "freebsd"', {
+ 'sources!': [
+ # Not automatically excluded by the *linux.cc rules.
+- 'gtk_util.cc',
+- 'gtk_util.h',
+ 'linux_util.cc',
+ ],
+ },
+@@ -491,6 +490,13 @@
+ ],
+ }],
+ [ 'OS == "freebsd" or OS == "openbsd"', {
++ # XXX rene: maybe this chunk should go one day
++ 'sources!': [
++ 'file_util_linux.cc',
++ 'process_linux.cc',
++ 'process_util_linux.cc',
++ 'files/file_path_watcher_linux.cc',
++ ],
+ 'link_settings': {
+ 'libraries': [
+ '-L/usr/local/lib -lexecinfo',