aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-16 01:17:04 +0800
committermiwi <miwi@FreeBSD.org>2009-03-16 01:17:04 +0800
commit5a6cdcc36092eed055ce86a3d1caff4c3a551e33 (patch)
tree9bfc64a321f972a3a5c32856ee1f9b5c94332096
parent6eee32bb8dcd83d22dc5a45a62536be4691dfa9b (diff)
downloadfreebsd-ports-gnome-5a6cdcc36092eed055ce86a3d1caff4c3a551e33.tar.gz
freebsd-ports-gnome-5a6cdcc36092eed055ce86a3d1caff4c3a551e33.tar.zst
freebsd-ports-gnome-5a6cdcc36092eed055ce86a3d1caff4c3a551e33.zip
This is an experimental distribution that attempts to intuit the underlying
indent "policy" for a text file (most likely a source code file). WWW: http://search.cpan.org/dist/Text-FindIndent/ PR: ports/132406 Submitted by: Cezary Morga <cm at therek.net>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-FindIndent/Makefile21
-rw-r--r--textproc/p5-Text-FindIndent/distinfo3
-rw-r--r--textproc/p5-Text-FindIndent/pkg-descr4
-rw-r--r--textproc/p5-Text-FindIndent/pkg-plist6
5 files changed, 35 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3e77e5a160a5..6a0756b39511 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -597,6 +597,7 @@
SUBDIR += p5-Text-FillIn
SUBDIR += p5-Text-Filter
SUBDIR += p5-Text-Filter-Chain
+ SUBDIR += p5-Text-FindIndent
SUBDIR += p5-Text-FixEOL
SUBDIR += p5-Text-FixedLength
SUBDIR += p5-Text-FixedLength-Extra
diff --git a/textproc/p5-Text-FindIndent/Makefile b/textproc/p5-Text-FindIndent/Makefile
new file mode 100644
index 000000000000..814c2d55e373
--- /dev/null
+++ b/textproc/p5-Text-FindIndent/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Text-FindIndent
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-FindIndent
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Perl5 module to heuristically determine the indent style of a file
+
+PERL_CONFIGURE= YES
+
+MAN3= Text::FindIndent.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-FindIndent/distinfo b/textproc/p5-Text-FindIndent/distinfo
new file mode 100644
index 000000000000..93b41dc36fcf
--- /dev/null
+++ b/textproc/p5-Text-FindIndent/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-FindIndent-0.04.tar.gz) = 4baf5b29c47e1bd0c3125a24ce697a11
+SHA256 (Text-FindIndent-0.04.tar.gz) = 44e659a563cab5884edf0401a347de1532014f320749e1f8449b0c9061cc4313
+SIZE (Text-FindIndent-0.04.tar.gz) = 27572
diff --git a/textproc/p5-Text-FindIndent/pkg-descr b/textproc/p5-Text-FindIndent/pkg-descr
new file mode 100644
index 000000000000..c7c08c875630
--- /dev/null
+++ b/textproc/p5-Text-FindIndent/pkg-descr
@@ -0,0 +1,4 @@
+This is an experimental distribution that attempts to intuit the underlying
+indent "policy" for a text file (most likely a source code file).
+
+WWW: http://search.cpan.org/dist/Text-FindIndent/
diff --git a/textproc/p5-Text-FindIndent/pkg-plist b/textproc/p5-Text-FindIndent/pkg-plist
new file mode 100644
index 000000000000..7d1ea30638f4
--- /dev/null
+++ b/textproc/p5-Text-FindIndent/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Text/FindIndent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/FindIndent/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/FindIndent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/Text