aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-08 06:17:25 +0800
committermiwi <miwi@FreeBSD.org>2009-01-08 06:17:25 +0800
commit5ac4d92429f539d6ff503ff0bbaf5b62f47f4b02 (patch)
tree6aed1f2ed35a9ff4b90dc8e2eb0cdb2a5c68c482
parent0bbbff12b5c751240474a200a7af3cdccbcd7e9d (diff)
downloadfreebsd-ports-gnome-5ac4d92429f539d6ff503ff0bbaf5b62f47f4b02.tar.gz
freebsd-ports-gnome-5ac4d92429f539d6ff503ff0bbaf5b62f47f4b02.tar.zst
freebsd-ports-gnome-5ac4d92429f539d6ff503ff0bbaf5b62f47f4b02.zip
- Adds self-test as recommended by INSTALL.
Excessively long self-test runs in lzo2 (a different port) were figured (thanks, naddy@) to be caused by "J" in /etc/malloc.conf, so we set MALLOC_OPTIONS=jz to avoid that. PR: 130153 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
-rw-r--r--archivers/lzo/Makefile7
-rw-r--r--archivers/lzo/files/patch-util-check.sh11
2 files changed, 17 insertions, 1 deletions
diff --git a/archivers/lzo/Makefile b/archivers/lzo/Makefile
index 367aafb9efec..ca5138ff3dd2 100644
--- a/archivers/lzo/Makefile
+++ b/archivers/lzo/Makefile
@@ -17,10 +17,15 @@ MAINTAINER= matthias.andree@gmx.de
COMMENT= Portable speedy, lossless data compression library
USE_AUTOTOOLS= libtool:15
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
+post-build:
+ @${ECHO_MSG} "===> Running self-tests for ${PKGNAME} (can take a few minutes)"
+ @# override MALLOC_OPTIONS, else tests take excessively long
+ cd ${WRKSRC} && ${SETENV} MALLOC_OPTIONS=jz ${MAKE} check test
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/archivers/lzo/files/patch-util-check.sh b/archivers/lzo/files/patch-util-check.sh
new file mode 100644
index 000000000000..d661772ff008
--- /dev/null
+++ b/archivers/lzo/files/patch-util-check.sh
@@ -0,0 +1,11 @@
+--- ./util/check.sh~ 2009-01-04 10:28:23.000000000 +0100
++++ ./util/check.sh 2009-01-04 10:33:34.000000000 +0100
+@@ -13,7 +13,7 @@
+ LTEST="ltest"
+ test -x ./ltest/ltest && LTEST="./ltest/ltest"
+ test -x ./ltest.exe && LTEST="./ltest.exe"
+-LFLAGS="-q -n2"
++LFLAGS="-Q -n2"
+
+ dir="${*-.}"
+