aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-09-07 13:24:56 +0800
committerkrion <krion@FreeBSD.org>2004-09-07 13:24:56 +0800
commit5b6928bf0b9e7860cfac9c2b092fd993c883117b (patch)
tree4d6369864745df986a3b8ebafbf5caaf9ff2396c
parent430a4857457ff856eb9e6609b0257975e91786bf (diff)
downloadfreebsd-ports-gnome-5b6928bf0b9e7860cfac9c2b092fd993c883117b.tar.gz
freebsd-ports-gnome-5b6928bf0b9e7860cfac9c2b092fd993c883117b.tar.zst
freebsd-ports-gnome-5b6928bf0b9e7860cfac9c2b092fd993c883117b.zip
Fix build with gcc-3.4
PR: ports/71447 Submitted by: maintainer Approved by: portmgr (implicit)
-rw-r--r--audio/kmp/files/patch-linkedlist.h11
1 files changed, 11 insertions, 0 deletions
diff --git a/audio/kmp/files/patch-linkedlist.h b/audio/kmp/files/patch-linkedlist.h
new file mode 100644
index 000000000000..f5ae19098ae5
--- /dev/null
+++ b/audio/kmp/files/patch-linkedlist.h
@@ -0,0 +1,11 @@
+--- linkedlist.h Tue Sep 7 06:32:48 2004
++++ linkedlist.h Tue Sep 7 06:33:00 2004
+@@ -121,7 +121,7 @@
+ int linkedList<ItemType>::add(ItemType Item, int location) {
+ node* parent;
+ node* nextspot;
+- if(!find(location, root_, parent)) return 0;
++ if(!find(location, root, parent)) return 0;
+ nextspot = parent->next;
+ parent->next = new node;
+ parent->next->next = nextspot;
ref='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/sysutils/doctl/Makefile?h=gnome-3.28&id=e600f8381c570939dd7ca3d84720fe56380894d7'>sysutils/doctl: Update to version 1.7.2jrm2018-03-151-1/+1 | | | | Upstream changes: https://github.com/digitalocean/doctl/releases/tag/v1.7.2 * sysutils/doctl: Update to version 1.7.1jrm2017-11-021-1/+2 | | | | | Upstream changes: https://github.com/digitalocean/doctl/blob/master/CHANGELOG.md