aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-02-05 01:33:13 +0800
committeradamw <adamw@FreeBSD.org>2016-02-05 01:33:13 +0800
commit5d5ba7c5ac3f574d2c82e37bcd3ca6aff7aaa961 (patch)
tree4e5232cd78b47bf12de0007f0cbaf2688f8eaa10
parent671d06e6e357500b23c04234661eae85a5c58f0e (diff)
downloadfreebsd-ports-gnome-5d5ba7c5ac3f574d2c82e37bcd3ca6aff7aaa961.tar.gz
freebsd-ports-gnome-5d5ba7c5ac3f574d2c82e37bcd3ca6aff7aaa961.tar.zst
freebsd-ports-gnome-5d5ba7c5ac3f574d2c82e37bcd3ca6aff7aaa961.zip
Lighten up the Perl dependencies.
git uses Perl for two things: Perl hooks into git, and the git-send-email(1) script. The Perl hooks only use p5-Error. The other modules dependencies, p5-Authen-SASL and p5-Net-SMTP-SSL (which bring in a number of other perl module dependencies) are only required for git-send-email(1). This commit adds a SEND_EMAIL option, defaulted to on, that auto-enables the PERL option and installs the git-send-email(1) script with the extra perl modules. With the PERL option on and SEND_EMAIL off, only the p5-Error module is required. No PORTREVISION bump as the default dependencies and plist haven't changed. PR: 206901 Approved by: garga (maintainer) Differential Revision: https://reviews.freebsd.org/D5179
-rw-r--r--devel/git/Makefile13
-rw-r--r--devel/git/pkg-plist8
2 files changed, 12 insertions, 9 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 0581a8158b9c..e697bc1316da 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -41,8 +41,8 @@ SHEBANG_FILES= *.perl */*.perl */*/*.perl */*.pl */*/*.pl */*/*/*.pl \
CONFIGURE_ARGS= --enable-pthreads=-pthread ac_cv_header_libcharset_h=no
OPTIONS_DEFINE= GUI SVN GITWEB CONTRIB P4 CVS HTMLDOCS PERL ICONV CURL \
- ETCSHELLS NLS
-OPTIONS_DEFAULT= CONTRIB P4 CVS PERL ICONV CURL ETCSHELLS NLS
+ ETCSHELLS SEND_EMAIL NLS
+OPTIONS_DEFAULT= CONTRIB P4 CVS PERL ICONV CURL ETCSHELLS SEND_EMAIL NLS
OPTIONS_SUB= yes
GITWEB_DESC= Install gitweb
@@ -51,6 +51,7 @@ P4_DESC= Enable Perforce support
CVS_DESC= Enable CVS support
HTMLDOCS_DESC= Install additional documentation
ETCSHELLS_DESC= Modify /etc/shells
+SEND_EMAIL_DESC=Enable the git-send-email(1) script
NLS_USES= gettext
NLS_MAKE_ARGS_OFF= NO_GETTEXT=yes
@@ -58,11 +59,13 @@ NLS_MAKE_ARGS_OFF= NO_GETTEXT=yes
PERL_USES= perl5
PERL_MAKE_ENV= PERL_PATH=${PERL}
PERL_BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
-PERL_RUN_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error \
- p5-Net-SMTP-SSL>=0:${PORTSDIR}/mail/p5-Net-SMTP-SSL \
- p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
+PERL_RUN_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
PERL_MAKE_ARGS_OFF= NO_PERL=1
+SEND_EMAIL_IMPLIES= PERL
+SEND_EMAIL_RUN_DEPENDS= p5-Net-SMTP-SSL>=0:${PORTSDIR}/mail/p5-Net-SMTP-SSL \
+ p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
+
ICONV_USES= iconv
ICONV_MAKE_ARGS_OFF= NO_ICONV=1
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 2c889ed84522..267446098787 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -120,7 +120,7 @@ man/man1/git-rev-list.1.gz
man/man1/git-rev-parse.1.gz
man/man1/git-revert.1.gz
man/man1/git-rm.1.gz
-man/man1/git-send-email.1.gz
+%%SEND_EMAIL%%man/man1/git-send-email.1.gz
man/man1/git-send-pack.1.gz
man/man1/git-sh-setup.1.gz
man/man1/git-sh-i18n.1.gz
@@ -315,7 +315,7 @@ libexec/git-core/git-rev-list
libexec/git-core/git-rev-parse
libexec/git-core/git-revert
libexec/git-core/git-rm
-libexec/git-core/git-send-email
+%%SEND_EMAIL%%libexec/git-core/git-send-email
libexec/git-core/git-send-pack
libexec/git-core/git-sh-i18n
libexec/git-core/git-sh-i18n--envsubst
@@ -604,7 +604,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/git-rev-parse.html
%%HTMLDOCS%%%%DOCSDIR%%/git-revert.html
%%HTMLDOCS%%%%DOCSDIR%%/git-rm.html
-%%HTMLDOCS%%%%DOCSDIR%%/git-send-email.html
+%%SEND_EMAIL%%%%HTMLDOCS%%%%DOCSDIR%%/git-send-email.html
%%HTMLDOCS%%%%DOCSDIR%%/git-send-pack.html
%%HTMLDOCS%%%%DOCSDIR%%/git-sh-i18n.html
%%HTMLDOCS%%%%DOCSDIR%%/git-sh-i18n--envsubst.html
@@ -962,7 +962,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/git-check-attr.txt
%%HTMLDOCS%%%%DOCSDIR%%/config.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-http-fetch.txt
-%%HTMLDOCS%%%%DOCSDIR%%/git-send-email.txt
+%%SEND_EMAIL%%%%HTMLDOCS%%%%DOCSDIR%%/git-send-email.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-annotate.txt
%%HTMLDOCS%%%%DOCSDIR%%/gitmodules.txt
%%HTMLDOCS%%%%DOCSDIR%%/pull-fetch-param.txt