aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2012-05-26 11:17:17 +0800
committerwxs <wxs@FreeBSD.org>2012-05-26 11:17:17 +0800
commit5eb3079cc794950ca06dd6262bd53e93fc39d480 (patch)
tree5c32d9e6feb271a90b8d9bb830059f5f7dc9b950
parentcfe7d672a52b5276741e7905e5d93747dbde0a95 (diff)
downloadfreebsd-ports-gnome-5eb3079cc794950ca06dd6262bd53e93fc39d480.tar.gz
freebsd-ports-gnome-5eb3079cc794950ca06dd6262bd53e93fc39d480.tar.zst
freebsd-ports-gnome-5eb3079cc794950ca06dd6262bd53e93fc39d480.zip
Fix build when BDB is selected.
PR: ports/168214 Submitted by: Robert Simmons <rsimmons0@gmail.com> Approved by: Joerg Pulz <Joerg.Pulz@frm2.tum.de> (maintainer)
-rw-r--r--security/heimdal/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index d79557f77d6a..037f34453c25 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -7,13 +7,12 @@
PORTNAME= heimdal
PORTVERSION= 1.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= http://www.h5l.org/dist/src/ \
http://ftp.pdc.kth.se/pub/heimdal/src/ \
ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
- ftp://ftp.sunet.se/pub/unix/admin/mirror-pdc/heimdal/src/ \
- ftp://ftp.ayamura.org/pub/heimdal/
+ ftp://ftp.sunet.se/pub/unix/admin/mirror-pdc/heimdal/src/
MAINTAINER= Joerg.Pulz@frm2.tum.de
COMMENT= A popular BSD-licensed implementation of Kerberos 5
@@ -77,10 +76,10 @@ USE_BDB= yes
CFLAGS+= -I${BDB_INCLUDE_DIR}
CPPFLAGS+= -I${BDB_INCLUDE_DIR}
LDFLAGS+= -L${BDB_LIB_DIR}
-CONFIGURE_ARGS+= --with-berkeley-db=${LOCALBASE}
-# --with-berkeley-db-include=${BDB_INCLUDE_DIR}
+CONFIGURE_ARGS+= --with-berkeley-db=${LOCALBASE} \
+ --with-berkeley-db-include=${BDB_INCLUDE_DIR}
.else
-CONFIGURE_ARGS+= --without-berkeley-db
+CONFIGURE_ARGS+= --with-berkeley-db=no
.endif
.if defined(WITH_SQLITE)