aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2016-11-26 05:27:37 +0800
committergerald <gerald@FreeBSD.org>2016-11-26 05:27:37 +0800
commit5ebb08b847ae4db7010dd0638e4c32691ddb7751 (patch)
tree6bec6a78bb240300325bb4d68e84361f36406264
parentc85ca64a54c0849db62bacc66ec3cca5b9fd9c49 (diff)
downloadfreebsd-ports-gnome-5ebb08b847ae4db7010dd0638e4c32691ddb7751.tar.gz
freebsd-ports-gnome-5ebb08b847ae4db7010dd0638e4c32691ddb7751.tar.zst
freebsd-ports-gnome-5ebb08b847ae4db7010dd0638e4c32691ddb7751.zip
Replace USE_GCC=4.9+ by USE_GCC=yes, now that lang/gcc and the default
version for GCC in the Ports Collection have moved to GCC 4.9.
-rw-r--r--biology/seqan-apps/Makefile2
-rw-r--r--devel/bisoncpp/Makefile2
-rw-r--r--devel/libbobcat/Makefile2
-rw-r--r--devel/pure-stldict/Makefile2
-rw-r--r--emulators/dolphin-emu/Makefile4
-rw-r--r--lang/cilkplus/Makefile2
-rw-r--r--lang/gcc6-devel/Makefile2
-rw-r--r--lang/gcc6/Makefile2
-rw-r--r--lang/gcc7-devel/Makefile2
-rw-r--r--lang/ruby21/Makefile2
-rw-r--r--lang/ruby22/Makefile2
-rw-r--r--lang/ruby23/Makefile2
12 files changed, 13 insertions, 13 deletions
diff --git a/biology/seqan-apps/Makefile b/biology/seqan-apps/Makefile
index f4489dd1ff52..30cb01a99262 100644
--- a/biology/seqan-apps/Makefile
+++ b/biology/seqan-apps/Makefile
@@ -24,7 +24,7 @@ GH_PROJECT= seqan
USES= cmake:outsource
CMAKE_ARGS= -DSEQAN_BUILD_SYSTEM="SEQAN_RELEASE_APPS"
-USE_GCC= 4.9+
+USE_GCC= yes
.include <bsd.port.pre.mk>
diff --git a/devel/bisoncpp/Makefile b/devel/bisoncpp/Makefile
index f2546e404999..6d91d420c5a7 100644
--- a/devel/bisoncpp/Makefile
+++ b/devel/bisoncpp/Makefile
@@ -20,7 +20,7 @@ PORTDOCS= *
WRKSRC= ${WRKDIR}/bisonc++-${PORTVERSION}
-USE_GCC= 4.9+
+USE_GCC= yes
USES= shebangfix
diff --git a/devel/libbobcat/Makefile b/devel/libbobcat/Makefile
index da4c198f7f7b..6d46933f8a04 100644
--- a/devel/libbobcat/Makefile
+++ b/devel/libbobcat/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= icmake:devel/icmake \
yodl>=3.0:textproc/yodl
-USE_GCC= 4.9+
+USE_GCC= yes
USE_XORG= x11
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
diff --git a/devel/pure-stldict/Makefile b/devel/pure-stldict/Makefile
index bdc635c86062..4ea9d4723cb3 100644
--- a/devel/pure-stldict/Makefile
+++ b/devel/pure-stldict/Makefile
@@ -26,7 +26,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 1000000
-USE_GCC= 4.9+
+USE_GCC= yes
.endif
post-install:
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index 42b3a36b18ed..50c498f294c4 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -85,9 +85,9 @@ NLS_CMAKE_OFF= -DDISABLE_NLS:BOOL=ON
CMAKE_ARGS+= -DENABLE_GENERIC:BOOL=ON
.endif
-# When building with Gcc, needs Gcc 4.9+
+# When building with GCC, needs GCC 4.9+
.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} < 49
-USE_GCC= 4.9+
+USE_GCC= yes
# Enable std::stoul()
CXXFLAGS+= -D_GLIBCXX_USE_C99
# Enable log2f(), exp2f() and roundf()
diff --git a/lang/cilkplus/Makefile b/lang/cilkplus/Makefile
index 06c2331e1edb..93df74c18f4b 100644
--- a/lang/cilkplus/Makefile
+++ b/lang/cilkplus/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD3CLAUSE
HG_REVISION= 004467
-USE_GCC= 4.9+
+USE_GCC= yes
ONLY_FOR_ARCHS= i386 amd64 sparc64
diff --git a/lang/gcc6-devel/Makefile b/lang/gcc6-devel/Makefile
index 96c1a308e5fc..596149e06d8c 100644
--- a/lang/gcc6-devel/Makefile
+++ b/lang/gcc6-devel/Makefile
@@ -70,7 +70,7 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.if ${ARCH} == powerpc64
CONFIGURE_ENV+= UNAME_m="powerpc64"
-USE_GCC= 4.9+
+USE_GCC= yes
.endif
.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
diff --git a/lang/gcc6/Makefile b/lang/gcc6/Makefile
index cf6ed2b288c6..8b11dc816c92 100644
--- a/lang/gcc6/Makefile
+++ b/lang/gcc6/Makefile
@@ -70,7 +70,7 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.if ${ARCH} == powerpc64
CONFIGURE_ENV+= UNAME_m="powerpc64"
-USE_GCC= 4.9+
+USE_GCC= yes
.endif
.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
diff --git a/lang/gcc7-devel/Makefile b/lang/gcc7-devel/Makefile
index b164de5b920f..3be6202228f6 100644
--- a/lang/gcc7-devel/Makefile
+++ b/lang/gcc7-devel/Makefile
@@ -61,7 +61,7 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.if ${ARCH} == powerpc64
CONFIGURE_ENV+= UNAME_m="powerpc64"
-USE_GCC= 4.9+
+USE_GCC= yes
.endif
.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index 578d1c478c3f..ba06e866a7df 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -97,7 +97,7 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
.if (${ARCH} == "powerpc64" || ${ARCH} == "powerpc")
-USE_GCC= 4.9+
+USE_GCC= yes
.endif
.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index aaf78c88e446..b0c376a8af47 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -98,7 +98,7 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
.if ${ARCH} == "powerpc" || ${ARCH} == "powerpc64"
-USE_GCC= 4.9+
+USE_GCC= yes
.endif
.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
diff --git a/lang/ruby23/Makefile b/lang/ruby23/Makefile
index 12cfb1222308..40be0e6994c3 100644
--- a/lang/ruby23/Makefile
+++ b/lang/ruby23/Makefile
@@ -97,7 +97,7 @@ CONFIGURE_ARGS+=--disable-dtrace
.endif
.if (${ARCH} == "powerpc64" || ${ARCH} == "powerpc")
-USE_GCC= 4.9+
+USE_GCC= yes
.endif
.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"