aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-28 01:05:15 +0800
committeraz <az@FreeBSD.org>2013-07-28 01:05:15 +0800
commit5eda15a636d5b8d68b5664d43167de21ed92204b (patch)
treef0b70151ca749e52f36ef51d18b34cf1e2d063ad
parent3311d519b8d5c595f4f211a9abf7633037ee2775 (diff)
downloadfreebsd-ports-gnome-5eda15a636d5b8d68b5664d43167de21ed92204b.tar.gz
freebsd-ports-gnome-5eda15a636d5b8d68b5664d43167de21ed92204b.tar.zst
freebsd-ports-gnome-5eda15a636d5b8d68b5664d43167de21ed92204b.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
-rw-r--r--textproc/p5-RDF-Notation3/Makefile8
-rw-r--r--www/bkmrkconv/Makefile8
-rw-r--r--x11-fonts/mkitalic/Makefile5
3 files changed, 6 insertions, 15 deletions
diff --git a/textproc/p5-RDF-Notation3/Makefile b/textproc/p5-RDF-Notation3/Makefile
index 207600d4b7c8..689e8c4f4d98 100644
--- a/textproc/p5-RDF-Notation3/Makefile
+++ b/textproc/p5-RDF-Notation3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: RDF::Notation3
-# Date created: 21 Nov 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= RDF-Notation3
PORTVERSION= 0.91
@@ -32,7 +28,7 @@ MAN3= RDF::Notation3.3 RDF::Notation3::PrefTriples.3 \
post-patch:
@${FIND} ${WRKSRC} -name "*.pm" | \
- ${XARGS} ${PERL} -pi -e 's!^require 5.005_62;!!'
+ ${XARGS} ${REINPLACE_CMD} -i '' -e 's!^require 5.005_62;!!'
${MV} ${WRKSRC}/doc/*.pod ${WRKSRC}/lib/RDF
.include <bsd.port.mk>
diff --git a/www/bkmrkconv/Makefile b/www/bkmrkconv/Makefile
index 7b26807c3022..ee11a51ec751 100644
--- a/www/bkmrkconv/Makefile
+++ b/www/bkmrkconv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bkmrkconv
-# Date created: 18 Dec 1999
-# Whom: Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
-#
PORTNAME= bkmrkconv
PORTVERSION= 1.12
@@ -17,7 +13,7 @@ USE_PERL5= yes
NO_BUILD= yes
post-patch:
- @${FIND} ${WRKSRC} -name '*.pl' | ${XARGS} ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name '*.pl' | ${XARGS} ${REINPLACE_CMD} -i '' -e \
's|/usr/bin/perl|${PERL}|g ; \
s|%%PREFIX%%|${PREFIX}|g'
diff --git a/x11-fonts/mkitalic/Makefile b/x11-fonts/mkitalic/Makefile
index 502cc7c8b40f..e8feb26b4dfe 100644
--- a/x11-fonts/mkitalic/Makefile
+++ b/x11-fonts/mkitalic/Makefile
@@ -20,9 +20,8 @@ EXTRACT_BEFORE_ARGS= #
EXTRACT_AFTER_ARGS= > ${WRKSRC}/mkitalic
NO_WRKSUBDIR= yes
USE_BZIP2= yes
-
-do-build:
- ${PERL} -pi.orig -e 's|^#!/usr/bin/perl|#! ${PERL}|' ${WRKSRC}/mkitalic
+USES= shebangfix
+SHEBANG_FILES= mkitalic
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/mkitalic ${PREFIX}/bin