aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2009-03-19 00:45:44 +0800
committeritetcu <itetcu@FreeBSD.org>2009-03-19 00:45:44 +0800
commit5f3d23c9a7244133e708ffa8185ccce48ff455e0 (patch)
treeea168832ca19d1dc58ea04869d93210fc5a4f6e2
parentd86cc2ad254b4d43939ed13ee9a32246d0a29ac3 (diff)
downloadfreebsd-ports-gnome-5f3d23c9a7244133e708ffa8185ccce48ff455e0.tar.gz
freebsd-ports-gnome-5f3d23c9a7244133e708ffa8185ccce48ff455e0.tar.zst
freebsd-ports-gnome-5f3d23c9a7244133e708ffa8185ccce48ff455e0.zip
- Update to latest upstream release (0.14.2)
- Add new ffmpeg knob to options, and LIBDEPENDS for avcodec/avformat/avutil - change wording on id3tag knob to specify id3 v1/v2 instead of just v1 - change shoutcast wording to specify ogg (so that it is clearer) - change several configure args to sync with the upstream. This includes --enable-mpd-id3tag, --disable-ogg, --disable-shout are now: --disable-id3, --disable-oggvorbis, --disable-shout-ogg and added --disable-shout-mp3. - Removed outdated iconv knob as this is no longer a valid configure option in musicpd configure script - rename files/musicpd.sh.in --> files/musicpd.sh to follow current rc.d practices. PR: ports/131914 Submitted by: David Horn Approved by: maintainer
-rw-r--r--audio/musicpd/Makefile35
-rw-r--r--audio/musicpd/distinfo6
-rw-r--r--audio/musicpd/files/musicpd.in (renamed from audio/musicpd/files/musicpd.sh.in)0
3 files changed, 22 insertions, 19 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 0721645c678d..ac0a1621ff06 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -6,12 +6,9 @@
#
PORTNAME= musicpd
-PORTVERSION= 0.14.1
-PORTREVISION= 1
+PORTVERSION= 0.14.2
CATEGORIES= audio ipv6
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
+MASTER_SITES= SF
DISTNAME= mpd-${PORTVERSION}
MAINTAINER= jo.lindqvist@gmail.com
@@ -24,7 +21,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20
-USE_RC_SUBR= musicpd.sh
+USE_RC_SUBR= ${PORTNAME}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -44,13 +41,13 @@ OPTIONS= FLAC "Support FLAC audio format" on \
AAC "Support MP4/AAC audio format" off \
MUSEPACK "Support MPC audio format" off \
MOD "Support MOD audio format" off \
- ICONV "Support international characters" on \
- ID3TAG "Support id3v1 tag encoding" off \
+ FFMPEG "Support FFMPEG (wma aiff ac3 ape...)" on \
+ ID3TAG "Support ID3 v1/v2 tags" on \
IPV6 "Support IPv6 protocol" on \
AO "Support libao audio library" off \
PULSEAUDIO "Support PulseAudio sound server" off \
JACK "Support JACK audio server" off \
- SHOUTCAST "Support for Icecast and Shoutcast" off \
+ SHOUTCAST "Support for OGG Icecast and Shoutcast" off \
LAME "Support for MP3 Icecast Streams" off \
SAMPLERATE "Support sample rate conversion" off
@@ -64,7 +61,7 @@ LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
.endif
.if defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+=--disable-ogg
+CONFIGURE_ARGS+=--disable-oggvorbis
.else
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
.endif
@@ -81,7 +78,10 @@ CONFIGURE_ARGS+=--disable-aac
.endif
.if defined(WITH_LAME)
+CONFIGURE_ARGS+=--enable-shout-mp3
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
+.else
+CONFIGURE_ARGS+=--disable-shout-mp3
.endif
.if defined(WITHOUT_WAV)
@@ -102,15 +102,18 @@ LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
CONFIGURE_ARGS+=--disable-mod
.endif
-.if defined(WITHOUT_ICONV)
-CONFIGURE_ARGS+=--disable-iconv
+.if defined(WITHOUT_FFMPEG)
+CONFIGURE_ARGS+=--disable-ffmpeg
.else
-USE_ICONV= yes
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
+ avformat:${PORTSDIR}/multimedia/ffmpeg \
+ avutil.1:${PORTSDIR}/multimedia/ffmpeg
.endif
-.if defined(WITH_ID3TAG)
+.if defined(WITHOUT_ID3TAG)
+CONFIGURE_ARGS+=--disable-id3
+.else
LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
-CONFIGURE_ARGS+=--enable-mpd-id3tag
.endif
.if defined(WITHOUT_IPV6)
@@ -139,7 +142,7 @@ CONFIGURE_ARGS+=--disable-jack
.if defined(WITH_SHOUTCAST) && !defined(WITH_TREMOR)
LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
.else
-CONFIGURE_ARGS+=--disable-shout
+CONFIGURE_ARGS+=--disable-shout-ogg
.endif
.if defined(WITHOUT_SAMPLERATE)
diff --git a/audio/musicpd/distinfo b/audio/musicpd/distinfo
index eee08e5d7f63..4894c229184c 100644
--- a/audio/musicpd/distinfo
+++ b/audio/musicpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (mpd-0.14.1.tar.bz2) = 4bc78cbc64728cddb0ace81867565204
-SHA256 (mpd-0.14.1.tar.bz2) = b7e1fc95701a84583077def6e1c507e2bfb759aa42e04d1eca498094bf0fc694
-SIZE (mpd-0.14.1.tar.bz2) = 286850
+MD5 (mpd-0.14.2.tar.bz2) = 66817a4b4c05454e6488f6b821f2a6a3
+SHA256 (mpd-0.14.2.tar.bz2) = 0b3926a141873f179efc3c3b9d296b65d332dbb898340ac5e5d1dd0c3dd9fb20
+SIZE (mpd-0.14.2.tar.bz2) = 287115
diff --git a/audio/musicpd/files/musicpd.sh.in b/audio/musicpd/files/musicpd.in
index 66684f6f3eb4..66684f6f3eb4 100644
--- a/audio/musicpd/files/musicpd.sh.in
+++ b/audio/musicpd/files/musicpd.in