aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-06-19 02:40:13 +0800
committerhrs <hrs@FreeBSD.org>2013-06-19 02:40:13 +0800
commit5fd024f710154f11389f559ff81a2037155693f4 (patch)
tree888bff386a8f094d6e986b8f8ffb9f160111c34f
parentb7ba4934257e00fb2e182fdfeda20a31c9945e21 (diff)
downloadfreebsd-ports-gnome-5fd024f710154f11389f559ff81a2037155693f4.tar.gz
freebsd-ports-gnome-5fd024f710154f11389f559ff81a2037155693f4.tar.zst
freebsd-ports-gnome-5fd024f710154f11389f559ff81a2037155693f4.zip
Add security/fbopenssl, a library containing extensions to OpenSSL,
including support for GSS-API (RFC 2743) and SPNEGO (RFC 2478).
-rw-r--r--security/Makefile1
-rw-r--r--security/fbopenssl/Makefile34
-rw-r--r--security/fbopenssl/distinfo2
-rw-r--r--security/fbopenssl/files/BSDMakefile36
-rw-r--r--security/fbopenssl/pkg-descr7
-rw-r--r--security/fbopenssl/pkg-plist11
6 files changed, 91 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5f3ab5892b39..7745e3ffbeaa 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -127,6 +127,7 @@
SUBDIR += fakebo
SUBDIR += fakeident
SUBDIR += fakeroot
+ SUBDIR += fbopenssl
SUBDIR += fcheck
SUBDIR += fcrackzip
SUBDIR += fiked
diff --git a/security/fbopenssl/Makefile b/security/fbopenssl/Makefile
new file mode 100644
index 000000000000..31732e674264
--- /dev/null
+++ b/security/fbopenssl/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= fbopenssl
+PORTVERSION= 0.0.4
+CATEGORIES= security
+MASTER_SITES= SF/modgssapache/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= GSS-API and SPNEGO extensions for OpenSSL
+
+LICENSE= GPLv2
+
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+MAKEFILE= BSDMakefile
+MAKE_ENV= BSD_INSTALL_DATA="${BSD_INSTALL_DATA}"
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PORTDOCS= readme.txt
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-extract:
+ ${INSTALL_DATA} ${FILESDIR}/BSDMakefile ${WRKSRC}
+
+.if ${PORT_OPTIONS:MDOCS}
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/fbopenssl/distinfo b/security/fbopenssl/distinfo
new file mode 100644
index 000000000000..468f910ef262
--- /dev/null
+++ b/security/fbopenssl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fbopenssl-0.0.4.tar.gz) = 8d850c7410bc3d5221ff128ca1cc1dbfb20a024ffbb142cc34e84c0af2f12e45
+SIZE (fbopenssl-0.0.4.tar.gz) = 15627
diff --git a/security/fbopenssl/files/BSDMakefile b/security/fbopenssl/files/BSDMakefile
new file mode 100644
index 000000000000..590ebb313f9a
--- /dev/null
+++ b/security/fbopenssl/files/BSDMakefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PREFIX?= /usr/local
+OPENSSLLIB?= /usr/lib
+OPENSSLINC?= /usr/include/openssl
+BSD_INSTALL_DATA?= install -m 0444
+
+LIB= fbopenssl
+LIBDIR= ${PREFIX}/lib
+SHLIBDIR= ${PREFIX}/lib
+SHLIB_MAJOR= 0
+NO_MAN=
+
+CFLAGS+=-ansi -I${OPENSSLINC}
+LDADD= -Wl,-R${OPENSSLLIB} -L${OPENSSLLIB} -lcrypto
+
+.PATH: src/asn1 src/file src/gssapi src/krb5 src/spnego
+SRCS= asn1help.c \
+ filehelp.c \
+ gssapi.c \
+ krb5help.c \
+ spnego.c \
+ spnegohelp.c
+
+FILES= include/asn1help.h \
+ include/filehelp.h \
+ include/gssapi.h \
+ include/krb5help.h \
+ include/spnego.h \
+ include/spnegohelp.h
+FILESDIR?= ${PREFIX}/include/fbopenssl
+
+beforeinstall:
+ install -m 0755 -d ${PREFIX}/include/fbopenssl
+
+.include <bsd.lib.mk>
diff --git a/security/fbopenssl/pkg-descr b/security/fbopenssl/pkg-descr
new file mode 100644
index 000000000000..a3387a73306b
--- /dev/null
+++ b/security/fbopenssl/pkg-descr
@@ -0,0 +1,7 @@
+fbopenssl is a library containing extensions to OpenSSL,
+including support for:
+
+- GSS-API (RFC 2743)
+- SPNEGO (RFC 2478)
+
+WWW: http://modgssapache.sourceforge.net/
diff --git a/security/fbopenssl/pkg-plist b/security/fbopenssl/pkg-plist
new file mode 100644
index 000000000000..95250179b6e1
--- /dev/null
+++ b/security/fbopenssl/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+include/fbopenssl/asn1help.h
+include/fbopenssl/filehelp.h
+include/fbopenssl/gssapi.h
+include/fbopenssl/krb5help.h
+include/fbopenssl/spnego.h
+include/fbopenssl/spnegohelp.h
+lib/libfbopenssl.a
+lib/libfbopenssl_p.a
+lib/libfbopenssl.so
+lib/libfbopenssl.so.0