aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-10-17 00:25:15 +0800
committerknu <knu@FreeBSD.org>2002-10-17 00:25:15 +0800
commit6066c6cbeadfe84e4d6aaa3ee225a466ccec6770 (patch)
tree7fcf2cd9d7603ea37643402232a94a8bde3b939a
parentbc769d773bddba79205f6df28d0f20702ac5aa95 (diff)
downloadfreebsd-ports-gnome-6066c6cbeadfe84e4d6aaa3ee225a466ccec6770.tar.gz
freebsd-ports-gnome-6066c6cbeadfe84e4d6aaa3ee225a466ccec6770.tar.zst
freebsd-ports-gnome-6066c6cbeadfe84e4d6aaa3ee225a466ccec6770.zip
Add ruby-yaml 0.44, a YAML serialization specification implementation
for Ruby. PR: ports/40679 (version 0.20) Submitted by: Stanislav Grozev <tacho@factline.com> Modified by: knu
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-yaml/Makefile34
-rw-r--r--devel/ruby-yaml/distinfo1
-rw-r--r--devel/ruby-yaml/pkg-comment1
-rw-r--r--devel/ruby-yaml/pkg-descr24
-rw-r--r--devel/ruby-yaml/pkg-plist10
6 files changed, 71 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 63664e1bcdf4..88d42f82a690 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -719,6 +719,7 @@
SUBDIR += ruby-textbuf
SUBDIR += ruby-tzfile
SUBDIR += ruby-unit
+ SUBDIR += ruby-yaml
SUBDIR += rudiments
SUBDIR += rvi
SUBDIR += rvm
diff --git a/devel/ruby-yaml/Makefile b/devel/ruby-yaml/Makefile
new file mode 100644
index 000000000000..ce8ba4476072
--- /dev/null
+++ b/devel/ruby-yaml/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: YAML4R
+# Date created: 16 Jul 2002
+# Whom: Stanislav Grozev <tacho@daemonz.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yaml
+PORTVERSION= 0.44
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}4r
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}rb-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= tacho@daemonz.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= CHANGELOG README yts/cookbook.html
+
+do-install:
+ @cd ${WRKSRC}; ${RUBY} install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-yaml/distinfo b/devel/ruby-yaml/distinfo
new file mode 100644
index 000000000000..b870cb71446c
--- /dev/null
+++ b/devel/ruby-yaml/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/yamlrb-0.44.tar.gz) = 8897e0f4ead6a017ac206adf56713e51
diff --git a/devel/ruby-yaml/pkg-comment b/devel/ruby-yaml/pkg-comment
new file mode 100644
index 000000000000..20b9e873ae69
--- /dev/null
+++ b/devel/ruby-yaml/pkg-comment
@@ -0,0 +1 @@
+A YAML serialization specification implementation for Ruby
diff --git a/devel/ruby-yaml/pkg-descr b/devel/ruby-yaml/pkg-descr
new file mode 100644
index 000000000000..43eeebbaff0c
--- /dev/null
+++ b/devel/ruby-yaml/pkg-descr
@@ -0,0 +1,24 @@
+"YAML(tm) (rhymes with 'camel') is a
+straightforward machine parsable data serialization format designed for
+human readability and interaction with scripting languages such as Perl
+and Python. YAML is optimized for data serialization, formatted
+dumping, configuration files, log files, Internet messaging and
+filtering. This specification describes the YAML information model and
+serialization format. Together with the Unicode standard for characters, it
+provides all the information necessary to understand YAML Version 1.0
+and construct computer programs to process it."
+
+For Ruby developers, YAML is a natural fit for object serialization and
+general data storage. Really, it's quite fantastic. Spreads right on
+your Rubyware like butter on bread!
+
+The possible uses for YAML are innumerable. Configuration files,
+custom internet protocols, documentation, the list goes on and on.
+Also, with YAML readers popping up for other languages (see YAML.pm
+and others), you can pass data easily to colleagues in distant lands,
+swamped in their archaic languages.
+
+WWW: http://yaml4r.sourceforge.net/
+
+- Stanislav Grozev
+tacho@daemonz.org
diff --git a/devel/ruby-yaml/pkg-plist b/devel/ruby-yaml/pkg-plist
new file mode 100644
index 000000000000..df85629a93af
--- /dev/null
+++ b/devel/ruby-yaml/pkg-plist
@@ -0,0 +1,10 @@
+%%RUBY_SITELIBDIR%%/okay.rb
+%%RUBY_SITELIBDIR%%/okay/news.rb
+%%RUBY_SITELIBDIR%%/okay/rpc.rb
+%%RUBY_SITELIBDIR%%/yaml.rb
+%%RUBY_SITELIBDIR%%/yod.rb
+@dirrm %%RUBY_SITELIBDIR%%/okay
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGELOG
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/cookbook.html
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%