aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2005-11-17 04:25:36 +0800
committerlth <lth@FreeBSD.org>2005-11-17 04:25:36 +0800
commit61e9d48a5e9c2642cbcb04bf8f55bd873bbca0c8 (patch)
treea000752a53670c5c69442a565a4f5b82263160ce
parenteac0b9d95c5798cedfb60105f0e69fc540cadaf1 (diff)
downloadfreebsd-ports-gnome-61e9d48a5e9c2642cbcb04bf8f55bd873bbca0c8.tar.gz
freebsd-ports-gnome-61e9d48a5e9c2642cbcb04bf8f55bd873bbca0c8.tar.zst
freebsd-ports-gnome-61e9d48a5e9c2642cbcb04bf8f55bd873bbca0c8.zip
Add p5-HTTP-Request-AsCGI 0.2, setup a CGI enviroment from a
HTTP::Request. PR: ports/89136 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Request-AsCGI/Makefile32
-rw-r--r--www/p5-HTTP-Request-AsCGI/distinfo3
-rw-r--r--www/p5-HTTP-Request-AsCGI/pkg-descr3
-rw-r--r--www/p5-HTTP-Request-AsCGI/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb934940dc4b..c5f01aea0602 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -554,6 +554,7 @@
SUBDIR += p5-HTTP-MobileAgent
SUBDIR += p5-HTTP-Proxy
SUBDIR += p5-HTTP-Recorder
+ SUBDIR += p5-HTTP-Request-AsCGI
SUBDIR += p5-HTTP-Server-Simple
SUBDIR += p5-HTTP-Server-Simple-Mason
SUBDIR += p5-HTTP-Server-Simple-Static
diff --git a/www/p5-HTTP-Request-AsCGI/Makefile b/www/p5-HTTP-Request-AsCGI/Makefile
new file mode 100644
index 000000000000..eb984e7b635d
--- /dev/null
+++ b/www/p5-HTTP-Request-AsCGI/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: p5-HTTP-Request-AsCGI
+# Date created: Nov 16, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Request-AsCGI
+PORTVERSION= 0.2
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MR/MRAMBERG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Setup a CGI enviroment from a HTTP::Request
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Request::AsCGI.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Request-AsCGI/distinfo b/www/p5-HTTP-Request-AsCGI/distinfo
new file mode 100644
index 000000000000..5b47676f281a
--- /dev/null
+++ b/www/p5-HTTP-Request-AsCGI/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Request-AsCGI-0.2.tar.gz) = 6180359421936b6a9579a4fb00c82d82
+SHA256 (HTTP-Request-AsCGI-0.2.tar.gz) = a04e961c0ac90651129f6edb995e9a2ef34c0327f97afb411514900d15bae4f3
+SIZE (HTTP-Request-AsCGI-0.2.tar.gz) = 5710
diff --git a/www/p5-HTTP-Request-AsCGI/pkg-descr b/www/p5-HTTP-Request-AsCGI/pkg-descr
new file mode 100644
index 000000000000..9f727f3cee0e
--- /dev/null
+++ b/www/p5-HTTP-Request-AsCGI/pkg-descr
@@ -0,0 +1,3 @@
+Provides a convinient way of setting up an CGI enviroment from a HTTP::Request.
+
+WWW: http://search.cpan.org/dist/HTTP-Request-AsCGI/
diff --git a/www/p5-HTTP-Request-AsCGI/pkg-plist b/www/p5-HTTP-Request-AsCGI/pkg-plist
new file mode 100644
index 000000000000..59af892a5742
--- /dev/null
+++ b/www/p5-HTTP-Request-AsCGI/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTTP/Request/AsCGI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Request/AsCGI/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Request 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Request/AsCGI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Request 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP 2>/dev/null || true