aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-06-30 22:51:11 +0800
committerantoine <antoine@FreeBSD.org>2013-06-30 22:51:11 +0800
commit62798a57c836ec77deea8e3af6d298950a0d8056 (patch)
treea05d220c84c47a8095bae0ceda8fed91c9297b55
parenta1c56d0ca646002f7301730424e26785e7a5e6e9 (diff)
downloadfreebsd-ports-gnome-62798a57c836ec77deea8e3af6d298950a0d8056.tar.gz
freebsd-ports-gnome-62798a57c836ec77deea8e3af6d298950a0d8056.tar.zst
freebsd-ports-gnome-62798a57c836ec77deea8e3af6d298950a0d8056.zip
New port: py-binplist
A binary property list parser module written in python
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-binplist/Makefile23
-rw-r--r--devel/py-binplist/distinfo2
-rw-r--r--devel/py-binplist/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f3dc332f48b7..7abbbec02a8f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3452,6 +3452,7 @@
SUBDIR += py-avro
SUBDIR += py-babel
SUBDIR += py-billiard
+ SUBDIR += py-binplist
SUBDIR += py-bison
SUBDIR += py-bitarray
SUBDIR += py-bitstring
diff --git a/devel/py-binplist/Makefile b/devel/py-binplist/Makefile
new file mode 100644
index 000000000000..c9bf1c342b72
--- /dev/null
+++ b/devel/py-binplist/Makefile
@@ -0,0 +1,23 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= binplist
+PORTVERSION= 0.1.1
+CATEGORIES= devel python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Binary plist parser
+
+LICENSE= AL2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+PLIST_FILES= bin/binplist \
+ %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/devel/py-binplist/distinfo b/devel/py-binplist/distinfo
new file mode 100644
index 000000000000..98ff36d651f2
--- /dev/null
+++ b/devel/py-binplist/distinfo
@@ -0,0 +1,2 @@
+SHA256 (binplist-0.1.1.tar.gz) = 244a269ca686195d461f3ccf33bca1ba7e3c3f840818f69e7a20b1f7e7d7d1b9
+SIZE (binplist-0.1.1.tar.gz) = 14796
diff --git a/devel/py-binplist/pkg-descr b/devel/py-binplist/pkg-descr
new file mode 100644
index 000000000000..28c8b75dd024
--- /dev/null
+++ b/devel/py-binplist/pkg-descr
@@ -0,0 +1,3 @@
+Binary property list (plist) parser module written in python.
+
+WWW: http://code.google.com/p/binplist/