aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-12-31 09:42:04 +0800
committerlioux <lioux@FreeBSD.org>2004-12-31 09:42:04 +0800
commit62d349e70b31e428303ffa12b60cfabeffa8b367 (patch)
tree1e2c74d826008537275ebe17f959cf5165a91a27
parent1f910e6c9a6ca949c7d30daa571905536bba1f45 (diff)
downloadfreebsd-ports-gnome-62d349e70b31e428303ffa12b60cfabeffa8b367.tar.gz
freebsd-ports-gnome-62d349e70b31e428303ffa12b60cfabeffa8b367.tar.zst
freebsd-ports-gnome-62d349e70b31e428303ffa12b60cfabeffa8b367.zip
New port gnu-crypto version 2.0.1: Java cryptographic primitives
and tools
-rw-r--r--security/Makefile1
-rw-r--r--security/gnu-crypto/Makefile67
-rw-r--r--security/gnu-crypto/distinfo2
-rw-r--r--security/gnu-crypto/pkg-descr14
4 files changed, 84 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 26da258d041b..564c695274fe 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -107,6 +107,7 @@
SUBDIR += gnome-ssh-askpass
SUBDIR += gnomekeyring
SUBDIR += gnomekeyringmanager
+ SUBDIR += gnu-crypto
SUBDIR += gnupg
SUBDIR += gnupg-devel
SUBDIR += gnupg-idea
diff --git a/security/gnu-crypto/Makefile b/security/gnu-crypto/Makefile
new file mode 100644
index 000000000000..f73882177c4c
--- /dev/null
+++ b/security/gnu-crypto/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: gnu-crypto
+# Date created: Fri Dec 31 00:00:25 UTC 2004
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnu-crypto
+PORTVERSION= 2.0.1
+CATEGORIES= security java
+MASTER_SITES= ${MASTER_SITE_GNUPG}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Java cryptographic primitives and tools
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ENV+= \
+ CLASSPATH='' \
+ JAR=${JAR} \
+ JAVA=${JAVA} \
+ JAVAC=${JAVAC}
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+USE_ANT= yes
+
+JAR_DIR= share/java/jar/${PORTNAME}
+JAR_FILES= \
+ javax-crypto.jar \
+ javax-security.jar \
+ gnu-crypto.jar
+
+INFO= gnu-crypto
+MAKEINFOFLAGS= --no-split
+
+.for jar in ${JAR_FILES}
+PLIST_FILES+= ${JAR_DIR}/${jar}
+.endfor
+
+PLIST_DIRS+= ${JAR_DIR}
+
+post-extract:
+ @${RM} ${WRKSRC}/docs/*.info*
+
+post-configure:
+ @${REINPLACE_CMD} -E \
+ -e 's|(\$$\(MAKEINFOFLAGS\))|\1 --no-split|' \
+ ${BUILD_WRKSRC}/docs/${MAKEFILE}
+
+post-build:
+ @cd ${WRKSRC}/docs && ${GMAKE} all
+
+do-install:
+ @${MKDIR} ${PREFIX}/${JAR_DIR}
+.for jar in ${JAR_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${jar} ${PREFIX}/${JAR_DIR}
+.endfor
+ @${MKDIR} ${PREFIX}/${INFO_PATH}
+ @${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.info \
+ ${PREFIX}/${INFO_PATH}
+
+.include <bsd.port.mk>
diff --git a/security/gnu-crypto/distinfo b/security/gnu-crypto/distinfo
new file mode 100644
index 000000000000..e2ba5ed8db07
--- /dev/null
+++ b/security/gnu-crypto/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnu-crypto-2.0.1.tar.bz2) = 39ac686b8f7ecfb95de7d58c85b8935b
+SIZE (gnu-crypto-2.0.1.tar.bz2) = 3895714
diff --git a/security/gnu-crypto/pkg-descr b/security/gnu-crypto/pkg-descr
new file mode 100644
index 000000000000..dbb59498e4d9
--- /dev/null
+++ b/security/gnu-crypto/pkg-descr
@@ -0,0 +1,14 @@
+[ excerpt from developer's web site ]
+
+GNU Crypto, part of the GNU project, released under the aegis of
+GNU, aims at providing free, versatile, high-quality, and provably
+correct implementations of cryptographic primitives and tools in
+the Java programming language for use by programmers and end-users.
+
+GNU Crypto is licensed under the terms of the GNU General Public
+License, with the "library exception" which permits its use as a
+library in conjunction with non-Free software.
+
+WWW: http://www.gnu.org/software/gnu-crypto/
+
+-- lioux@FreeBSD.org