aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-03-09 21:58:31 +0800
committermm <mm@FreeBSD.org>2011-03-09 21:58:31 +0800
commit63809c745ebe07a247f00ba3cebfc470a83483d4 (patch)
tree3ee3ac11ba9d93bf9c52f2bb09ad382bab3ddcfb
parent6492d6c6fb186c503ec65d89e1e22be66271aa44 (diff)
downloadfreebsd-ports-gnome-63809c745ebe07a247f00ba3cebfc470a83483d4.tar.gz
freebsd-ports-gnome-63809c745ebe07a247f00ba3cebfc470a83483d4.tar.zst
freebsd-ports-gnome-63809c745ebe07a247f00ba3cebfc470a83483d4.zip
- Update to 6.6.7.10
- Change WITH_IMAGEMAGICK_SVG to on by default and only warn if WITHOUT_X11 - Fix dependency on liblzma
-rw-r--r--graphics/ImageMagick/Makefile23
-rw-r--r--graphics/ImageMagick/distinfo4
-rw-r--r--graphics/ImageMagick/pkg-plist18
3 files changed, 35 insertions, 10 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 5903c0dc0389..b36581db2865 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ImageMagick
-DISTVERSION= 6.6.6-10
+DISTVERSION= 6.6.7-10
CATEGORIES= graphics perl5
MASTER_SITES= ftp://ftp.imagemagick.org/pub/ImageMagick/ \
ftp://ftp.nluug.nl/pub/ImageMagick/ \
@@ -51,6 +51,7 @@ OPTIONS=\
IMAGEMAGICK_JPEG "JPG format support" on \
IMAGEMAGICK_JPEG2000 "JPEG2000 format support" on \
IMAGEMAGICK_LCMS "LCMS support" on \
+ IMAGEMAGICK_LZMA "LZMA support" on \
IMAGEMAGICK_LQR "Liquid Rescale support" on \
IMAGEMAGICK_MODULES "Modules support" on \
IMAGEMAGICK_OPENEXR "OpenEXR support (needs threads)" off \
@@ -58,7 +59,7 @@ OPTIONS=\
IMAGEMAGICK_PDF "PDF format support" on \
IMAGEMAGICK_PERL "Perl support" on \
IMAGEMAGICK_PNG "PNG format support" on \
- IMAGEMAGICK_SVG "SVG format support" off \
+ IMAGEMAGICK_SVG "SVG format support" on \
IMAGEMAGICK_TESTS "Run bundled self-tests after build" on \
IMAGEMAGICK_TIFF "TIFF format support" on \
IMAGEMAGICK_TTF "Freetype support" on \
@@ -269,6 +270,15 @@ LDFLAGS+= -L${LOCALBASE}/lib/graphviz
CONFIGURE_ARGS+= --without-gvc
.endif
+# LZMA support
+.if !defined(WITHOUT_LZMA)
+. if (${OSVERSION} >= 900000 && ${OSVERSION} < 900012) || (${OSVERSION} < 800505)
+LIB_DEPENDS= lzma:${PORTSDIR}/archivers/xz
+. endif
+.else
+CONFIGURE_ARGS+= --without-lzma
+.endif
+
# LCMS (Little CMS) color management
.if !defined(WITHOUT_IMAGEMAGICK_LCMS)
LIB_DEPENDS+= lcms:${PORTSDIR}/graphics/lcms
@@ -308,16 +318,12 @@ PLIST_SUB+= WMF="@comment "
.endif
# SVG (Scalable Vector Graphics) requires both libxml2 and X11
-.if defined(WITH_IMAGEMAGICK_SVG)
-. if defined(WITHOUT_X11)
-IGNORE= svg support requires X11
-. else
+.if defined(WITH_IMAGEMAGICK_SVG) && !defined(WITHOUT_X11)
USE_GNOME+= libxml2
LIB_DEPENDS+= rsvg-2:${PORTSDIR}/graphics/librsvg2
CONFIGURE_ARGS+= --with-rsvg --with-xml
CONFIGURE_ENV+= RSVG_CFLAGS="-I${LOCALBASE}/include/librsvg-2" \
RSVG_LIBS="-L${LOCALBASE}/lib"
-. endif
.else
CONFIGURE_ARGS+= --without-rsvg --without-xml
.endif
@@ -390,6 +396,9 @@ pre-configure:
@${ECHO_CMD} NOTICE: ${_IMAGEMAGICK_THREADS_PERL_MSG}. Building ImageMagick ${_IMAGEMAGICK_THREADS_MSG}.
@${ECHO_CMD} '###################################################################'
.endif
+.if defined(WITH_IMAGEMAGICK_SVG) && defined(WITHOUT_X11)
+ @${ECHO_CMD} NOTICE: SVG format support disabled (WITHOUT_X11)
+.endif
post-install:
.if !defined(WITHOUT_IMAGEMAGICK_PERL)
diff --git a/graphics/ImageMagick/distinfo b/graphics/ImageMagick/distinfo
index 2a4ef349d715..c6d002d8f064 100644
--- a/graphics/ImageMagick/distinfo
+++ b/graphics/ImageMagick/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ImageMagick-6.6.6-10.tar.xz) = d37187ae3063030d82624e5548db5f788dcfd8e5c9de3edc15c6b36e32c93e9e
-SIZE (ImageMagick-6.6.6-10.tar.xz) = 6449280
+SHA256 (ImageMagick-6.6.7-10.tar.xz) = 9e77a2fa64956b2d22f4bed95c46b34c3c2745f6a4fedfe14319bc0e76e26c2f
+SIZE (ImageMagick-6.6.7-10.tar.xz) = 7634160
diff --git a/graphics/ImageMagick/pkg-plist b/graphics/ImageMagick/pkg-plist
index 233096defbaf..19898d589cf5 100644
--- a/graphics/ImageMagick/pkg-plist
+++ b/graphics/ImageMagick/pkg-plist
@@ -149,6 +149,8 @@ lib/ImageMagick-%%PORTVERSION%%/config/type-dejavu.xml
lib/ImageMagick-%%PORTVERSION%%/config/type-ghostscript.xml
lib/ImageMagick-%%PORTVERSION%%/config/type-windows.xml
lib/ImageMagick-%%PORTVERSION%%/modules-%%QBIT%%/coders/.keep
+%%MODULES%%lib/ImageMagick-%%PORTVERSION%%/modules-%%QBIT%%/coders/aai.la
+%%MODULES%%lib/ImageMagick-%%PORTVERSION%%/modules-%%QBIT%%/coders/aai.so
%%MODULES%%lib/ImageMagick-%%PORTVERSION%%/modules-%%QBIT%%/coders/art.la
%%MODULES%%lib/ImageMagick-%%PORTVERSION%%/modules-%%QBIT%%/coders/art.so
%%MODULES%%lib/ImageMagick-%%PORTVERSION%%/modules-%%QBIT%%/coders/avs.la
@@ -420,6 +422,7 @@ libdata/pkgconfig/Wand.pc
%%PORTDOCS%%%%DOCSDIR%%/images/cylinder_shaded.png
%%PORTDOCS%%%%DOCSDIR%%/images/definitive-guide.png
%%PORTDOCS%%%%DOCSDIR%%/images/difference.png
+%%PORTDOCS%%%%DOCSDIR%%/images/donate.png
%%PORTDOCS%%%%DOCSDIR%%/images/examples.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/frame.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/fuzzy-magick.png
@@ -427,7 +430,10 @@ libdata/pkgconfig/Wand.pc
%%PORTDOCS%%%%DOCSDIR%%/images/granite.png
%%PORTDOCS%%%%DOCSDIR%%/images/imade_art2.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/label.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/logo.eps
+%%PORTDOCS%%%%DOCSDIR%%/images/logo-sm-flop.png
+%%PORTDOCS%%%%DOCSDIR%%/images/logo-sm-fx.png
+%%PORTDOCS%%%%DOCSDIR%%/images/logo-sm.png
+%%PORTDOCS%%%%DOCSDIR%%/images/logo.png
%%PORTDOCS%%%%DOCSDIR%%/images/logo.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/montage.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/navy.png
@@ -451,6 +457,7 @@ libdata/pkgconfig/Wand.pc
%%PORTDOCS%%%%DOCSDIR%%/images/t-shirt.png
%%PORTDOCS%%%%DOCSDIR%%/images/tricks.png
%%PORTDOCS%%%%DOCSDIR%%/images/wand.ico
+%%PORTDOCS%%%%DOCSDIR%%/images/wand.png
%%PORTDOCS%%%%DOCSDIR%%/images/white-highlight.png
%%PORTDOCS%%%%DOCSDIR%%/images/wizard.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/wizard.png
@@ -934,6 +941,7 @@ libdata/pkgconfig/Wand.pc
%%PORTDOCS%%%%DOCSDIR%%/www/api/MagickCore/struct__Ascii85Info.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/MagickCore/struct__BlobInfo.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/MagickCore/struct__CacheInfo.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/MagickCore/struct__CacheView.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/MagickCore/struct__CacheMethods.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/MagickCore/struct__ChannelStatistics.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/MagickCore/struct__ChromaticityInfo.html
@@ -1230,6 +1238,7 @@ libdata/pkgconfig/Wand.pc
%%PORTDOCS%%%%DOCSDIR%%/www/api/enhance.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/exception.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/feature.html
+%%PORTDOCS%%%%DOCSDIR%%/www/api/fourier.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/fx.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/histogram.html
%%PORTDOCS%%%%DOCSDIR%%/www/api/image.html
@@ -1317,17 +1326,24 @@ libdata/pkgconfig/Wand.pc
%%PORTDOCS%%%%DOCSDIR%%/www/source/coder.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/colors.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/configure.xml
+%%PORTDOCS%%%%DOCSDIR%%/www/source/contrast.c
%%PORTDOCS%%%%DOCSDIR%%/www/source/core.c
%%PORTDOCS%%%%DOCSDIR%%/www/source/delegates.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/english.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/examples.pl
+%%PORTDOCS%%%%DOCSDIR%%/www/source/francais.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/incantation.msl
%%PORTDOCS%%%%DOCSDIR%%/www/source/locale.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/log.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/magic.xml
+%%PORTDOCS%%%%DOCSDIR%%/www/source/mgk.c
+%%PORTDOCS%%%%DOCSDIR%%/www/source/mime.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/piechart.mvg
%%PORTDOCS%%%%DOCSDIR%%/www/source/piechart.svg
+%%PORTDOCS%%%%DOCSDIR%%/www/source/policy.xml
+%%PORTDOCS%%%%DOCSDIR%%/www/source/thresholds.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/type-ghostscript.xml
+%%PORTDOCS%%%%DOCSDIR%%/www/source/type-windows.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/type.xml
%%PORTDOCS%%%%DOCSDIR%%/www/source/wand.c
%%PORTDOCS%%%%DOCSDIR%%/www/sponsors.html