aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2014-06-01 20:35:41 +0800
committerse <se@FreeBSD.org>2014-06-01 20:35:41 +0800
commit6566acd7add5ff7d6e5dcf4212a533b487a918af (patch)
tree62098e47db95805fe4161b6aad1a7440f5e1d027
parent4b55616adac8cf2f07c9c3c6f9524f863fd962d9 (diff)
downloadfreebsd-ports-gnome-6566acd7add5ff7d6e5dcf4212a533b487a918af.tar.gz
freebsd-ports-gnome-6566acd7add5ff7d6e5dcf4212a533b487a918af.tar.zst
freebsd-ports-gnome-6566acd7add5ff7d6e5dcf4212a533b487a918af.zip
Add stage support and support for the DOCS option.
Approved by: antoine (mentor)
-rw-r--r--security/blindelephant/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/security/blindelephant/Makefile b/security/blindelephant/Makefile
index da284fdbab6e..c168a61ddbd9 100644
--- a/security/blindelephant/Makefile
+++ b/security/blindelephant/Makefile
@@ -14,7 +14,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Fingerprint the web applications used by a web site
LICENSE= LGPL3
-USE_BZIP2= YES
+
+USES= tar:bzip2
USE_PYTHON= yes
USE_PYDISTUTILS= YES
@@ -22,10 +23,9 @@ SUB_FILES= ${PORTNAME}.sh
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} \
PATH=${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}
-PORTDOCS= README Blind_Elephant_BlackHat_2010.pdf
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+PORTDOCS= README Blind_Elephant_BlackHat_2010.pdf
post-extract:
@${MV} ${WRKSRC}/src/* ${WRKSRC}
@@ -33,12 +33,10 @@ post-extract:
${WRKSRC}/Blind_Elephant_BlackHat_2010.pdf
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
. for I in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${I} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${I} ${STAGEDIR}${DOCSDIR}
. endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>