aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-01-16 07:09:31 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-01-16 07:09:31 +0800
commit6772ac3d73eccf2c1e1a4547dadb1bfde5538774 (patch)
treed699b408d04df45416f9f6c93f7e571d593a6d8b
parent42e982f1852a754a6d470241d613ff8bb75017d0 (diff)
downloadfreebsd-ports-gnome-6772ac3d73eccf2c1e1a4547dadb1bfde5538774.tar.gz
freebsd-ports-gnome-6772ac3d73eccf2c1e1a4547dadb1bfde5538774.tar.zst
freebsd-ports-gnome-6772ac3d73eccf2c1e1a4547dadb1bfde5538774.zip
- Use correct default serial device on 8.x
PR: 140913 Submitted by: myself Approved by: maintainer timeout
-rw-r--r--comms/minicom/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 3f6cb9175fc8..6aa32b768f66 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -8,7 +8,7 @@
PORTNAME= minicom
PORTVERSION= 2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms
MASTER_SITES= http://alioth.debian.org/frs/download.php/2332/ \
ftp://ftp.nuug.no/pub/anders/distfiles/ \
@@ -35,11 +35,18 @@ CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
--sysconfdir=${PREFIX}/etc/minicom \
--enable-lock-dir=/var/spool/lock
-MINICOM_DEFAULT_PORT?= /dev/cuad0
CONFIGURE_ARGS+= --enable-dfl-port=${MINICOM_DEFAULT_PORT}
MAN1= minicom.1 runscript.1 ascii-xfr.1 xminicom.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800045
+MINICOM_DEFAULT_PORT?= /dev/cuad0
+.else
+MINICOM_DEFAULT_PORT?= /dev/cuau0
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s@/usr/local/bin/@${LOCALBASE}/bin/@; \
s@/sz@/lsz@;s@/sb@/lsb@;s@/sx@/lsx@;s@/rz@/lrz@; \
@@ -65,4 +72,4 @@ post-install:
${DOCSDIR})
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>