aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-01-30 05:44:50 +0800
committermezz <mezz@FreeBSD.org>2005-01-30 05:44:50 +0800
commit691e1551822a9ebb299da7a987d69e7bc389c996 (patch)
tree5d39f3c649e56bf26e52bef1940517a23f3775df
parentea6d9950772357668fcae0e897de6e20f32e2b04 (diff)
downloadfreebsd-ports-gnome-691e1551822a9ebb299da7a987d69e7bc389c996.tar.gz
freebsd-ports-gnome-691e1551822a9ebb299da7a987d69e7bc389c996.tar.zst
freebsd-ports-gnome-691e1551822a9ebb299da7a987d69e7bc389c996.zip
- Early ready for the future Perl change.
s|#!/usr/bin/perl|#!/usr/bin/env perl|g - Add perl5 in CATEGORIES. - Bump PORTREVISION.
-rw-r--r--graphics/cbview/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/cbview/Makefile b/graphics/cbview/Makefile
index 9bb005a70da3..a33cb863e66a 100644
--- a/graphics/cbview/Makefile
+++ b/graphics/cbview/Makefile
@@ -7,8 +7,8 @@
PORTNAME= cbview
PORTVERSION= 0.06
-PORTREVISION= 1
-CATEGORIES= graphics
+PORTREVISION= 2
+CATEGORIES= graphics perl5
MASTER_SITES= http://elvine.org/code/cbview/
MAINTAINER= mezz@FreeBSD.org
@@ -21,10 +21,15 @@ RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar \
NO_BUILD= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= COPYING Changes INSTALL README TODO
+post-patch:
+ @${REINPLACE_CMD} -e 's|perl -w|env perl -w|g' \
+ ${WRKSRC}/${PORTNAME}
+
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
.ifndef (NOPORTDOCS)