aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2013-01-05 11:00:14 +0800
committeravilla <avilla@FreeBSD.org>2013-01-05 11:00:14 +0800
commit69a51942d754cc314e77646bc76021fe818eceef (patch)
treecaeb1689e09dafc57913d0f1cf473f56bfc84d91
parent7d9153efbfce536a3e5686311ea0a0530cd73ae6 (diff)
downloadfreebsd-ports-gnome-69a51942d754cc314e77646bc76021fe818eceef.tar.gz
freebsd-ports-gnome-69a51942d754cc314e77646bc76021fe818eceef.tar.zst
freebsd-ports-gnome-69a51942d754cc314e77646bc76021fe818eceef.zip
- Port to optionsNG.
- Trim headers. - Cleanup COMMENT and LICENSE. PR: 173807 [1] Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> [1], bapt via email
-rw-r--r--accessibility/speech-dispatcher/Makefile86
-rw-r--r--comms/usbmuxd/Makefile16
-rw-r--r--devel/libplist/Makefile21
-rw-r--r--graphics/opengtl/Makefile14
4 files changed, 60 insertions, 77 deletions
diff --git a/accessibility/speech-dispatcher/Makefile b/accessibility/speech-dispatcher/Makefile
index cf3029173a2b..4c6fa6a769c6 100644
--- a/accessibility/speech-dispatcher/Makefile
+++ b/accessibility/speech-dispatcher/Makefile
@@ -1,7 +1,3 @@
-# New ports collection makefile for: speech-dispatcher
-# Date created: 8 December 2009
-# Whom: Alberto Villa <villa.alberto@gmail.com>
-#
# $FreeBSD$
PORTNAME= speech-dispatcher
@@ -16,8 +12,8 @@ COMMENT= Common interface to speech synthesis
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= dotconf.0:${PORTSDIR}/devel/dotconf \
- sndfile.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= dotconf:${PORTSDIR}/devel/dotconf \
+ sndfile:${PORTSDIR}/audio/libsndfile
# gnomehier is required because of share/sounds directory.
USE_GNOME= glib20 gnomehier pkgconfig
@@ -40,16 +36,14 @@ PLIST_SUB+= ETCFILES="${ETCFILES}"
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
-INFO= spd-say ${PORTNAME} ssip
+INFO= spd-say speech-dispatcher ssip
-OPTIONS= ALSA "ALSA support" off \
- ESPEAK "eSpeak output module" on \
- FESTIVAL "Festival output module" off \
- FLITE "Festival Lite output module" off \
- LIBAO "libao support" off \
- NAS "Network Audio System support" off \
- PULSEAUDIO "PulseAudio support" off \
- PYTHON "Python support" off
+OPTIONS_DEFINE= ALSA AO ESPEAK FESTIVAL FLITE NAS PULSEAUDIO PYTHON
+OPTIONS_DEFAULT=ESPEAK
+
+ESPEAK_DESC= eSpeak output module
+FESTIVAL_DESC= Festival output module
+FLITE_DESC= Festival Lite output module
.include <bsd.port.options.mk>
@@ -57,64 +51,64 @@ OPTIONS= ALSA "ALSA support" off \
CFLAGS+= -fPIC
.endif
-.ifdef(WITH_ALSA)
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
-CONFIGURE_ARGS+= --with-alsa
+.if ${PORT_OPTIONS:MALSA}
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
+CONFIGURE_ARGS+=--with-alsa
+.else
+CONFIGURE_ARGS+=--without-alsa
+.endif
+
+.if ${PORT_OPTIONS:MAO}
+LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
+CONFIGURE_ARGS+=--with-libao
.else
-CONFIGURE_ARGS+= --without-alsa
+CONFIGURE_ARGS+=--without-libao
.endif
-.ifndef(WITHOUT_ESPEAK)
-LIB_DEPENDS+= espeak.1:${PORTSDIR}/audio/espeak
-CONFIGURE_ARGS+= --with-espeak
+.if ${PORT_OPTIONS:MESPEAK}
+LIB_DEPENDS+= espeak:${PORTSDIR}/audio/espeak
+CONFIGURE_ARGS+=--with-espeak
PLIST_SUB+= ESPEAK=""
.else
-CONFIGURE_ARGS+= --without-espeak
+CONFIGURE_ARGS+=--without-espeak
PLIST_SUB+= ESPEAK="@comment "
.endif
-.ifdef(WITH_FESTIVAL)
+.if ${PORT_OPTIONS:MFESTIVAL}
RUN_DEPENDS+= festival:${PORTSDIR}/audio/festival \
${LOCALBASE}/share/festival/lib/${PORTNAME}.scm:${PORTSDIR}/audio/festival-freebsoft-utils
.endif
-.ifdef(WITH_FLITE)
+.if ${PORT_OPTIONS:MFLITE}
BUILD_DEPENDS+= flite:${PORTSDIR}/audio/flite
RUN_DEPENDS+= flite:${PORTSDIR}/audio/flite
-CONFIGURE_ARGS+= --with-flite
+CONFIGURE_ARGS+=--with-flite
PLIST_SUB+= FLITE=""
.else
-CONFIGURE_ARGS+= --without-flite
+CONFIGURE_ARGS+=--without-flite
PLIST_SUB+= FLITE="@comment "
.endif
-.ifdef(WITH_LIBAO)
-LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
-CONFIGURE_ARGS+= --with-libao
-.else
-CONFIGURE_ARGS+= --without-libao
-.endif
-
-.ifdef(WITH_NAS)
-LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
-CONFIGURE_ARGS+= --with-nas
+.if ${PORT_OPTIONS:MNAS}
+LIB_DEPENDS+= audio:${PORTSDIR}/audio/nas
+CONFIGURE_ARGS+=--with-nas
.else
-CONFIGURE_ARGS+= --without-nas
+CONFIGURE_ARGS+=--without-nas
.endif
-.if defined(WITH_PULSEAUDIO) && ${OSVERSION} >= 700041
-LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
-CONFIGURE_ARGS+= --with-pulse
+.if ${PORT_OPTIONS:MPULSEAUDIO}
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
+CONFIGURE_ARGS+=--with-pulse
.else
-CONFIGURE_ARGS+= --without-pulse
+CONFIGURE_ARGS+=--without-pulse
.endif
-.ifdef(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= 2.5+
-CONFIGURE_ARGS+= --enable-python
+CONFIGURE_ARGS+=--enable-python
PLIST_SUB+= PYTHON=""
.else
-CONFIGURE_ARGS+= --disable-python
+CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
@@ -137,7 +131,7 @@ post-install:
${CP} -p ${ETCDIR}/${f}.sample ${ETCDIR}/${f}; \
fi
.endfor
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/comms/usbmuxd/Makefile b/comms/usbmuxd/Makefile
index a14557e2d64c..d12b9e0be041 100644
--- a/comms/usbmuxd/Makefile
+++ b/comms/usbmuxd/Makefile
@@ -1,7 +1,3 @@
-# New ports collection makefile for: usbmuxd
-# Date created: 10 June 2010
-# Whom: Alberto Villa <avilla@FreeBSD.org>
-#
# $FreeBSD$
PORTNAME= usbmuxd
@@ -13,7 +9,7 @@ MASTER_SITES= http://www.libimobiledevice.org/downloads/
MAINTAINER= avilla@FreeBSD.org
COMMENT= Daemon for multiplexing connections over USB to an iPhone/iPod Touch
-LIB_DEPENDS= plist.1:${PORTSDIR}/devel/libplist
+LIB_DEPENDS= plist:${PORTSDIR}/devel/libplist
USE_BZIP2= yes
USE_CMAKE= yes
@@ -22,12 +18,14 @@ USE_LDCONFIG= yes
PORTDOCS= AUTHORS README README.devel
-OPTIONS= INOTIFY "Use inotify instead of polling (saves energy)" off
+OPTIONS_DEFINE= INOTIFY
+
+INOTIFY_DESC= Use inotify instead of polling (saves energy)
.include <bsd.port.options.mk>
-.ifdef(WITH_INOTIFY)
-LIB_DEPENDS+= inotify.0:${PORTSDIR}/devel/libinotify
+.if ${PORT_OPTIONS:MINOTIFY}
+LIB_DEPENDS+= inotify:${PORTSDIR}/devel/libinotify
.else
CMAKE_ARGS+= -DWANT_INOTIFY:BOOL=FALSE
.endif
@@ -50,7 +48,7 @@ post-install:
${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/python-client/*.py \
${DATADIR}/
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/devel/libplist/Makefile b/devel/libplist/Makefile
index 07bcd6ba91ce..84f6ce1c15eb 100644
--- a/devel/libplist/Makefile
+++ b/devel/libplist/Makefile
@@ -1,7 +1,3 @@
-# New ports collection makefile for: libplist
-# Date created: 28 May 2010
-# Whom: Alberto Villa <avilla@FreeBSD.org>
-#
# $FreeBSD$
PORTNAME= libplist
@@ -10,10 +6,9 @@ CATEGORIES= devel
MASTER_SITES= http://www.libimobiledevice.org/downloads/
MAINTAINER= avilla@FreeBSD.org
-COMMENT= A library to handle Apple Property List format
+COMMENT= Library to handle Apple Property List format
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
USE_GNOME= libxml2
# Unlisted dependency.
@@ -27,24 +22,24 @@ USE_LDCONFIG= ${LOCALBASE}/lib
PORTDOCS= AUTHORS NEWS README
-OPTIONS= CYTHON "Enable Cython Python bindings" off \
- SWIG "Enable Swig Python bindings" off
+OPTIONS_DEFINE= CYTHON SWIG
+
+CYTHON_DESC= Cython Python bindings
+SWIG_DESC= Swig Python bindings
.include <bsd.port.options.mk>
-.ifdef(WITH_CYTHON)
+.if ${PORT_OPTIONS:MCYTHON}
BUILD_DEPENDS+= cython:${PORTSDIR}/lang/cython
USE_PYTHON= yes
CMAKE_ARGS+= -DENABLE_CYTHON:BOOL=On
-# Is this really needed?
-USE_LDCONFIG+= ${PYTHON_SITELIBDIR}
PLIST_SUB+= CYTHON=""
.else
CMAKE_ARGS+= -DENABLE_CYTHON:BOOL=Off
PLIST_SUB+= CYTHON="@comment "
.endif
-.ifdef(WITH_SWIG)
+.if ${PORT_OPTIONS:MSWIG}
BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
USE_PYTHON= yes
CMAKE_ARGS+= -DENABLE_SWIG:BOOL=On
@@ -59,7 +54,7 @@ pre-configure:
${WRKSRC}/CMakeLists.txt
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/graphics/opengtl/Makefile b/graphics/opengtl/Makefile
index 1d7337cb464e..f00f1371da27 100644
--- a/graphics/opengtl/Makefile
+++ b/graphics/opengtl/Makefile
@@ -1,7 +1,3 @@
-# New ports collection makefile for: opengtl
-# Date created: 28 September 2009
-# Whom: Alberto Villa <villa.alberto@gmail.com>
-#
# $FreeBSD$
PORTNAME= opengtl
@@ -14,12 +10,9 @@ MAINTAINER= avilla@FreeBSD.org
COMMENT= Graphics Transformation Languages
LICENSE= LGPL20
-LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-
BUILD_DEPENDS= ${LOCALBASE}/lib/libLLVM-3.1.so:${PORTSDIR}/devel/llvm
-
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= yes
@@ -28,13 +21,16 @@ USE_CMAKE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-OPTIONS= SHIVA "Install filters and generators" on
+OPTIONS_DEFINE= SHIVA
+OPTIONS_DEFAULT=SHIVA
+
+SHIVA_DESC= Install filters and generators
PLIST_SUB+= PORTVERSION=${PORTVERSION}
.include <bsd.port.options.mk>
-.ifndef(WITHOUT_SHIVA)
+.if ${PORT_OPTIONS:MSHIVA}
RUN_DEPENDS+= ${LOCALBASE}/share/OpenGTL/shiva/kernels/oilify.shiva:${PORTSDIR}/graphics/shiva-collections
.endif